summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Orlitzky <mjo@gentoo.org>2022-06-15 08:03:18 -0400
committerMichael Orlitzky <mjo@gentoo.org>2022-06-15 08:13:20 -0400
commit6fd43ab4062e470d8222dcc577a035e9bb8f0d9b (patch)
tree92b43643155e0ae7611c5354ade81c1ef30d5608 /net-mail/postfix-logwatch
parentdev-db/sqlite: add 9999 (diff)
downloadgentoo-6fd43ab4062e470d8222dcc577a035e9bb8f0d9b.tar.gz
gentoo-6fd43ab4062e470d8222dcc577a035e9bb8f0d9b.tar.bz2
gentoo-6fd43ab4062e470d8222dcc577a035e9bb8f0d9b.zip
net-mail/postfix-logwatch: new upstream v1.40.05.
Package-Manager: Portage-3.0.30, Repoman-3.0.3 Signed-off-by: Michael Orlitzky <mjo@gentoo.org>
Diffstat (limited to 'net-mail/postfix-logwatch')
-rw-r--r--net-mail/postfix-logwatch/Manifest1
-rw-r--r--net-mail/postfix-logwatch/postfix-logwatch-1.40.05.ebuild31
2 files changed, 32 insertions, 0 deletions
diff --git a/net-mail/postfix-logwatch/Manifest b/net-mail/postfix-logwatch/Manifest
index dcdbf05f981c..51c32dfc4bad 100644
--- a/net-mail/postfix-logwatch/Manifest
+++ b/net-mail/postfix-logwatch/Manifest
@@ -1 +1,2 @@
DIST postfix-logwatch-1.40.04.tar.xz 78996 BLAKE2B fea2a08a7bc776cf0106a60bc0f86730c562d6c893629a1028183150a246803bda8ada6a5ec7e264685fe40016b82ce4140031af7e508ac4b1d9a34e552b865d SHA512 194917fe4d05e9808893da0c175859e932d5e48956d1dda96129dd5de7f9ee23131ae1831b558c8c2d32d03ffda80aa95cfd5048543b7766a0486a71efa6c19b
+DIST postfix-logwatch-1.40.05.tar.xz 79504 BLAKE2B 5d45a43ef2206b77092a90cd463a1718fada286fdd499df4416739aea7246c79b0670503585e7e057174ac715986767e3a72974d9790f33a2cd251221d883687 SHA512 15ba438701be110ce75c59bb6803cbb308bd53876428b01a457f42b3fb12e565c9b0c2d4559d71451475ec4986fccfc9f06854760035b4653c72508b968d5a0d
diff --git a/net-mail/postfix-logwatch/postfix-logwatch-1.40.05.ebuild b/net-mail/postfix-logwatch/postfix-logwatch-1.40.05.ebuild
new file mode 100644
index 000000000000..dc661eb713af
--- /dev/null
+++ b/net-mail/postfix-logwatch/postfix-logwatch-1.40.05.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DESCRIPTION="A log analyzer for postfix"
+HOMEPAGE="http://michael.orlitzky.com/code/postfix-logwatch.xhtml"
+SRC_URI="http://michael.orlitzky.com/code/releases/${P}.tar.xz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="dev-lang/perl"
+
+src_prepare() {
+ default
+ # Replace the default config file location with ours.
+ local cfg_default='/usr/local/etc/${progname_prefix}-logwatch.conf'
+ local cfg_gentoo='/etc/${progname_prefix}-logwatch.conf';
+ sed -i "s~${cfg_default}~${cfg_gentoo}~" ${PN} \
+ || die 'failed to update the default config location'
+}
+
+src_install() {
+ dodoc Bugs Changes README ${PN}.conf-topn
+ doman ${PN}.1
+ dobin ${PN}
+ insinto /etc
+ doins ${PN}.conf
+}