summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /net-mail/qmail-autoresponder
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'net-mail/qmail-autoresponder')
-rw-r--r--net-mail/qmail-autoresponder/Manifest1
-rw-r--r--net-mail/qmail-autoresponder/files/qmail-autoresponder-0.97-remove-mysql.h.diff8
-rw-r--r--net-mail/qmail-autoresponder/metadata.xml12
-rw-r--r--net-mail/qmail-autoresponder/qmail-autoresponder-0.97-r1.ebuild58
-rw-r--r--net-mail/qmail-autoresponder/qmail-autoresponder-0.97-r2.ebuild58
5 files changed, 137 insertions, 0 deletions
diff --git a/net-mail/qmail-autoresponder/Manifest b/net-mail/qmail-autoresponder/Manifest
new file mode 100644
index 000000000000..ffa10c33ac5a
--- /dev/null
+++ b/net-mail/qmail-autoresponder/Manifest
@@ -0,0 +1 @@
+DIST qmail-autoresponder-0.97.tar.gz 28158 SHA256 445a36f10dd4c0af3608c9d546f3b2aad48870bffe35db31ea5dcb857abf699c
diff --git a/net-mail/qmail-autoresponder/files/qmail-autoresponder-0.97-remove-mysql.h.diff b/net-mail/qmail-autoresponder/files/qmail-autoresponder-0.97-remove-mysql.h.diff
new file mode 100644
index 000000000000..be33e047b16a
--- /dev/null
+++ b/net-mail/qmail-autoresponder/files/qmail-autoresponder-0.97-remove-mysql.h.diff
@@ -0,0 +1,8 @@
+diff -Naur qmail-autoresponder-0.97.orig/options.c qmail-autoresponder-0.97/options.c
+--- qmail-autoresponder-0.97.orig/options.c 2009-09-26 22:45:17.000000000 +0200
++++ qmail-autoresponder-0.97/options.c 2009-09-26 22:46:07.000000000 +0200
+@@ -1,4 +1,3 @@
+-#include <mysql/mysql.h>
+ #include <stdlib.h>
+ #include <string.h>
+ #include <str/str.h>
diff --git a/net-mail/qmail-autoresponder/metadata.xml b/net-mail/qmail-autoresponder/metadata.xml
new file mode 100644
index 000000000000..60cac0fceab8
--- /dev/null
+++ b/net-mail/qmail-autoresponder/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>qmail</herd>
+<longdescription lang="en">
+This is a simple program to automatically respond to emails.
+
+It is based on some ideas (but little or no code) from a similar
+autoresponder by Eric Huss, and ideas presented
+on the qmail mailing list.
+</longdescription>
+</pkgmetadata>
diff --git a/net-mail/qmail-autoresponder/qmail-autoresponder-0.97-r1.ebuild b/net-mail/qmail-autoresponder/qmail-autoresponder-0.97-r1.ebuild
new file mode 100644
index 000000000000..85c3cdbc3c71
--- /dev/null
+++ b/net-mail/qmail-autoresponder/qmail-autoresponder-0.97-r1.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="2"
+
+inherit toolchain-funcs eutils
+
+DESCRIPTION="Rate-limited autoresponder for qmail"
+HOMEPAGE="http://untroubled.org/qmail-autoresponder/"
+SRC_URI="http://untroubled.org/qmail-autoresponder/archive/${P}.tar.gz"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="alpha amd64 hppa ~mips ppc sparc x86"
+IUSE="mysql"
+
+DEPEND=">=dev-libs/bglibs-1.022
+ mysql? ( virtual/mysql )"
+RDEPEND="
+ ${DEPEND}
+ virtual/qmail
+ mysql? ( virtual/mysql )
+"
+
+src_prepare() {
+ use mysql || epatch "${FILESDIR}/${PN}-0.97-remove-mysql.h.diff"
+}
+
+src_configure() {
+ echo "/usr/include/bglibs" > conf-bgincs
+ echo "/usr/lib/bglibs" > conf-bglibs
+ echo "$(tc-getCC) ${CFLAGS}" > conf-cc
+ echo "$(tc-getCC) ${LDFLAGS}" > conf-ld
+}
+
+src_compile() {
+ # fails on parallel builds!
+ make qmail-autoresponder || die "Failed to make qmail-autoresponder"
+ if use mysql; then
+ make qmail-autoresponder-mysql || die "Failed to make qmail-autoresponder-mysql"
+ fi
+}
+
+src_install () {
+ dobin qmail-autoresponder || die
+ doman qmail-autoresponder.1
+ if use mysql; then
+ dobin qmail-autoresponder-mysql || die
+ dodoc schema.mysql
+ fi
+
+ dodoc ANNOUNCEMENT NEWS README TODO ChangeLog procedure.txt
+}
+
+pkg_postinst() {
+ elog "Please see the README file in /usr/share/doc/${PF}/ for per-user configurations."
+}
diff --git a/net-mail/qmail-autoresponder/qmail-autoresponder-0.97-r2.ebuild b/net-mail/qmail-autoresponder/qmail-autoresponder-0.97-r2.ebuild
new file mode 100644
index 000000000000..1f42f3457956
--- /dev/null
+++ b/net-mail/qmail-autoresponder/qmail-autoresponder-0.97-r2.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="2"
+
+inherit toolchain-funcs eutils multilib
+
+DESCRIPTION="Rate-limited autoresponder for qmail"
+HOMEPAGE="http://untroubled.org/qmail-autoresponder/"
+SRC_URI="http://untroubled.org/qmail-autoresponder/archive/${P}.tar.gz"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~alpha ~amd64 ~hppa ~mips ~ppc ~sparc ~x86"
+IUSE="mysql"
+
+DEPEND=">=dev-libs/bglibs-1.106
+ mysql? ( virtual/mysql )"
+RDEPEND="
+ ${DEPEND}
+ virtual/qmail
+ mysql? ( virtual/mysql )
+"
+
+src_prepare() {
+ use mysql || epatch "${FILESDIR}/${PN}-0.97-remove-mysql.h.diff"
+}
+
+src_configure() {
+ echo "/usr/include/bglibs" > conf-bgincs
+ echo "/usr/$(get_libdir)/bglibs" > conf-bglibs
+ echo "$(tc-getCC) ${CFLAGS}" > conf-cc
+ echo "$(tc-getCC) ${LDFLAGS}" > conf-ld
+}
+
+src_compile() {
+ # fails on parallel builds!
+ make qmail-autoresponder || die "Failed to make qmail-autoresponder"
+ if use mysql; then
+ make qmail-autoresponder-mysql || die "Failed to make qmail-autoresponder-mysql"
+ fi
+}
+
+src_install () {
+ dobin qmail-autoresponder || die
+ doman qmail-autoresponder.1
+ if use mysql; then
+ dobin qmail-autoresponder-mysql || die
+ dodoc schema.mysql
+ fi
+
+ dodoc ANNOUNCEMENT NEWS README TODO ChangeLog procedure.txt
+}
+
+pkg_postinst() {
+ elog "Please see the README file in /usr/share/doc/${PF}/ for per-user configurations."
+}