summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Mair-Keimberger <mmk@levelnine.at>2024-02-06 19:31:45 +0100
committerConrad Kostecki <conikost@gentoo.org>2024-03-16 13:13:27 +0100
commita25387739f03c8fba1caf9a91cc220c35793b989 (patch)
tree86e20cde90f8cd80aa94935ad6d18d19c26e5f52 /net-mail/randomsig
parentnet-mail/nmzmail: EAPI8 bump, fix SRC_URI, HOMEPAGE (diff)
downloadgentoo-a25387739f03c8fba1caf9a91cc220c35793b989.tar.gz
gentoo-a25387739f03c8fba1caf9a91cc220c35793b989.tar.bz2
gentoo-a25387739f03c8fba1caf9a91cc220c35793b989.zip
net-mail/randomsig: EAPI8 bump, use HTTPS, fix LICENSE
Signed-off-by: Michael Mair-Keimberger <mmk@levelnine.at> Closes: https://github.com/gentoo/gentoo/pull/35203 Signed-off-by: Conrad Kostecki <conikost@gentoo.org>
Diffstat (limited to 'net-mail/randomsig')
-rw-r--r--net-mail/randomsig/randomsig-1.10.0-r1.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/net-mail/randomsig/randomsig-1.10.0-r1.ebuild b/net-mail/randomsig/randomsig-1.10.0-r1.ebuild
new file mode 100644
index 000000000000..433e05933e0f
--- /dev/null
+++ b/net-mail/randomsig/randomsig-1.10.0-r1.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+MY_P="${PN}-v${PV}"
+
+DESCRIPTION="Perl script for generating random .signature files"
+HOMEPAGE="https://suso.suso.org/xulu/Randomsig"
+SRC_URI="https://suso.suso.org/programs/randomsig/downloads/${MY_P}.tar.gz"
+S="${WORKDIR}/${MY_P}"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~s390 ~sparc ~x86"
+
+RDEPEND="dev-lang/perl"
+DEPEND="${RDEPEND}"
+
+src_prepare() {
+ default
+
+ sed -e "s:/usr/local/bin:${EPREFIX}/usr/bin:" \
+ -e "s:/usr/local/etc:${EPREFIX}/etc:" \
+ -i Makefile || die
+ sed -e "s:/usr/local/etc:${EPREFIX}/etc:" \
+ -i randomsig || die
+}
+
+src_install() {
+ dobin randomsig
+ einstalldocs
+
+ insinto /etc/randomsig
+ doins .randomsigrc .sigquotes .sigcancel .sigread
+}