summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSebastian Pipping <sping@gentoo.org>2020-08-02 20:41:25 +0200
committerSebastian Pipping <sping@gentoo.org>2020-08-02 20:44:55 +0200
commit99d19219f0ef2d9b95e307ff952bc2412765afa8 (patch)
treef7ae5ef2223ffd8e6baa956a5e82b68f36e18fab /net-mail/rss2email/rss2email-3.12.1.ebuild
parentsys-apps/pmount: adopting. (diff)
downloadgentoo-99d19219f0ef2d9b95e307ff952bc2412765afa8.tar.gz
gentoo-99d19219f0ef2d9b95e307ff952bc2412765afa8.tar.bz2
gentoo-99d19219f0ef2d9b95e307ff952bc2412765afa8.zip
net-mail/rss2email: 3.12.1
Signed-off-by: Sebastian Pipping <sping@gentoo.org> Package-Manager: Portage-3.0.0, Repoman-2.3.23
Diffstat (limited to 'net-mail/rss2email/rss2email-3.12.1.ebuild')
-rw-r--r--net-mail/rss2email/rss2email-3.12.1.ebuild27
1 files changed, 27 insertions, 0 deletions
diff --git a/net-mail/rss2email/rss2email-3.12.1.ebuild b/net-mail/rss2email/rss2email-3.12.1.ebuild
new file mode 100644
index 000000000000..0d679cf6d547
--- /dev/null
+++ b/net-mail/rss2email/rss2email-3.12.1.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6,7,8} )
+
+inherit distutils-r1
+
+DESCRIPTION="A python script that converts RSS/Atom newsfeeds to email"
+HOMEPAGE="https://github.com/rss2email/rss2email"
+SRC_URI="https://github.com/rss2email/rss2email/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="|| ( GPL-2 GPL-3 )"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="<dev-python/feedparser-6[${PYTHON_USEDEP}]
+ >=dev-python/html2text-3.01[${PYTHON_USEDEP}]
+ dev-python/setuptools[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}"
+
+src_install() {
+ distutils-r1_src_install
+ doman r2e.1
+}