summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /net-mail/uw-imap/files
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'net-mail/uw-imap/files')
-rw-r--r--net-mail/uw-imap/files/uw-imap-2004c-amd64-so-fix.patch13
-rw-r--r--net-mail/uw-imap/files/uw-imap-ldflags.patch52
-rw-r--r--net-mail/uw-imap/files/uw-imap.xinetd15
-rw-r--r--net-mail/uw-imap/files/uw-imaps.xinetd16
-rw-r--r--net-mail/uw-imap/files/uw-ipop2.xinetd16
-rw-r--r--net-mail/uw-imap/files/uw-ipop3.xinetd15
-rw-r--r--net-mail/uw-imap/files/uw-ipop3s.xinetd15
7 files changed, 142 insertions, 0 deletions
diff --git a/net-mail/uw-imap/files/uw-imap-2004c-amd64-so-fix.patch b/net-mail/uw-imap/files/uw-imap-2004c-amd64-so-fix.patch
new file mode 100644
index 000000000000..1400fc254c6d
--- /dev/null
+++ b/net-mail/uw-imap/files/uw-imap-2004c-amd64-so-fix.patch
@@ -0,0 +1,13 @@
+diff -ruN src/osdep/unix/Makefile src/osdep/unix/Makefile
+--- src/osdep/unix/Makefile 2005-01-29 22:43:25.739341544 +0000
++++ src/osdep/unix/Makefile 2005-01-29 22:43:50.375596264 +0000
+@@ -912,6 +912,9 @@
+ -DRSHPATH=\"$(RSHPATH)\" -DLOCKPGM=\"$(LOCKPGM)\" > OSCFLAGS
+ echo $(BASELDFLAGS) $(EXTRALDFLAGS) > LDFLAGS
+ echo "$(ARRC) $(ARCHIVE) $(BINARIES);$(RANLIB) $(ARCHIVE)" > ARCHIVE
++ echo "`$(CAT) CCTYPE` `$(CAT) CFLAGS` `$(CAT) OSFLAGS` -shared \
++ -Wl,-soname,libc-client.so.1 -o libc-client.so.1.0.0 $(BINARIES)" \
++ >> ARCHIVE
+ echo $(OS) > OSTYPE
+ ./drivers $(EXTRADRIVERS) $(DEFAULTDRIVERS) dummy
+ ./mkauths $(EXTRAAUTHENTICATORS) $(DEFAULTAUTHENTICATORS)
diff --git a/net-mail/uw-imap/files/uw-imap-ldflags.patch b/net-mail/uw-imap/files/uw-imap-ldflags.patch
new file mode 100644
index 000000000000..41bd0925ed14
--- /dev/null
+++ b/net-mail/uw-imap/files/uw-imap-ldflags.patch
@@ -0,0 +1,52 @@
+diff --git a/Makefile b/Makefile
+index e6e4987..8acfe23 100644
+--- a/Makefile
++++ b/Makefile
+@@ -257,7 +257,7 @@ EXTRACFLAGS=
+
+ # Extra linker flags (additional/alternative libraries, etc.)
+
+-EXTRALDFLAGS=
++EXTRALDFLAGS=${LDFLAGS}
+
+
+ # Special make flags (e.g. to override make environment variables)
+diff --git a/src/mlock/Makefile b/src/mlock/Makefile
+index d425da8..9c3020b 100644
+--- a/src/mlock/Makefile
++++ b/src/mlock/Makefile
+@@ -36,7 +36,7 @@ CFLAGS = -O2 -pipe -march=core2
+ all: mlock
+
+ mlock: mlock.o
+- $(CC) $(CFLAGS) -o mlock mlock.o
++ $(CC) $(CFLAGS) ${LDFLAGS} -o mlock mlock.o
+
+ install: mlock
+ chgrp mail mlock
+diff --git a/Makefile b/Makefile
+index 8acfe23..70f889d 100644
+--- a/Makefile
++++ b/Makefile
+@@ -698,7 +698,7 @@ rebuild:
+ @echo Rebuilding c-client for `$(CAT) OSTYPE`...
+ @$(TOUCH) SPECIALS
+ $(CD) c-client;$(MAKE) all CC=`$(CAT) CCTYPE` \
+- CFLAGS="`$(CAT) CFLAGS`" `$(CAT) SPECIALS`
++ CFLAGS="`$(CAT) CFLAGS`" LDFLAGS=${LDFLAGS} `$(CAT) SPECIALS`
+
+ rebuildclean:
+ $(SH) -c '$(RM) rebuild || true'
+diff --git a/src/osdep/unix/Makefile b/src/osdep/unix/Makefile
+index ef1d059..a53318c 100644
+--- a/src/osdep/unix/Makefile
++++ b/src/osdep/unix/Makefile
+@@ -969,7 +969,7 @@ onceenv:
+ -DLOCKPGM3=\"$(LOCKPGM3)\" > OSCFLAGS
+ echo $(BASELDFLAGS) $(EXTRALDFLAGS) > LDFLAGS
+ echo "$(ARRC) $(ARCHIVE) $(BINARIES);$(RANLIB) $(ARCHIVE)" > ARCHIVE
+- echo "`$(CAT) CCTYPE` `$(CAT) CFLAGS` `$(CAT) OSFLAGS` -shared \
++ echo "`$(CAT) CCTYPE` `$(CAT) CFLAGS` `$(CAT) OSFLAGS` `$(CAT) LDFLAGS` -shared \
+ -Wl,-soname,libc-client.so.1 -o libc-client.so.1.0.0 $(BINARIES)" \
+ >> ARCHIVE
+ echo $(OS) > OSTYPE
diff --git a/net-mail/uw-imap/files/uw-imap.xinetd b/net-mail/uw-imap/files/uw-imap.xinetd
new file mode 100644
index 000000000000..213c505f2f9f
--- /dev/null
+++ b/net-mail/uw-imap/files/uw-imap.xinetd
@@ -0,0 +1,15 @@
+# default: off
+# $Id$
+# description: The IMAP service allows remote users to access their mail using \
+# an IMAP client such as Mutt, Pine, fetchmail, or Netscape \
+# Communicator.
+service imap2
+{
+ socket_type = stream
+ wait = no
+ user = root
+ server = /usr/sbin/imapd
+ log_on_success += DURATION USERID
+ log_on_failure += USERID
+ disable = yes
+}
diff --git a/net-mail/uw-imap/files/uw-imaps.xinetd b/net-mail/uw-imap/files/uw-imaps.xinetd
new file mode 100644
index 000000000000..e8cf04b03151
--- /dev/null
+++ b/net-mail/uw-imap/files/uw-imaps.xinetd
@@ -0,0 +1,16 @@
+# default: off
+# $Id$
+# description: The IMAPS service allows remote users to access their mail \
+# using an IMAP client with SSL support such as Netscape \
+# Communicator or fetchmail.
+service imaps
+{
+ socket_type = stream
+ wait = no
+ user = root
+ server = /usr/sbin/imapd
+ log_on_success += DURATION USERID
+ log_on_failure += USERID
+ disable = yes
+}
+
diff --git a/net-mail/uw-imap/files/uw-ipop2.xinetd b/net-mail/uw-imap/files/uw-ipop2.xinetd
new file mode 100644
index 000000000000..8e0d85b622b9
--- /dev/null
+++ b/net-mail/uw-imap/files/uw-ipop2.xinetd
@@ -0,0 +1,16 @@
+# default: off
+# $Id$
+# description: The POP2 service allows remote users to access their mail \
+# using an POP2 client such as fetchmail. In most cases, clients \
+# support POP3 instead of POP2, so enabling this service is rarely \
+# necessary.
+service pop-2
+{
+ socket_type = stream
+ wait = no
+ user = root
+ server = /usr/sbin/ipop2d
+ log_on_success += USERID
+ log_on_failure += USERID
+ disable = yes
+}
diff --git a/net-mail/uw-imap/files/uw-ipop3.xinetd b/net-mail/uw-imap/files/uw-ipop3.xinetd
new file mode 100644
index 000000000000..f06482767942
--- /dev/null
+++ b/net-mail/uw-imap/files/uw-ipop3.xinetd
@@ -0,0 +1,15 @@
+# default: off
+# $Id$
+# description: The POP3 service allows remote users to access their mail \
+# using an POP3 client such as Netscape Communicator, mutt, \
+# or fetchmail.
+service pop-3
+{
+ socket_type = stream
+ wait = no
+ user = root
+ server = /usr/sbin/ipop3d
+ log_on_success += USERID
+ log_on_failure += USERID
+ disable = yes
+}
diff --git a/net-mail/uw-imap/files/uw-ipop3s.xinetd b/net-mail/uw-imap/files/uw-ipop3s.xinetd
new file mode 100644
index 000000000000..1ca3f1922c1b
--- /dev/null
+++ b/net-mail/uw-imap/files/uw-ipop3s.xinetd
@@ -0,0 +1,15 @@
+# default: off
+# $Id$
+# description: The POP3 service allows remote users to access their mail \
+# using an POP3 client such as Netscape Communicator, mutt, \
+# or fetchmail.
+service pop3s
+{
+ socket_type = stream
+ wait = no
+ user = root
+ server = /usr/sbin/ipop3d
+ log_on_success += USERID
+ log_on_failure += USERID
+ disable = yes
+}