summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLars Wendler <polynomial-c@gentoo.org>2021-09-20 16:21:28 +0200
committerLars Wendler <polynomial-c@gentoo.org>2021-09-20 16:21:42 +0200
commitba52d365d7a5c9e48b2911010cd26546896ba4ff (patch)
tree5beca4ee46899101cf2fe91cc7eddc02764cf1c0 /net-mail/ytnef/ytnef-2.0.ebuild
parentapp-misc/resolve-march-native: py3.10 + DISTUTILS_USE_SETUPTOOLS (diff)
downloadgentoo-ba52d365d7a5c9e48b2911010cd26546896ba4ff.tar.gz
gentoo-ba52d365d7a5c9e48b2911010cd26546896ba4ff.tar.bz2
gentoo-ba52d365d7a5c9e48b2911010cd26546896ba4ff.zip
net-mail/ytnef: Bump to version 2.0
Bug: https://bugs.gentoo.org/774255 Signed-off-by: Lars Wendler <polynomial-c@gentoo.org>
Diffstat (limited to 'net-mail/ytnef/ytnef-2.0.ebuild')
-rw-r--r--net-mail/ytnef/ytnef-2.0.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/net-mail/ytnef/ytnef-2.0.ebuild b/net-mail/ytnef/ytnef-2.0.ebuild
new file mode 100644
index 000000000000..0ba15afddf97
--- /dev/null
+++ b/net-mail/ytnef/ytnef-2.0.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit autotools
+
+DESCRIPTION="Yeraze's TNEF Stream Reader - for winmail.dat files"
+HOMEPAGE="https://github.com/Yeraze/ytnef"
+SRC_URI="https://github.com/Yeraze/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ppc ~ppc64 ~sparc ~x86"
+IUSE="static-libs"
+
+DEPEND="sys-devel/libtool"
+RDEPEND="dev-perl/MIME-tools"
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+src_configure() {
+ econf $(use_enable static-libs static)
+}
+
+src_install() {
+ default
+ find "${ED}" -name "*.la" -delete || die
+}