summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Harder <radhermit@gentoo.org>2016-01-14 15:18:07 -0500
committerTim Harder <radhermit@gentoo.org>2016-01-14 17:10:07 -0500
commit07da1383cf65ca3d60366580677c08c89bafa124 (patch)
tree8d33be623e1ee065db3c5e0f4b344e09b83f5173 /net-mail
parentnet-mail/getmail: version bump to 4.49.0 (diff)
downloadgentoo-07da1383cf65ca3d60366580677c08c89bafa124.tar.gz
gentoo-07da1383cf65ca3d60366580677c08c89bafa124.tar.bz2
gentoo-07da1383cf65ca3d60366580677c08c89bafa124.zip
net-mail/libpst: version bump to 0.6.66
Diffstat (limited to 'net-mail')
-rw-r--r--net-mail/libpst/Manifest1
-rw-r--r--net-mail/libpst/libpst-0.6.66.ebuild63
-rw-r--r--net-mail/libpst/metadata.xml2
3 files changed, 65 insertions, 1 deletions
diff --git a/net-mail/libpst/Manifest b/net-mail/libpst/Manifest
index cb48fe25a483..80fe50c7968d 100644
--- a/net-mail/libpst/Manifest
+++ b/net-mail/libpst/Manifest
@@ -5,3 +5,4 @@ DIST libpst-0.6.60.tar.gz 13851530 SHA256 dc31bb66020ce5f4cfee9d195b37172423614c
DIST libpst-0.6.61.tar.gz 13852925 SHA256 aad27d0097aa7359b7a839894345fb77f0e22fbac8d5ec0e96fc8ed2f738806e SHA512 46c9a685ba87bd3057754c8dd427230e747d01f42f076b9851cd2ff06e48defb98adaa44c7a905aa6e803daa22057f7f78ca0bc47375a7a5999281ea2365af03 WHIRLPOOL e05a6774ec1a3bf94e1b7fe80b061f4e9cc6a96a1d2a5a216f8a1413b9f4b667ce9c6bef5d5830f98d9132ce3eee7c02d96585491e0717d95c9cbb3ef0d8256a
DIST libpst-0.6.63.tar.gz 13853290 SHA256 5f522606fb7b97d6e31bc2490dcce77b89ec77e12ade4af4551290f953483062 SHA512 1d45f3a19851e25b8af495c3ceeee34b74c4d14d4a9a723dcf63c009b38e5bcbc4cdb3219d136c234a85992f2d96a74b6069ad5b6cc8eed1963dfd6f7c46e836 WHIRLPOOL 19cac49b72d0fdd787105ffdadf6d8503735b21d1d6f615de4ffa0cdc4d8cb6f50010399a05bc2a101d08268ff25928eb11ece69d774dd2acc2625bf18ad4295
DIST libpst-0.6.64.tar.gz 13861215 SHA256 13c4f26f422b571c08ec5f602d878527606a435408724b1bf90a11e31dc17fe3 SHA512 28f5ca83c4ede616b2d4d8dfd074a6866932a08594419aa7bb2af49f7871b4c92d97e0a583d8e2ef3be88a26c1a98c10ce9b1c0498073b528b6810d75988ee4a WHIRLPOOL 3f8c264cb1e9cf36992d453d5568af3fe195aef9f67fea529c50f8de71ba6b49e37b9bb95b817e34210f680b87682daaef121540bf5bd2d4388304f37c9dad46
+DIST libpst-0.6.66.tar.gz 13836942 SHA256 92b49939d821091d9d25e27e17c78dbb867f3f9ab5b8f43e2b01ace0677e1f72 SHA512 0d07b13554b9e009787ce651714281d21a4d38afae997bd87244690538bd18176ab74655c0a0646b1c475c916052d4295ffe749e6a03765450af7e9c8443dd86 WHIRLPOOL 32c59f618013a2f1799b880eb3231d668412e22b1292cd5d4c026ca12e23c2133304f6ec3bd67ea22ec3622b5f32028d54fbaebd6e1d1d788284eecc1a29252f
diff --git a/net-mail/libpst/libpst-0.6.66.ebuild b/net-mail/libpst/libpst-0.6.66.ebuild
new file mode 100644
index 000000000000..d74c815c7d9b
--- /dev/null
+++ b/net-mail/libpst/libpst-0.6.66.ebuild
@@ -0,0 +1,63 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+PYTHON_DEPEND="python? 2"
+
+inherit autotools eutils python
+
+DESCRIPTION="Tools and library for reading Outlook files (.pst format)"
+HOMEPAGE="http://www.five-ten-sg.com/libpst/"
+SRC_URI="http://www.five-ten-sg.com/${PN}/packages/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE="debug dii doc python static-libs"
+
+RDEPEND="dii? ( media-gfx/imagemagick[png] )
+ gnome-extra/libgsf"
+DEPEND="${RDEPEND}
+ virtual/libiconv
+ virtual/pkgconfig
+ dii? ( media-libs/gd[png] )
+ python? ( >=dev-libs/boost-1.48[python] )"
+
+pkg_setup() {
+ if use python; then
+ python_set_active_version 2
+ python_pkg_setup
+ fi
+}
+
+src_prepare() {
+ # don't build the static python library
+ epatch "${FILESDIR}"/${PN}-0.6.52-no-static-python-lib.patch
+
+ # fix pkgconfig file for static linking
+ epatch "${FILESDIR}"/${PN}-0.6.53-pkgconfig-static.patch
+
+ # conditionally install the extra documentation
+ use doc || { sed -i -e "/SUBDIRS/s: html::" Makefile.am || die; }
+
+ # don't install duplicate docs
+ sed -i -e "/^html_DATA =/d" Makefile.am || die
+
+ eautoreconf
+}
+
+src_configure() {
+ econf \
+ --enable-libpst-shared \
+ $(use_enable debug pst-debug) \
+ $(use_enable dii) \
+ $(use_enable python) \
+ $(use_enable static-libs static) \
+ $(use python && echo --with-boost-python=boost_python-${PYTHON_ABI})
+}
+
+src_install() {
+ default
+ prune_libtool_files --all
+}
diff --git a/net-mail/libpst/metadata.xml b/net-mail/libpst/metadata.xml
index 896f994c2ce1..f2dd6174b4b0 100644
--- a/net-mail/libpst/metadata.xml
+++ b/net-mail/libpst/metadata.xml
@@ -1,7 +1,7 @@
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
- <herd>forensics</herd>
+ <herd>forensics</herd>
<use>
<flag name="dii">enable dii support</flag>
</use>