summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorManuel Rüger <mrueg@gentoo.org>2017-07-03 00:46:16 +0200
committerManuel Rüger <mrueg@gentoo.org>2017-07-03 00:46:16 +0200
commit18a203d21e8c3beaddd3dd1b31abc1ef04f566fb (patch)
tree0315005ce769e498975bd72f1a29bf4a243539b1 /net-mail
parentmedia-fonts/font-misc-misc: Port to EAPI5 (diff)
downloadgentoo-18a203d21e8c3beaddd3dd1b31abc1ef04f566fb.tar.gz
gentoo-18a203d21e8c3beaddd3dd1b31abc1ef04f566fb.tar.bz2
gentoo-18a203d21e8c3beaddd3dd1b31abc1ef04f566fb.zip
net-mail/mpack: Port to EAPI6
Package-Manager: Portage-2.3.6, Repoman-2.3.2
Diffstat (limited to 'net-mail')
-rw-r--r--net-mail/mpack/files/mpack-1.6-clang.patch4
-rw-r--r--net-mail/mpack/mpack-1.6-r4.ebuild38
2 files changed, 40 insertions, 2 deletions
diff --git a/net-mail/mpack/files/mpack-1.6-clang.patch b/net-mail/mpack/files/mpack-1.6-clang.patch
index 0aac7d2adfba..fc21d170af5f 100644
--- a/net-mail/mpack/files/mpack-1.6-clang.patch
+++ b/net-mail/mpack/files/mpack-1.6-clang.patch
@@ -1,5 +1,5 @@
---- uudecode.c 2003-07-21 20:46:37.000000000 +0000
-+++ uudecode.c 2014-04-19 10:04:19.000000000 +0000
+--- umpack-1.6/udecode.c 2003-07-21 20:46:37.000000000 +0000
++++ mpack-1.6/uudecode.c 2014-04-19 10:04:19.000000000 +0000
@@ -845,7 +845,7 @@
}
line += 4;
diff --git a/net-mail/mpack/mpack-1.6-r4.ebuild b/net-mail/mpack/mpack-1.6-r4.ebuild
new file mode 100644
index 000000000000..549f2af53198
--- /dev/null
+++ b/net-mail/mpack/mpack-1.6-r4.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+AT_M4DIR=cmulocal
+
+inherit autotools
+
+DESCRIPTION="Command-line MIME encoding and decoding utilities"
+HOMEPAGE="ftp://ftp.andrew.cmu.edu/pub/mpack/"
+SRC_URI="ftp://ftp.andrew.cmu.edu/pub/mpack/${P}.tar.gz"
+
+SLOT="0"
+LICENSE="HPND"
+KEYWORDS="~amd64 ~x86 ~ppc-macos ~sparc-solaris ~x86-solaris"
+IUSE=""
+
+PATCHES=( "${FILESDIR}"/${P}-filenames.patch
+ "${FILESDIR}"/${P}-usage.patch
+ "${FILESDIR}"/${P}-munpack.patch
+ # NOTE: These three patches replace <mpack-1.6-gentoo.patch>
+ "${FILESDIR}"/${P}-compile.patch
+ "${FILESDIR}"/${P}-paths.patch
+ "${FILESDIR}"/${P}-cve-2011-4919.patch
+
+ "${FILESDIR}"/${P}-clang.patch
+)
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+src_install () {
+ emake DESTDIR="${D}" install
+ dodoc README.* Changes
+}