summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Smith <matthew@gentoo.org>2022-05-23 07:26:27 +0100
committerMatthew Smith <matthew@gentoo.org>2022-05-23 07:29:01 +0100
commit38e58cb042d13fbb1d6ba28ec482e3765ab5b0ce (patch)
tree5d6cf334a1a269b7febab76f5e16e87b18f491d1 /net-mail
parentmedia-gfx/ttfautohint: fix harfbuzz dependency (diff)
downloadgentoo-38e58cb042d13fbb1d6ba28ec482e3765ab5b0ce.tar.gz
gentoo-38e58cb042d13fbb1d6ba28ec482e3765ab5b0ce.tar.bz2
gentoo-38e58cb042d13fbb1d6ba28ec482e3765ab5b0ce.zip
net-mail/mu: add 1.7.23
Bug: https://bugs.gentoo.org/846944 Signed-off-by: Matthew Smith <matthew@gentoo.org>
Diffstat (limited to 'net-mail')
-rw-r--r--net-mail/mu/Manifest1
-rw-r--r--net-mail/mu/mu-1.7.23.ebuild90
2 files changed, 91 insertions, 0 deletions
diff --git a/net-mail/mu/Manifest b/net-mail/mu/Manifest
index 660c1bb17ab2..7c83ea73a6c8 100644
--- a/net-mail/mu/Manifest
+++ b/net-mail/mu/Manifest
@@ -1,3 +1,4 @@
DIST mu-1.6.10.tar.xz 867008 BLAKE2B 6cce22f18691c3ad6dda1ec012d72c398df2ba4d1beca70fc6f88d87aa9b749e2aa4c03f5c0e0d70f4f9978e2beb60ea02642b8ff71e86e0668df726e5923b52 SHA512 a51847b338afeff9c9fa88c4698df4b85289d017063cb5e3410eb967c605d8779618dcbd988e2d923a92291c1e0738ec84afecf017c76a63776149619d134887
DIST mu-1.7.12.tar.xz 2129072 BLAKE2B 3518a361bc06b632899f9296ec211dc926a07973433247bf6f9ecfb069dcfd8b762f358aa32418276bf7dcba40bad768dd4599534613a1fae285cef9c6ceedd0 SHA512 fe0f41520959df7f78525317bf5caad4ae7f7468ac6291b84c48805e133883192458a8f79a929c0ebda2e45ec2014db1aa72650d0a6e176d7678449be36fc4f2
DIST mu-1.7.13.tar.xz 2139140 BLAKE2B c5eea94df8640e0362fd7bd18da78cc53023e7c85c3b4a653df7ae52e57dc64433572bfb2bc41494ce60a1b26abdd75ee07cb945a282754a12f65835a4545e6d SHA512 c5c447cdcf6fd2a3c3dfb8c7cffc9c50e147de2779db04fedaf59897fd135a76b309576f2c9473919221f0dcd6b8793732af3483d86dbe0f073a66d2559fe315
+DIST mu-1.7.23.tar.xz 2136016 BLAKE2B 9b0a27fc07072e52c06d8d4b807a77491d314d4c531799a83b1281ce935b79f5eab3510dc94be98ee0effe86c69379331172cfea3db330b8302d03582f7bf364 SHA512 412789146e4962f670c356576906e5eabc5783dd0fc7d04440146f064877f53b4e948713ed557e97b114a96d7a41b3087a8e3c528b48bb363e68fd0eabfe42fc
diff --git a/net-mail/mu/mu-1.7.23.ebuild b/net-mail/mu/mu-1.7.23.ebuild
new file mode 100644
index 000000000000..39d5cb8ad147
--- /dev/null
+++ b/net-mail/mu/mu-1.7.23.ebuild
@@ -0,0 +1,90 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit elisp-common meson
+
+DESCRIPTION="Set of tools to deal with Maildirs, in particular, searching and indexing"
+HOMEPAGE="https://www.djcbsoftware.nl/code/mu/ https://github.com/djcb/mu"
+SRC_URI="https://dev.gentoo.org/~matthew/distfiles/${P}.tar.xz"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86 ~x64-macos"
+IUSE="emacs readline"
+
+DEPEND="
+ dev-libs/glib:2
+ dev-libs/gmime:3.0
+ >=dev-libs/xapian-1.4:=
+ emacs? ( >=app-editors/emacs-25.3:* )
+ readline? ( sys-libs/readline:= )"
+RDEPEND="${DEPEND}"
+BDEPEND="
+ sys-apps/texinfo
+ virtual/pkgconfig
+"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-1.7.12-optional-mu4e.patch
+ "${FILESDIR}"/${PN}-1.7.12-gcc12.patch
+)
+
+SITEFILE="70mu-gentoo-autoload.el"
+
+src_prepare() {
+ default
+
+ # Don't install NEWS.org into /usr/share/doc.
+ sed -i '/NEWS.org/,+1 d' meson.build || die
+ sed -i '/mu4e-about.org/d' mu4e/meson.build || die
+
+ # Instead, put it in /usr/share/doc/${PF}.
+ sed -i "/MU_DOC_DIR/s/mu/${PF}/" mu4e/meson.build || die
+}
+
+src_configure() {
+ local emesonargs=(
+ $(meson_feature emacs)
+ $(meson_feature readline)
+ # NOTE: Guile interface is deprecated to be removed shortly.
+ -Dguile=disabled
+ )
+ meson_src_configure
+}
+
+src_install() {
+ meson_src_install
+
+ # Since meson no longer installs NEWS.org, install it with dodoc.
+ # Also, it must be uncompressed so that it can be viewed with
+ # mu4e-info.
+ docompress -x /usr/share/doc/${PF}/NEWS.org
+ dodoc NEWS.org
+
+ # Same as above.
+ docompress -x /usr/share/doc/${PF}/mu4e-about.org
+ dodoc mu4e/mu4e-about.org
+}
+
+pkg_preinst() {
+ if [[ -n ${REPLACING_VERSIONS} ]]; then
+ elog "After upgrading from an old major version, you should"
+ elog "rebuild your mail index."
+ fi
+}
+
+pkg_postinst() {
+ if use emacs; then
+ einfo "To use mu4e you need to configure it in your .emacs file"
+ einfo "See the manual for more information:"
+ einfo "https://www.djcbsoftware.nl/code/mu/mu4e/"
+
+ elisp-site-regen
+ fi
+}
+
+pkg_postrm() {
+ use emacs && elisp-site-regen
+}