summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBernard Cafarelli <voyageur@gentoo.org>2020-09-15 18:32:33 +0200
committerBernard Cafarelli <voyageur@gentoo.org>2020-09-16 00:22:51 +0200
commit61e472a97bf13f64c6bd6753a8a54da27fc5568b (patch)
tree9501096c2c557b56e6f0560bfc03272239710b33 /net-mail
parentwww-apps/nextcloud: 19.0.3, 18.0.9 bumps (diff)
downloadgentoo-61e472a97bf13f64c6bd6753a8a54da27fc5568b.tar.gz
gentoo-61e472a97bf13f64c6bd6753a8a54da27fc5568b.tar.bz2
gentoo-61e472a97bf13f64c6bd6753a8a54da27fc5568b.zip
net-mail/fetchmail: 6.4.12 bump
Package-Manager: Portage-3.0.7, Repoman-3.0.1 Signed-off-by: Bernard Cafarelli <voyageur@gentoo.org>
Diffstat (limited to 'net-mail')
-rw-r--r--net-mail/fetchmail/Manifest1
-rw-r--r--net-mail/fetchmail/fetchmail-6.4.12.ebuild107
2 files changed, 108 insertions, 0 deletions
diff --git a/net-mail/fetchmail/Manifest b/net-mail/fetchmail/Manifest
index f81bfaf5df16..36ce8a3fb731 100644
--- a/net-mail/fetchmail/Manifest
+++ b/net-mail/fetchmail/Manifest
@@ -1,2 +1,3 @@
DIST fetchmail-6.4.11.tar.xz 1302708 BLAKE2B 660f05c54ea9772de2dd3e584d0d2ff9addfdb7927396330a829f85995a7a2cd818c37762f704030ab73aba6750b62862dc79ad4617d45e948e8a96474fe8258 SHA512 aa7961490e34bffffb571bbc67eccec4bdef046da0a959cb2522e511074c275dbf4d797f9d8d019d7f464baae7ca19194cafeef65b5bc258dbf970d58f2dfd16
+DIST fetchmail-6.4.12.tar.xz 1303532 BLAKE2B d37c020b07b342ef4ba95a4b7f017217515e26ec06512350fea2bd58aa4d848a4865d98b1f9440ead544d9c377221f31f97f02499b7799ffa56c1e7dae7b73cf SHA512 277c324bab528a036f2896909b63baaa68d986b79baa24e2ee5cd8ca1d86082d4cd41ca371114fc8ae150eb0f97af50fd5238e88485ad5c701699b69964fe256
DIST fetchmail-6.4.8.tar.xz 1282300 BLAKE2B 31b7f9fa31edff534210a2a0764cc6dec461968071a8aa29b1d1e9915ff6b8d2949b128f97d72fafe6d431b06d4e5c6b38d4a3cdba06736bdf8ec1879a991798 SHA512 c1052389baafa3a48186733133130bf69b87c8dda8faa00e82f5947037845b95d3271c8183df729728a351888175174ca11eb18f9adb8b3515860cba95ab8987
diff --git a/net-mail/fetchmail/fetchmail-6.4.12.ebuild b/net-mail/fetchmail/fetchmail-6.4.12.ebuild
new file mode 100644
index 000000000000..9b96312d1c6c
--- /dev/null
+++ b/net-mail/fetchmail/fetchmail-6.4.12.ebuild
@@ -0,0 +1,107 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6,7,8} )
+PYTHON_REQ_USE="tk"
+
+inherit python-single-r1 systemd toolchain-funcs autotools
+
+DESCRIPTION="the legendary remote-mail retrieval and forwarding utility"
+HOMEPAGE="https://www.fetchmail.info/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.xz"
+
+LICENSE="GPL-2 public-domain"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~sparc-solaris ~x64-solaris ~x86-solaris"
+IUSE="ssl nls kerberos tk socks libressl"
+REQUIRED_USE="tk? ( ${PYTHON_REQUIRED_USE} )"
+
+RDEPEND="acct-user/fetchmail
+ ssl? (
+ !libressl? ( >=dev-libs/openssl-1.1.1:= )
+ libressl? ( dev-libs/libressl:= )
+ )
+ kerberos? (
+ virtual/krb5
+ !libressl? ( >=dev-libs/openssl-1.0.2:= )
+ libressl? ( dev-libs/libressl:= )
+ )
+ nls? ( virtual/libintl )
+ !elibc_glibc? ( sys-libs/e2fsprogs-libs )
+ socks? ( net-proxy/dante )
+ tk? (
+ ${PYTHON_DEPS}
+ $(python_gen_cond_dep '
+ dev-python/future[${PYTHON_MULTI_USEDEP}]
+ ')
+ )"
+DEPEND="${RDEPEND}
+ app-arch/xz-utils
+ sys-devel/flex
+ nls? ( sys-devel/gettext )"
+
+DOCS="FAQ FEATURES NEWS NOTES README README.NTLM README.SSL* TODO"
+HTML_DOCS="*.html"
+PATCHES=(
+ "${FILESDIR}"/${PN}-6.3.26-python-optional.patch
+)
+S=${WORKDIR}/${P/_/.}
+
+pkg_setup() {
+ use tk && python-single-r1_pkg_setup
+}
+
+src_prepare() {
+ default
+ # don't compile during src_install
+ use tk && : > "${S}"/py-compile
+ eautoreconf
+}
+
+src_configure() {
+ use tk || export PYTHON=:
+
+ econf \
+ --enable-RPA \
+ --enable-NTLM \
+ --enable-SDPS \
+ $(use_enable nls) \
+ $(use_with ssl ssl "${EPREFIX}/usr") \
+ $(use kerberos && echo "--with-ssl=${EPREFIX}/usr") \
+ $(use_with kerberos gssapi) \
+ $(use_with kerberos kerberos5) \
+ --without-hesiod \
+ $(use_with socks)
+}
+
+src_compile() {
+ emake AR="$(tc-getAR)"
+}
+
+src_install() {
+ default
+
+ newinitd "${FILESDIR}"/fetchmail.initd fetchmail
+ newconfd "${FILESDIR}"/fetchmail.confd fetchmail
+
+ systemd_dounit "${FILESDIR}"/${PN}.service
+ systemd_newunit "${FILESDIR}"/${PN}_at.service "${PN}@.service"
+ systemd_dotmpfilesd "${FILESDIR}"/${PN}.conf
+
+ docinto contrib
+ local f
+ for f in contrib/* ; do
+ [ -f "${f}" ] && dodoc "${f}"
+ done
+
+ use tk && python_optimize
+}
+
+pkg_postinst() {
+ if [[ -z ${REPLACING_VERSIONS} ]]; then
+ elog "Please see /etc/conf.d/fetchmail if you want to adjust"
+ elog "the polling delay used by the fetchmail init script."
+ fi
+}