summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Orlitzky <mjo@gentoo.org>2016-07-15 10:47:20 -0400
committerMichael Orlitzky <mjo@gentoo.org>2016-07-15 11:04:57 -0400
commit61f3a0994dfb4a7220d6899dd5fb40c97c8f15f6 (patch)
tree3ee6ae0405d48fcfe24096c6ddbb63cf4d147bfd /net-mail
parentdev-haskell/configurator: new package to read config files in Haskell. (diff)
downloadgentoo-61f3a0994dfb4a7220d6899dd5fb40c97c8f15f6.tar.gz
gentoo-61f3a0994dfb4a7220d6899dd5fb40c97c8f15f6.tar.bz2
gentoo-61f3a0994dfb4a7220d6899dd5fb40c97c8f15f6.zip
net-mail/list-remote-forwards: new package to find off-site mail forwards.
Package-Manager: portage-2.2.28
Diffstat (limited to 'net-mail')
-rw-r--r--net-mail/list-remote-forwards/Manifest1
-rw-r--r--net-mail/list-remote-forwards/list-remote-forwards-0.0.1-r1.ebuild42
-rw-r--r--net-mail/list-remote-forwards/metadata.xml142
3 files changed, 185 insertions, 0 deletions
diff --git a/net-mail/list-remote-forwards/Manifest b/net-mail/list-remote-forwards/Manifest
new file mode 100644
index 000000000000..acd556e47c4d
--- /dev/null
+++ b/net-mail/list-remote-forwards/Manifest
@@ -0,0 +1 @@
+DIST list-remote-forwards-0.0.1.tar.gz 25869 SHA256 da772a92043fcdfd60698bd24c03c1a73cd0531ab88923dd1dbe13ed091105af SHA512 b6d8c0e8a72e3dcbc62c00b291da99da6c37c853997c367eb60db128db327c1f862e9dc6d9ad4028aad2e0cec9acc96add28d85d4b22508e1fd00a65bb9b0317 WHIRLPOOL 5ac8b0001b8cc53fc8ecf3dcd25ac8e4c071a3516efda929f7c977c9d91a94b97596bf332612e32e2396f8f4907799dd7251c5d9061276f17970c2909902c899
diff --git a/net-mail/list-remote-forwards/list-remote-forwards-0.0.1-r1.ebuild b/net-mail/list-remote-forwards/list-remote-forwards-0.0.1-r1.ebuild
new file mode 100644
index 000000000000..5701833f6c81
--- /dev/null
+++ b/net-mail/list-remote-forwards/list-remote-forwards-0.0.1-r1.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+# ebuild generated by hackport 0.4.4
+
+CABAL_FEATURES="bin test-suite"
+inherit haskell-cabal
+
+DESCRIPTION="List all remote forwards for mail accounts stored in a database"
+HOMEPAGE="http://hackage.haskell.org/package/list-remote-forwards"
+SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND=""
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.16.0
+ >=dev-haskell/cmdargs-0.10
+ >=dev-haskell/configurator-0.2
+ >=dev-haskell/dns-1.4
+ >=dev-haskell/hdbc-2.4
+ >=dev-haskell/hdbc-postgresql-2.3
+ >=dev-haskell/hdbc-sqlite-2.3
+ >=dev-haskell/missingh-1.2
+ >=dev-haskell/tasty-0.8
+ >=dev-haskell/tasty-hunit-0.8
+ >=dev-haskell/tasty-quickcheck-0.8
+ >=dev-lang/ghc-7.6.1
+ test? ( >=dev-haskell/doctest-0.9
+ >=dev-haskell/filemanip-0.3.6 )
+"
+
+src_install() {
+ haskell-cabal_src_install
+ doman "${S}/doc/man1/${PN}.1"
+}
diff --git a/net-mail/list-remote-forwards/metadata.xml b/net-mail/list-remote-forwards/metadata.xml
new file mode 100644
index 000000000000..9ff09b22b666
--- /dev/null
+++ b/net-mail/list-remote-forwards/metadata.xml
@@ -0,0 +1,142 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>mjo@gentoo.org</email>
+ <name>Michael Orlitzky</name>
+ </maintainer>
+ <maintainer type="project">
+ <email>haskell@gentoo.org</email>
+ <name>Gentoo Haskell</name>
+ </maintainer>
+ <longdescription>
+ /Usage/:
+
+ @
+ list-remote-forwards [OPTIONS]
+ @
+
+ List all remote forwards for mail accounts stored in a SQL database.
+
+ A list of local domains is supplied to the program (more or less)
+ through the @--domain-query@ option. Any addresses which
+ forward to another address not contained in this list of local domains
+ is considered a remote forward. Remote forwards can cause problems for
+ a number of reasons, the most common of which are,
+
+ * If the sender has an SPF record authorizing his mail server to send
+ mail on his behalf, then when his message is forwarded by the
+ recipient's mail server, it will fail any subsequent SPF checks. This
+ will likely cause the message to be rejected, and the original
+ recipient's server will generate backscatter.
+
+ * If any spam makes it through the filter on the recipient's mail
+ server, that spam will then be forwarded to a remote destination. The
+ remote destination will blame the forwarding server for the spam, and
+ that can impact its reputation and potentially lead to a blacklisting
+ even though the spam did not originate on the recipient's server.
+
+ Whether or not these are an issue depends on the circumstances, but in
+ any case it is useful to know who is forwarding mail off-site.
+
+ /Input:/
+
+ None.
+
+ /Output:/
+
+ A list of addresses that are forwarded to remote domains.
+
+ /Options/:
+
+ @
+ \--database
+ @
+
+ The name of the database (or file, if SQLite) to which we should
+ connect.
+
+ Default: The name of the current user (Postgres only).
+
+ @
+ \--domain-query
+ @
+ SQL query used to produce a list of local domains. This should return
+ the set of all domains (i.e one column) that are local to the
+ server. See the default value for an example.
+
+ Default: \"SELECT domain FROM domain WHERE domain &lt;&gt; 'ALL' ORDER BY domain;\"
+
+ @
+ \--exclude-mx, -e
+ @
+
+ The name of a mail exchanger, the forwards of whose domains we should
+ ignore. For example, if one mail exchanger, mx1.example.com, has
+ strict spam filtering, it may be acceptable to have remote forwarding
+ for domains that have mx1.example.com as their sole mail exchanger (MX
+ record). In that case, you might want to exclude those domains from
+ the report by naming mx1.example.com here.
+
+ A forward will be excluded from the report only if /all/ of its MX
+ records are contained in the given exclude list.
+
+ This option can be repeated to add mail exchangers to the exclude list.
+
+ Default: [] (empty)
+
+ @
+ \--forward-query, -f
+ @
+
+ SQL query used to produce a list of all forwards on the mail
+ system. This query should return the set of all (address, goto)
+ triples, where \"goto\" is the destination address; i.e. to where
+ the \"address\" forwards. The \"goto\" field may contain more
+ than one email address, separated by commas.
+
+ Default: \"SELECT address,goto FROM alias ORDER BY address;\"
+
+ @
+ \--host, -h
+ @
+
+ Hostname where the database is located (Postgres-only).
+
+ Default: None, a UNIX domain socket connection is attempted (Postgres only)
+
+ @
+ \--password
+ @
+
+ Password used to connect to the database (Postgres-only).
+
+ Default: None (assumes passwordless authentication)
+
+ @
+ \--port
+ @
+ Port number used to connect to the database (Postgres-only).
+
+ Default: None, a UNIX domain socket connection is attempted (Postgres only)
+
+ @
+ \--username, -u
+ @
+
+ Username used to connect to the database (Postgres-only).
+
+ Default: The current user
+
+ /Examples/:
+
+ @
+ $ list-remote-forwards --database=test/fixtures/postfixadmin.sqlite3
+ user1@example.com -&gt; user1@example.net
+ user2@example.com -&gt; user1@example.org
+ user2@example.com -&gt; user2@example.org
+ user2@example.com -&gt; user3@example.org
+ user7@example.com -&gt; user8@example.net
+ @
+ </longdescription>
+</pkgmetadata>