summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Smith <matthew@gentoo.org>2024-02-26 14:39:49 +0000
committerMatthew Smith <matthew@gentoo.org>2024-02-26 14:39:49 +0000
commit6595e07cab120ebc8bc8804b8f090a6698d02315 (patch)
tree6b983217ad8408332e4e55a01bffe8a2217806de /net-mail
parentwww-apps/moodle: version bumps to 4.2.6 and 4.3.3 (diff)
downloadgentoo-6595e07cab120ebc8bc8804b8f090a6698d02315.tar.gz
gentoo-6595e07cab120ebc8bc8804b8f090a6698d02315.tar.bz2
gentoo-6595e07cab120ebc8bc8804b8f090a6698d02315.zip
net-mail/mu: fix build without python3
Avoid dependency on Python. Closes: https://bugs.gentoo.org/925503 Signed-off-by: Matthew Smith <matthew@gentoo.org>
Diffstat (limited to 'net-mail')
-rw-r--r--net-mail/mu/files/mu-1.12.0-no-python.patch30
-rw-r--r--net-mail/mu/mu-1.12.0.ebuild4
2 files changed, 34 insertions, 0 deletions
diff --git a/net-mail/mu/files/mu-1.12.0-no-python.patch b/net-mail/mu/files/mu-1.12.0-no-python.patch
new file mode 100644
index 000000000000..9840da22ca33
--- /dev/null
+++ b/net-mail/mu/files/mu-1.12.0-no-python.patch
@@ -0,0 +1,30 @@
+https://bugs.gentoo.org/925503
+
+Call coreutils date instead of a Python script.
+--- a/meson.build
++++ b/meson.build
+@@ -104,17 +104,16 @@ cxx.check_header('charconv', required:true)
+ build_aux = join_paths(meson.current_source_dir(), 'build-aux')
+ ################################################################################
+ # derived date values (based on 'mu-date'); used in docs
+-# we can't use the 'date' because MacOS 'date' is incompatible with GNU's.
+-pdate=find_program(join_paths(build_aux, 'date.py'))
++date=find_program('date', required:true)
+ env = environment()
+ env.set('LANG', 'C')
+-mu_day_month_year = run_command(pdate, mu_date, '%d %B %Y',
++mu_day_month_year = run_command(date, '-u', '+%d %B %Y', '--date', mu_date,
+ check:true, capture:true,
+ env: env).stdout().strip()
+-mu_month_year = run_command(pdate, mu_date, '%B %Y',
++mu_month_year = run_command(date, '-u', '+%B %Y', '--date', mu_date,
+ check:true, capture:true,
+ env: env).stdout().strip()
+-mu_year = run_command(pdate, mu_date, '%Y',
++mu_year = run_command(date, '-u', '+%Y', '--date', mu_date,
+ check:true, capture:true, env: env).stdout().strip()
+
+ ################################################################################
+--
+2.44.0
+
diff --git a/net-mail/mu/mu-1.12.0.ebuild b/net-mail/mu/mu-1.12.0.ebuild
index 4df4e56cb6e2..8152dc0b9a0e 100644
--- a/net-mail/mu/mu-1.12.0.ebuild
+++ b/net-mail/mu/mu-1.12.0.ebuild
@@ -27,7 +27,11 @@ BDEPEND="
"
PATCHES=(
+ # https://github.com/djcb/mu/pull/2632
"${FILESDIR}"/${PN}-1.12.0-cld2-opt.patch
+
+ # https://bugs.gentoo.org/925503
+ "${FILESDIR}"/${PN}-1.12.0-no-python.patch
)
SITEFILE="70mu-gentoo-autoload.el"