summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Orlitzky <mjo@gentoo.org>2016-07-15 18:06:06 -0400
committerMichael Orlitzky <mjo@gentoo.org>2016-07-15 18:06:06 -0400
commit65bb6654e931adfeafc407c3554f25f77691d321 (patch)
tree74a1c4bdc66ed0c40a452d3faa75caa762dba9ce /net-mail
parentdev-php/PHPMailer: version bump 5.2.14 -> 5.2.16. (diff)
downloadgentoo-65bb6654e931adfeafc407c3554f25f77691d321.tar.gz
gentoo-65bb6654e931adfeafc407c3554f25f77691d321.tar.bz2
gentoo-65bb6654e931adfeafc407c3554f25f77691d321.zip
net-mail/mailbox-count: new package to count SQL mailboxes.
Package-Manager: portage-2.2.28
Diffstat (limited to 'net-mail')
-rw-r--r--net-mail/mailbox-count/Manifest1
-rw-r--r--net-mail/mailbox-count/mailbox-count-0.0.2-r1.ebuild35
-rw-r--r--net-mail/mailbox-count/metadata.xml144
3 files changed, 180 insertions, 0 deletions
diff --git a/net-mail/mailbox-count/Manifest b/net-mail/mailbox-count/Manifest
new file mode 100644
index 000000000000..831867e01389
--- /dev/null
+++ b/net-mail/mailbox-count/Manifest
@@ -0,0 +1 @@
+DIST mailbox-count-0.0.2.tar.gz 20644 SHA256 6eef4b2300a8a5a53bb44ec8c192324025ebddcdc81c2ba145f812a941dba3fd SHA512 98e39927382719295260c64bd5888244000dbbb3fbd7f6405dcffe78a4fc5f1dea7f8236542e58eb0118bb421c19225a8be0560b92c7688c0701418c7221d569 WHIRLPOOL e8a01030415a3be24926d9b0f6ba812a706d361f065c3b8a7622ab532f31282f4d506e976f1fefdf208039ddc95e1e9b8002e27e01d67ca3648cb85cf7cff7e8
diff --git a/net-mail/mailbox-count/mailbox-count-0.0.2-r1.ebuild b/net-mail/mailbox-count/mailbox-count-0.0.2-r1.ebuild
new file mode 100644
index 000000000000..2fc2721c9dfa
--- /dev/null
+++ b/net-mail/mailbox-count/mailbox-count-0.0.2-r1.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+# ebuild generated by hackport 0.4.2
+
+CABAL_FEATURES="bin test-suite"
+inherit haskell-cabal
+
+DESCRIPTION="Count mailboxes in a SQL database"
+HOMEPAGE="http://hackage.haskell.org/package/mailbox-count"
+SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND=""
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.16.0
+ >=dev-haskell/cmdargs-0.10
+ >=dev-haskell/configurator-0.2
+ >=dev-haskell/hdbc-2.4
+ >=dev-haskell/hdbc-postgresql-2.3
+ >=dev-haskell/hdbc-sqlite-2.3
+ >=dev-haskell/missingh-1.2
+ >=dev-haskell/tasty-0.8
+ >=dev-haskell/tasty-hunit-0.8
+ >=dev-lang/ghc-7.6.1
+ test? ( >=dev-haskell/doctest-0.9
+ >=dev-haskell/filemanip-0.3.6 )
+"
diff --git a/net-mail/mailbox-count/metadata.xml b/net-mail/mailbox-count/metadata.xml
new file mode 100644
index 000000000000..fb7f98befbe3
--- /dev/null
+++ b/net-mail/mailbox-count/metadata.xml
@@ -0,0 +1,144 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>mjo@gentoo.org</email>
+ <name>Michael Orlitzky</name>
+ </maintainer>
+ <maintainer type="project">
+ <email>haskell@gentoo.org</email>
+ <name>Gentoo Haskell</name>
+ </maintainer>
+ <longdescription>
+ /Usage/:
+
+ @
+ mailbox-count [OPTIONS]
+ @
+
+ Mailbox-count produces a simple count of mailboxes that exist
+ per-domain in some SQL database. The default queries are compatible
+ with the schema used by PostfixAdmin &lt;http://postfixadmin.sourceforge.net/&gt;,
+ but it is possible to supply your own queries via the @--summary-query@
+ and @--detail-query@ options.
+
+ The summary report lists each domain, along with the number of
+ mailboxes owned by that domain. The order is determined by the summary
+ query, which lists the domains alphabetically by default.
+
+ The default detail report shows the same, but also contains a list of
+ each individual mailbox (again in alphabetical order) belonging to the
+ domains.
+
+ /Input/:
+
+ None.
+
+ /Output/:
+
+ Either a summary, or detailed report (with @--detail@) of the
+ number of mailboxes per-domain contained in the database.
+
+ /Options/:
+
+ @
+ \--database
+ @
+
+ The name of the database (or file, if SQLite) to which we should
+ connect.
+
+ Default: The name of the current user (Postgres only).
+
+ @
+ \--detail
+ @
+
+ Produce a detailed report listing all mailboxes by domain.
+
+ @
+ \--detail-query
+ @
+
+ SQL query used to produce the detail report. This should return the
+ set of all (domain, username) pairs. See the default value for an
+ example.
+
+ Default: \"SELECT domain,username FROM mailbox ORDER BY domain;\"
+
+ @
+ \--host
+ @
+
+ Hostname where the database is located (Postgres-only).
+
+ Default: None, a UNIX domain socket connection is attempted (Postgres only)
+
+ @
+ \--password
+ @
+
+ Password used to connect to the database (Postgres-only).
+
+ Default: None (assumes passwordless authentication)
+
+ @
+ \--port
+ @
+ Port number used to connect to the database (Postgres-only).
+
+ Default: None, a UNIX domain socket connection is attempted (Postgres only)
+
+ @
+ \--summary-query
+ @
+
+ SQL query used to produce the summary report. This should return
+ (domain, user count) pairs. See the default value for an
+ example.
+
+ Default: \"SELECT domain,COUNT(username) FROM mailbox GROUP BY domain
+ ORDER BY domain;\"
+
+ @
+ \--username
+ @
+
+ Username used to connect to the database (Postgres-only).
+
+ Default: The current user
+
+ /Examples/:
+
+ The default summary report:
+
+ @
+ $ mailbox-count --database=postfixadmin.sqlite3
+ Summary (number of mailboxes per domain)
+ \----------------------------------------
+ example.com: 3
+ example.invalid: 1
+ example.net: 2
+ example.org: 1
+ @
+
+ The more detailed report:
+
+ @
+ $ mailbox-count --detail --database=postfixadmin.sqlite3
+ Detail (list of all mailboxes by domain)
+ \----------------------------------------
+ example.com (3):
+ &amp;#x20; user1
+ &amp;#x20; user3
+ &amp;#x20; user5
+ example.invalid (1):
+ &amp;#x20; user7
+ example.net (2):
+ &amp;#x20; user2
+ &amp;#x20; user4
+ example.org (1):
+ &amp;#x20; user6
+ @
+ </longdescription>
+</pkgmetadata>