summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorZoltan Puskas <zoltan@sinustrom.info>2023-03-06 01:17:15 -0800
committerMatthew Smith <matthew@gentoo.org>2023-03-08 15:28:30 +0000
commit6b3d297e2d9c3bb85cc2de8b6f903a40208a3819 (patch)
tree42a4fcfc7ac6029a079683c3ea28c1e4cf4e04b3 /net-mail
parentnet-irc/weechat: add new USE flag 'enchant' for spell checker plugin (diff)
downloadgentoo-6b3d297e2d9c3bb85cc2de8b6f903a40208a3819.tar.gz
gentoo-6b3d297e2d9c3bb85cc2de8b6f903a40208a3819.tar.bz2
gentoo-6b3d297e2d9c3bb85cc2de8b6f903a40208a3819.zip
net-mail/getmail: add 6.18.12
Bug: https://bugs.gentoo.org/897110 Signed-off-by: Zoltan Puskas <zoltan@sinustrom.info> Closes: https://github.com/gentoo/gentoo/pull/29956 Signed-off-by: Matthew Smith <matthew@gentoo.org>
Diffstat (limited to 'net-mail')
-rw-r--r--net-mail/getmail/Manifest1
-rw-r--r--net-mail/getmail/getmail-6.18.12.ebuild27
2 files changed, 28 insertions, 0 deletions
diff --git a/net-mail/getmail/Manifest b/net-mail/getmail/Manifest
index 565822d99c07..c2949be36c93 100644
--- a/net-mail/getmail/Manifest
+++ b/net-mail/getmail/Manifest
@@ -1,2 +1,3 @@
DIST getmail-6.18.10.gh.tar.gz 205481 BLAKE2B a0597db32ff2ce43bf96feadcba4d926d48898cc412ec96e8d62086e29a364f6b806f0279878b95976e3ca7b0966afb19cb59939ef8bea1627a230518ea28602 SHA512 feda9236d3a1a7ceb21ca293d41c9631fec5f8753be4ece6e1b6910c052d10a8466547977fb4d0452ec4ae9f89ebff36105e0fe5843d02b2af3fd4bcea36e6c1
+DIST getmail-6.18.12.gh.tar.gz 207087 BLAKE2B 916c7fe7d459c27001ae80fafb95c8ea561a3c1b7335d142678c94242e7602070bf1d93c56db52363fbf62071f261dd8df5ca2c9cb71f2e7c7b8eb2826fa1035 SHA512 8b58c3295831740cac854ccc4dabf9ff53a08f85648beeb50952fc895df7115304cdaec8c3f6f94e9ee828914268dd8f23978cae4f5d3f6eff9f48fa59d3f5de
DIST getmail-6.18.9.tar.gz 204488 BLAKE2B 4bf95cec36ce10d5fd6c9fbb6b96923915a13f4b339a9846caafc5602a56612fb9f4b7209a138a03b81b19b7d28328bb46c60165215384650e7dcf98294cc5fa SHA512 dfeaebbca0c8766a16783d27171e65595d97a4b557943677dd7e7a66a9da8b49dfdbfb4aba9655ce3815ff6e2f991905317085b156ba6dbac841bb0fbb26c8b5
diff --git a/net-mail/getmail/getmail-6.18.12.ebuild b/net-mail/getmail/getmail-6.18.12.ebuild
new file mode 100644
index 000000000000..e890841ed946
--- /dev/null
+++ b/net-mail/getmail/getmail-6.18.12.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_SINGLE_IMPL=1
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{9..11} )
+PYTHON_REQ_USE="ssl"
+inherit distutils-r1
+
+DESCRIPTION="A mail retriever with reliable Maildir and mbox delivery"
+HOMEPAGE="https://www.getmail6.org/ https://github.com/getmail6/getmail6"
+SRC_URI="https://github.com/getmail6/getmail6/archive/v${PV}.tar.gz -> ${P}.gh.tar.gz"
+S="${WORKDIR}/getmail6-${PV}"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+python_prepare_all() {
+ # Use gentoo version number (including revision) for doc dir and remove COPYING file
+ sed -i -e "s,'getmail-%s' % __version__,'${PF}'," \
+ -e "/docs\/COPYING/d" "${S}"/setup.py || die
+
+ distutils-r1_python_prepare_all
+}