summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2024-03-12 08:14:15 +0000
committerSam James <sam@gentoo.org>2024-03-12 15:11:31 +0000
commit7239dad821b0f817fcd2abb95b5f3ed7514bb86a (patch)
tree1aa925692ac0781286ab452e30d1af73c776e3b7 /net-mail
parentx11-terms/kitty: Stabilize 0.32.2 arm64, #926114 (diff)
downloadgentoo-7239dad821b0f817fcd2abb95b5f3ed7514bb86a.tar.gz
gentoo-7239dad821b0f817fcd2abb95b5f3ed7514bb86a.tar.bz2
gentoo-7239dad821b0f817fcd2abb95b5f3ed7514bb86a.zip
net-mail/b4: add 0.13.0
Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'net-mail')
-rw-r--r--net-mail/b4/Manifest1
-rw-r--r--net-mail/b4/b4-0.13.0.ebuild27
2 files changed, 28 insertions, 0 deletions
diff --git a/net-mail/b4/Manifest b/net-mail/b4/Manifest
index 8e8f77770f70..590a6ca033d5 100644
--- a/net-mail/b4/Manifest
+++ b/net-mail/b4/Manifest
@@ -1 +1,2 @@
DIST b4-0.12.1.tar.gz 233691 BLAKE2B d10dc969d16722083ab0b79b7a2a26df44dbe2d5a8a804a0339903ff30f2a25a915e7755d4c5a9855d9b3abd8fbd6a3ff3b8034a6679491835446fdd24ee1b0f SHA512 6a7cacfdda6b4c8c3b87554c1b8fc7b2e797ea0b44476943aa6b75a901dc57cc17fab2a584d63c3724967ee8e6d9b3070dea94a6e4df43547a521ba741366032
+DIST b4-0.13.0.tar.gz 243729 BLAKE2B b004209ab289026e5013003355873feeef0c275dbd638a9ca725adc0bb594ea5091094b2fb30737fad9ef60a742809699c9c9a0e0015e9ebf58ee3d1c90fc989 SHA512 692d01970019d3fc604187882004d97f4286a22d87e5778d7830ec247757534a9d951fa8edfe9e04e8f14107c77b08b6c15024f37bd99f4abf3aa0d823df21e5
diff --git a/net-mail/b4/b4-0.13.0.ebuild b/net-mail/b4/b4-0.13.0.ebuild
new file mode 100644
index 000000000000..21f935f044e6
--- /dev/null
+++ b/net-mail/b4/b4-0.13.0.ebuild
@@ -0,0 +1,27 @@
+# Copyright 2020-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{9..11} )
+inherit distutils-r1
+
+DESCRIPTION="Utility for fetching patchsets from public-inbox"
+HOMEPAGE="https://pypi.org/project/b4/"
+# pypi lacks tests
+SRC_URI="https://git.kernel.org/pub/scm/utils/b4/b4.git/snapshot/${P}.tar.gz"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+
+RDEPEND="
+ >=dev-python/dkimpy-1.0[${PYTHON_USEDEP}]
+ >=dev-python/dnspython-2.1[${PYTHON_USEDEP}]
+ >=dev-python/patatt-0.6[${PYTHON_USEDEP}]
+ >=dev-python/requests-2.24[${PYTHON_USEDEP}]
+ >=dev-vcs/git-filter-repo-2.30[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests pytest