summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Harder <radhermit@gentoo.org>2018-12-25 14:15:04 -0600
committerTim Harder <radhermit@gentoo.org>2018-12-25 14:17:30 -0600
commit880fe1d5d8b28061e77c270b1f8fe5dac1307322 (patch)
treec9c2435e19557ed44193d382b96493c9ad45941c /net-mail
parentx11-misc/tint2: version bump 16.6.1 (diff)
downloadgentoo-880fe1d5d8b28061e77c270b1f8fe5dac1307322.tar.gz
gentoo-880fe1d5d8b28061e77c270b1f8fe5dac1307322.tar.bz2
gentoo-880fe1d5d8b28061e77c270b1f8fe5dac1307322.zip
net-mail/getmail: version bump to 5.8
Signed-off-by: Tim Harder <radhermit@gentoo.org>
Diffstat (limited to 'net-mail')
-rw-r--r--net-mail/getmail/Manifest1
-rw-r--r--net-mail/getmail/getmail-5.8.ebuild24
2 files changed, 25 insertions, 0 deletions
diff --git a/net-mail/getmail/Manifest b/net-mail/getmail/Manifest
index b589d7fac67e..bcc5c76e60f8 100644
--- a/net-mail/getmail/Manifest
+++ b/net-mail/getmail/Manifest
@@ -1,2 +1,3 @@
DIST getmail-5.4.tar.gz 194884 BLAKE2B f6a64b0bb4f5d89e75187fe162ad13e6e3601fd3338e6d9ef30b2100d8ab59328df1446a6771ec992b18e46e75341fff9308af9a994e4e61f41ab89cec20cf4c SHA512 6557cc46df1d31116f9d28cda1232737c01a568e6ada44edb14cdec30a42160966e1e69f42c46855ce139c3b70d77747324adda8abff3dd772a54a79015b0050
DIST getmail-5.6.tar.gz 197360 BLAKE2B 0833933c4dd4b0b7962070dd3d6738b2c7336f359ca9e40e6febbeaffc6cea6942e4271de6cd3053447af94cc7fd189a25beb99c81d2d1221f1c478807dd7c33 SHA512 7ee34f214ab4d98d1b34e46abba61561133f27edf1f64bb9c5d5f671e6944724d1773234bd8ab626607b732cc54fd335cbfcb69fdff8f4d8fcdb33108b25bafd
+DIST getmail-5.8.tar.gz 197874 BLAKE2B d5d236c03f1ea5620e773ff47203fe707e7c96bd4267b0267afc8681c3ab4015b291b08967ed0c05a2a1c82bca904236be550bd95d14f781445daf86a9ab6a87 SHA512 8469bc81fb0df4eeb27620b2cc472919bd441cbcb860a0f56b6d2433d22c85a0a326c86e1f566cd2a9d0acc0680d03b84f62cdfd5b92ae0e5bf7293dfdfe466b
diff --git a/net-mail/getmail/getmail-5.8.ebuild b/net-mail/getmail/getmail-5.8.ebuild
new file mode 100644
index 000000000000..bcefbf5318b0
--- /dev/null
+++ b/net-mail/getmail/getmail-5.8.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2018 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python2_7 )
+PYTHON_REQ_USE="ssl?"
+
+inherit distutils-r1
+
+DESCRIPTION="A mail retriever with reliable Maildir and mbox delivery"
+HOMEPAGE="http://pyropus.ca/software/getmail/"
+SRC_URI="http://pyropus.ca/software/getmail/old-versions/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86 ~ppc-macos ~x86-macos ~x64-solaris"
+IUSE="ssl"
+
+python_prepare_all() {
+ sed -i -e "s,'getmail-%s' % __version__,'${PF}'," \
+ -e "/docs\/COPYING/d" "${S}"/setup.py || die
+
+ distutils-r1_python_prepare_all
+}