summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatt Smith <matt@offtopica.uk>2021-08-13 08:27:22 +0100
committerSam James <sam@gentoo.org>2021-08-16 02:58:01 +0100
commit8957459ba5bc73d752af583fe73d1d2e19889a90 (patch)
treea3004d4b7a5515a8cb26dab38ab8461a75666d93 /net-mail
parentapp-misc/detox: drop 1.4.3 (diff)
downloadgentoo-8957459ba5bc73d752af583fe73d1d2e19889a90.tar.gz
gentoo-8957459ba5bc73d752af583fe73d1d2e19889a90.tar.bz2
gentoo-8957459ba5bc73d752af583fe73d1d2e19889a90.zip
net-mail/mu: Bump to 1.6.3
Also add a `readline' USE flag and drop the `mug' USE flag. Package-Manager: Portage-3.0.20, Repoman-3.0.3 Signed-off-by: Matt Smith <matt@offtopica.uk> Closes: https://github.com/gentoo/gentoo/pull/21971 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'net-mail')
-rw-r--r--net-mail/mu/Manifest1
-rw-r--r--net-mail/mu/mu-1.6.3.ebuild60
2 files changed, 61 insertions, 0 deletions
diff --git a/net-mail/mu/Manifest b/net-mail/mu/Manifest
index 422f865a8e50..8e7443940a64 100644
--- a/net-mail/mu/Manifest
+++ b/net-mail/mu/Manifest
@@ -1,3 +1,4 @@
DIST mu-1.4.15.tar.gz 2309695 BLAKE2B 9808e59b758525937ec97e0ca6515108c1fb4287f3134d0c6038a74ef57b4992fede6b8957ba4e7e1681d8d307aec32fa6b2931e588004849e6c1dfb7da2f7f5 SHA512 dd0426c1fb7fe2430b47fc1232e067d1c017b3c428bbd8012c542f6e1ffa7741bb145c6851f40cbc945403534dabb4aa99faf369166167d187f083dde1d30546
DIST mu-1.4.15.tar.xz 846052 BLAKE2B 933d04696c4ac145f20ca6c84f6fbe62f70fa3e45e50dfdf2e48a7007acecc56d8650f965dc6810fc7f8bbdae6595b7b7349f2675b08cd9fb619ee9eb24eb251 SHA512 e7741b77bce5c7c1c818549e803fb386f0b8727b995a7ac9b961b74e89cc7dbeed52b45d70895995a1640cfd36a49b052eeeed9be6c48999f2182a68bf5c205e
DIST mu-1.6.1.tar.xz 866044 BLAKE2B ed6464e2ef63d37c42783235a0537cd20c7442333d4a6b59af0d257db8e3e6d85db7106ae2f89aa5f1536e50afadd40c89a8215a288080130d14e3ceb79b1638 SHA512 d894f302cabef86ff6b1d85eb945b2aca27729eaa6558598076c8f065d584592d5e601fe6a6045cea9b8a1466320c838f995ffdfd564447683538a5e48f8d7b0
+DIST mu-1.6.3.tar.xz 867224 BLAKE2B dffe67df4731028fa5e77d62d32fb787639b25d43a48aaac0c0e446c14cd3c5f79ad5559968446603782f1a7df9c129b2c3e1c3576e01d162a59693a2abd960e SHA512 73bfc85561cbc31d8c8ba6043ad79b7c17ac33edbbfcb3f09d460b291454c7696b282ee98c7738e05a9842963169c3f87eff56c3f6729cb22cdb6136ae8b95e3
diff --git a/net-mail/mu/mu-1.6.3.ebuild b/net-mail/mu/mu-1.6.3.ebuild
new file mode 100644
index 000000000000..94eaeb52fa23
--- /dev/null
+++ b/net-mail/mu/mu-1.6.3.ebuild
@@ -0,0 +1,60 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit elisp-common
+
+DESCRIPTION="Set of tools to deal with Maildirs, in particular, searching and indexing"
+HOMEPAGE="https://www.djcbsoftware.nl/code/mu/ https://github.com/djcb/mu"
+SRC_URI="https://github.com/djcb/mu/releases/download/${PV}/mu-${PV}.tar.xz"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86 ~x64-macos"
+IUSE="emacs guile readline"
+
+DEPEND="
+ dev-libs/glib:2
+ dev-libs/gmime:3.0
+ >=dev-libs/xapian-1.4:=
+ emacs? ( >=app-editors/emacs-25.3:* )
+ guile? ( >=dev-scheme/guile-2.2:* )
+ readline? ( sys-libs/readline:= )"
+RDEPEND="${DEPEND}"
+BDEPEND="virtual/pkgconfig"
+
+SITEFILE="70mu-gentoo-autoload.el"
+
+src_configure() {
+ local myeconfargs=(
+ $(use_enable emacs mu4e)
+ $(use_enable guile)
+ $(use_enable readline)
+ --disable-gtk
+ --disable-webkit
+ )
+
+ econf "${myeconfargs[@]}"
+}
+
+pkg_preinst() {
+ if [[ -n ${REPLACING_VERSIONS} ]]; then
+ elog "After upgrading from an old major version, you should"
+ elog "rebuild your mail index."
+ fi
+}
+
+pkg_postinst() {
+ if use emacs; then
+ einfo "To use mu4e you need to configure it in your .emacs file"
+ einfo "See the manual for more information:"
+ einfo "https://www.djcbsoftware.nl/code/mu/mu4e/"
+
+ elisp-site-regen
+ fi
+}
+
+pkg_postrm() {
+ use emacs && elisp-site-regen
+}