summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorCraig Andrews <candrews@gentoo.org>2023-02-27 09:13:36 -0500
committerCraig Andrews <candrews@gentoo.org>2023-02-27 09:24:41 -0500
commitadd5d781f12da8e7a447f055718dffe92450110b (patch)
tree0ca5787ccb293134f97adbc2ec0a699c11c29c27 /net-mail
parentnet-mail/onionrouter: Python 3.11 compatibility (diff)
downloadgentoo-add5d781f12da8e7a447f055718dffe92450110b.tar.gz
gentoo-add5d781f12da8e7a447f055718dffe92450110b.tar.bz2
gentoo-add5d781f12da8e7a447f055718dffe92450110b.zip
net-mail/onionrouter: EAPI=8
Signed-off-by: Craig Andrews <candrews@gentoo.org>
Diffstat (limited to 'net-mail')
-rw-r--r--net-mail/onionrouter/onionrouter-0.6.2-r1.ebuild50
-rw-r--r--net-mail/onionrouter/onionrouter-9999.ebuild4
2 files changed, 52 insertions, 2 deletions
diff --git a/net-mail/onionrouter/onionrouter-0.6.2-r1.ebuild b/net-mail/onionrouter/onionrouter-0.6.2-r1.ebuild
new file mode 100644
index 000000000000..f5a753cbc898
--- /dev/null
+++ b/net-mail/onionrouter/onionrouter-0.6.2-r1.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{9,10,11} )
+DISTUTILS_USE_PEP517=setuptools
+DISTUTILS_SINGLE_IMPL=1
+
+inherit distutils-r1 systemd
+
+DESCRIPTION=".onion discovery via SRV DNS lookups for use with postfix"
+HOMEPAGE="https://pypi.org/project/onionrouter/ https://github.com/ehloonion/onionrouter/"
+if [[ ${PV} == *9999 ]] ; then
+ SRC_URI=""
+ EGIT_REPO_URI="https://github.com/ehloonion/onionrouter.git"
+ inherit git-r3
+else
+ KEYWORDS="~amd64"
+ SRC_URI="https://pypi.io/packages/source/${PN::1}/${PN}/${P}.tar.gz"
+fi
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+LICENSE="GPL-3+"
+SLOT="0"
+
+RDEPEND="$(python_gen_cond_dep '
+ dev-python/dnspython[${PYTHON_USEDEP}]
+ dev-python/pyyaml[${PYTHON_USEDEP}]
+')"
+BDEPEND="$(python_gen_cond_dep '
+ test? (
+ dev-python/pytest[${PYTHON_USEDEP}]
+ dev-python/wheel[${PYTHON_USEDEP}]
+ )
+')"
+
+distutils_enable_tests pytest
+
+src_prepare() {
+ distutils-r1_src_prepare
+}
+
+src_install() {
+ distutils-r1_src_install
+ systemd_dounit "${FILESDIR}/${PN}.service"
+ insinto /etc/onionrouter
+ doins "${S}/onionrouter/configs/onionrouter.ini"
+}
diff --git a/net-mail/onionrouter/onionrouter-9999.ebuild b/net-mail/onionrouter/onionrouter-9999.ebuild
index 6e70759dfa0c..f5a753cbc898 100644
--- a/net-mail/onionrouter/onionrouter-9999.ebuild
+++ b/net-mail/onionrouter/onionrouter-9999.ebuild
@@ -1,11 +1,11 @@
# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
+EAPI=8
PYTHON_COMPAT=( python3_{9,10,11} )
+DISTUTILS_USE_PEP517=setuptools
DISTUTILS_SINGLE_IMPL=1
-DISTUTILS_USE_SETUPTOOLS=rdepend
inherit distutils-r1 systemd