summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Smith <matthew@gentoo.org>2022-04-02 10:27:30 +0100
committerMatthew Smith <matthew@gentoo.org>2022-04-02 10:28:02 +0100
commitba0c9a35185de0a8e42bad8e11b9e4540f0588e1 (patch)
treef5617e43ac977e94179d240a5c8c48d13d014a20 /net-mail
parentdev-games/poker-eval: fix HOMEPAGE, LICENSE (diff)
downloadgentoo-ba0c9a35185de0a8e42bad8e11b9e4540f0588e1.tar.gz
gentoo-ba0c9a35185de0a8e42bad8e11b9e4540f0588e1.tar.bz2
gentoo-ba0c9a35185de0a8e42bad8e11b9e4540f0588e1.zip
net-mail/mu: add 1.7.12
Closes: https://bugs.gentoo.org/836618 Signed-off-by: Matthew Smith <matthew@gentoo.org>
Diffstat (limited to 'net-mail')
-rw-r--r--net-mail/mu/Manifest1
-rw-r--r--net-mail/mu/files/mu-1.7.12-optional-mu4e.patch41
-rw-r--r--net-mail/mu/mu-1.7.12.ebuild83
3 files changed, 125 insertions, 0 deletions
diff --git a/net-mail/mu/Manifest b/net-mail/mu/Manifest
index 23706f595cfd..8b5188322ef3 100644
--- a/net-mail/mu/Manifest
+++ b/net-mail/mu/Manifest
@@ -1 +1,2 @@
DIST mu-1.6.10.tar.xz 867008 BLAKE2B 6cce22f18691c3ad6dda1ec012d72c398df2ba4d1beca70fc6f88d87aa9b749e2aa4c03f5c0e0d70f4f9978e2beb60ea02642b8ff71e86e0668df726e5923b52 SHA512 a51847b338afeff9c9fa88c4698df4b85289d017063cb5e3410eb967c605d8779618dcbd988e2d923a92291c1e0738ec84afecf017c76a63776149619d134887
+DIST mu-1.7.12.tar.xz 2129072 BLAKE2B 3518a361bc06b632899f9296ec211dc926a07973433247bf6f9ecfb069dcfd8b762f358aa32418276bf7dcba40bad768dd4599534613a1fae285cef9c6ceedd0 SHA512 fe0f41520959df7f78525317bf5caad4ae7f7468ac6291b84c48805e133883192458a8f79a929c0ebda2e45ec2014db1aa72650d0a6e176d7678449be36fc4f2
diff --git a/net-mail/mu/files/mu-1.7.12-optional-mu4e.patch b/net-mail/mu/files/mu-1.7.12-optional-mu4e.patch
new file mode 100644
index 000000000000..0f14bf3249e2
--- /dev/null
+++ b/net-mail/mu/files/mu-1.7.12-optional-mu4e.patch
@@ -0,0 +1,41 @@
+From 41e262b51968359074faac21fa80d2f1237c57cf Mon Sep 17 00:00:00 2001
+From: Matthew Smith <matthew@gentoo.org>
+Date: Sat, 2 Apr 2022 10:06:21 +0100
+Subject: [PATCH] build: add emacs option
+
+Without this option, mu4e will always be installed when Emacs is
+installed.
+---
+ meson.build | 2 +-
+ meson_options.txt | 5 +++++
+ 2 files changed, 6 insertions(+), 1 deletion(-)
+
+diff --git a/meson.build b/meson.build
+index 58ac9002..5f71d766 100644
+--- a/meson.build
++++ b/meson.build
+@@ -174,7 +174,7 @@ subdir('lib')
+ subdir('mu')
+ subdir('man')
+
+-if emacs.found()
++if get_option('emacs').enabled() and emacs.found()
+ subdir('mu4e')
+ endif
+
+diff --git a/meson_options.txt b/meson_options.txt
+index 0c70826e..34cb0c02 100644
+--- a/meson_options.txt
++++ b/meson_options.txt
+@@ -29,3 +29,8 @@ option('readline',
+ type: 'feature',
+ value: 'auto',
+ description: 'enable readline support for the mu4e repl')
++
++option('emacs',
++ type : 'feature',
++ value: 'disabled',
++ description: 'build mu4e')
+--
+2.35.1
+
diff --git a/net-mail/mu/mu-1.7.12.ebuild b/net-mail/mu/mu-1.7.12.ebuild
new file mode 100644
index 000000000000..02358e6b56c8
--- /dev/null
+++ b/net-mail/mu/mu-1.7.12.ebuild
@@ -0,0 +1,83 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit elisp-common meson
+
+DESCRIPTION="Set of tools to deal with Maildirs, in particular, searching and indexing"
+HOMEPAGE="https://www.djcbsoftware.nl/code/mu/ https://github.com/djcb/mu"
+SRC_URI="https://dev.gentoo.org/~matthew/distfiles/${P}.tar.xz"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86 ~x64-macos"
+IUSE="emacs readline"
+
+DEPEND="
+ dev-libs/glib:2
+ dev-libs/gmime:3.0
+ >=dev-libs/xapian-1.4:=
+ emacs? ( >=app-editors/emacs-25.3:* )
+ readline? ( sys-libs/readline:= )"
+RDEPEND="${DEPEND}"
+BDEPEND="
+ sys-apps/texinfo
+ virtual/pkgconfig
+"
+
+PATCHES=( "${FILESDIR}"/${PN}-1.7.12-optional-mu4e.patch )
+
+SITEFILE="70mu-gentoo-autoload.el"
+
+src_prepare() {
+ default
+
+ # Don't install NEWS.org into /usr/share/doc.
+ sed -i '/NEWS.org/,+1 d' meson.build || die
+
+ # Instead, put it in /usr/share/doc/${PF}.
+ sed -i "/MU_DOC_DIR/s/mu/${PF}/" mu4e/meson.build || die
+}
+
+src_configure() {
+ local emesonargs=(
+ $(meson_feature emacs)
+ $(meson_feature readline)
+ # NOTE: Guile interface is deprecated to be removed shortly.
+ -Dguile=disabled
+ -Dtoys=disabled
+ )
+ meson_src_configure
+}
+
+src_install() {
+ meson_src_install
+
+ # Since meson no longer installs NEWS.org, install it with dodoc.
+ # Also, it must be uncompressed so that it can be viewed with
+ # mu4e-info.
+ docompress -x /usr/share/doc/${PF}/NEWS.org
+ dodoc NEWS.org
+}
+
+pkg_preinst() {
+ if [[ -n ${REPLACING_VERSIONS} ]]; then
+ elog "After upgrading from an old major version, you should"
+ elog "rebuild your mail index."
+ fi
+}
+
+pkg_postinst() {
+ if use emacs; then
+ einfo "To use mu4e you need to configure it in your .emacs file"
+ einfo "See the manual for more information:"
+ einfo "https://www.djcbsoftware.nl/code/mu/mu4e/"
+
+ elisp-site-regen
+ fi
+}
+
+pkg_postrm() {
+ use emacs && elisp-site-regen
+}