summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2023-03-18 21:54:02 +0000
committerSam James <sam@gentoo.org>2023-03-18 21:54:38 +0000
commitc56bfb9f4f4b728f0d9e47f1aac0be355ad5e1b3 (patch)
treef6eccbe2435e7e3649c461a4de7f893bebf2e8af /net-mail
parentnet-mail/fdm: drop 2.0-r1, 2.1 (diff)
downloadgentoo-c56bfb9f4f4b728f0d9e47f1aac0be355ad5e1b3.tar.gz
gentoo-c56bfb9f4f4b728f0d9e47f1aac0be355ad5e1b3.tar.bz2
gentoo-c56bfb9f4f4b728f0d9e47f1aac0be355ad5e1b3.zip
net-mail/fdm: fix configure w/ clang 16, fix strlcpy check
Closes: https://bugs.gentoo.org/731262 Thanks-to: Markus Peloquin <markus@cs.wisc.edu> Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'net-mail')
-rw-r--r--net-mail/fdm/fdm-2.2-r1.ebuild (renamed from net-mail/fdm/fdm-2.2.ebuild)8
-rw-r--r--net-mail/fdm/files/fdm-2.2-configure-strlcpy.patch20
2 files changed, 28 insertions, 0 deletions
diff --git a/net-mail/fdm/fdm-2.2.ebuild b/net-mail/fdm/fdm-2.2-r1.ebuild
index 895dd72d1b2c..cac36667dc18 100644
--- a/net-mail/fdm/fdm-2.2.ebuild
+++ b/net-mail/fdm/fdm-2.2-r1.ebuild
@@ -3,6 +3,8 @@
EAPI=8
+inherit autotools
+
DESCRIPTION="Fetch, filter and deliver mail"
HOMEPAGE="https://github.com/nicm/fdm"
SRC_URI="https://github.com/nicm/fdm/releases/download/${PV}/${P}.tar.gz"
@@ -25,11 +27,17 @@ RDEPEND="
DOCS=( CHANGES README TODO MANUAL )
+PATCHES=(
+ "${FILESDIR}"/${PN}-2.2-configure-strlcpy.patch
+)
+
src_prepare() {
default
# Change user '_fdm' to 'fdm'
sed -e 's/_fdm/fdm/g' -i fdm.h || die
+
+ eautoreconf
}
src_configure() {
diff --git a/net-mail/fdm/files/fdm-2.2-configure-strlcpy.patch b/net-mail/fdm/files/fdm-2.2-configure-strlcpy.patch
new file mode 100644
index 000000000000..443a7240c40a
--- /dev/null
+++ b/net-mail/fdm/files/fdm-2.2-configure-strlcpy.patch
@@ -0,0 +1,20 @@
+diff --git a/configure.ac b/configure.ac
+index e356e9c..d91ae66 100644
+--- a/configure.ac
++++ b/configure.ac
+@@ -124,13 +124,13 @@ if test "x$found_libssl" = xno; then
+ AC_MSG_ERROR("libssl not found")
+ fi
+
+-AC_CHECK_DECL(strlcpy, found_strlcpy=yes, found_strlcpy=no)
++AC_CHECK_FUNC(strlcpy, found_strlcpy=yes, found_strlcpy=no)
+ if test "x$found_strlcpy" = xyes; then
+ AC_DEFINE(HAVE_STRLCPY)
+ fi
+ AM_CONDITIONAL(NO_STRLCPY, [test "x$found_strlcpy" = xno])
+
+-AC_CHECK_DECL(strlcat, found_strlcat=yes, found_strlcat=no)
++AC_CHECK_FUNC(strlcat, found_strlcat=yes, found_strlcat=no)
+ if test "x$found_strlcat" = xyes; then
+ AC_DEFINE(HAVE_STRLCAT)
+ fi