summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatt Smith <matt@offtopica.uk>2021-09-05 10:17:07 +0100
committerSam James <sam@gentoo.org>2021-09-08 04:11:07 +0100
commitd31f65dc64ccdf2ad5736319c188261f2e81ef7f (patch)
tree43fb3d22f56c04220a7443f515d2f9ac1226bc83 /net-mail
parentnet-mail/mu: Drop old (diff)
downloadgentoo-d31f65dc64ccdf2ad5736319c188261f2e81ef7f.tar.gz
gentoo-d31f65dc64ccdf2ad5736319c188261f2e81ef7f.tar.bz2
gentoo-d31f65dc64ccdf2ad5736319c188261f2e81ef7f.zip
net-mail/mu: Bump to 1.6.6
Package-Manager: Portage-3.0.22, Repoman-3.0.3 Signed-off-by: Matt Smith <matt@offtopica.uk> Closes: https://github.com/gentoo/gentoo/pull/22218 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'net-mail')
-rw-r--r--net-mail/mu/Manifest1
-rw-r--r--net-mail/mu/mu-1.6.6.ebuild60
2 files changed, 61 insertions, 0 deletions
diff --git a/net-mail/mu/Manifest b/net-mail/mu/Manifest
index a5be2e0a8a9f..9ca96b3dacea 100644
--- a/net-mail/mu/Manifest
+++ b/net-mail/mu/Manifest
@@ -1,3 +1,4 @@
DIST mu-1.6.1.tar.xz 866044 BLAKE2B ed6464e2ef63d37c42783235a0537cd20c7442333d4a6b59af0d257db8e3e6d85db7106ae2f89aa5f1536e50afadd40c89a8215a288080130d14e3ceb79b1638 SHA512 d894f302cabef86ff6b1d85eb945b2aca27729eaa6558598076c8f065d584592d5e601fe6a6045cea9b8a1466320c838f995ffdfd564447683538a5e48f8d7b0
DIST mu-1.6.3.tar.xz 867224 BLAKE2B dffe67df4731028fa5e77d62d32fb787639b25d43a48aaac0c0e446c14cd3c5f79ad5559968446603782f1a7df9c129b2c3e1c3576e01d162a59693a2abd960e SHA512 73bfc85561cbc31d8c8ba6043ad79b7c17ac33edbbfcb3f09d460b291454c7696b282ee98c7738e05a9842963169c3f87eff56c3f6729cb22cdb6136ae8b95e3
DIST mu-1.6.5.tar.xz 867240 BLAKE2B d3e8ad88b38f1329e4a5716f981c97e62c2042835e81910dab02b1219abfc670fe84a68f992fd08dce282a3288aaa91a465ce881f79e7ece917ba089c2ad0348 SHA512 b25203d281fa43b22abacb442caa56d797489d32bfc1dde874d23035510cbc8fb331b45574ea74d4a01e4af0a706c1a84656d8b8d6e60f518b2ea75fa27361ea
+DIST mu-1.6.6.tar.xz 866724 BLAKE2B 3417d4b3e5bfae943558fbc936ca0207be912f9548621b1599437484e94f3b49271aa1e97e7cc2b5b6027b8e0cf97d3b96d2052772f7783d897b4fa0dcf03184 SHA512 07daf9864bfd1ff4278aee98a0ae9c4fc3be94468e3b2022ae801f048f339b5becdb9ad8ebb2e12b9131e0e6dfcfb541bdca8288657dc19d47b0e510831f54eb
diff --git a/net-mail/mu/mu-1.6.6.ebuild b/net-mail/mu/mu-1.6.6.ebuild
new file mode 100644
index 000000000000..94eaeb52fa23
--- /dev/null
+++ b/net-mail/mu/mu-1.6.6.ebuild
@@ -0,0 +1,60 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit elisp-common
+
+DESCRIPTION="Set of tools to deal with Maildirs, in particular, searching and indexing"
+HOMEPAGE="https://www.djcbsoftware.nl/code/mu/ https://github.com/djcb/mu"
+SRC_URI="https://github.com/djcb/mu/releases/download/${PV}/mu-${PV}.tar.xz"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86 ~x64-macos"
+IUSE="emacs guile readline"
+
+DEPEND="
+ dev-libs/glib:2
+ dev-libs/gmime:3.0
+ >=dev-libs/xapian-1.4:=
+ emacs? ( >=app-editors/emacs-25.3:* )
+ guile? ( >=dev-scheme/guile-2.2:* )
+ readline? ( sys-libs/readline:= )"
+RDEPEND="${DEPEND}"
+BDEPEND="virtual/pkgconfig"
+
+SITEFILE="70mu-gentoo-autoload.el"
+
+src_configure() {
+ local myeconfargs=(
+ $(use_enable emacs mu4e)
+ $(use_enable guile)
+ $(use_enable readline)
+ --disable-gtk
+ --disable-webkit
+ )
+
+ econf "${myeconfargs[@]}"
+}
+
+pkg_preinst() {
+ if [[ -n ${REPLACING_VERSIONS} ]]; then
+ elog "After upgrading from an old major version, you should"
+ elog "rebuild your mail index."
+ fi
+}
+
+pkg_postinst() {
+ if use emacs; then
+ einfo "To use mu4e you need to configure it in your .emacs file"
+ einfo "See the manual for more information:"
+ einfo "https://www.djcbsoftware.nl/code/mu/mu4e/"
+
+ elisp-site-regen
+ fi
+}
+
+pkg_postrm() {
+ use emacs && elisp-site-regen
+}