summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2021-05-06 22:44:21 +0000
committerSam James <sam@gentoo.org>2021-05-06 23:26:17 +0000
commitf2b08a02bdc724992071e52b60e356ee9fcd0759 (patch)
treeba0476eb4f10e8841fc3fefe6517b830db3b391f /net-mail
parentnet-mail/cyrus-imapd: fix metadata indentation (diff)
downloadgentoo-f2b08a02bdc724992071e52b60e356ee9fcd0759.tar.gz
gentoo-f2b08a02bdc724992071e52b60e356ee9fcd0759.tar.bz2
gentoo-f2b08a02bdc724992071e52b60e356ee9fcd0759.zip
net-mail/cyrus-imapd: add 3.0.15
Bug: https://bugs.gentoo.org/738280 Bug: https://bugs.gentoo.org/740188 Bug: https://bugs.gentoo.org/738278 Bug: https://bugs.gentoo.org/738276 Bug: https://bugs.gentoo.org/356341 Bug: https://bugs.gentoo.org/688242 Bug: https://bugs.gentoo.org/721466 Bug: https://bugs.gentoo.org/662896 Bug: https://bugs.gentoo.org/687864 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'net-mail')
-rw-r--r--net-mail/cyrus-imapd/Manifest1
-rw-r--r--net-mail/cyrus-imapd/cyrus-imapd-3.0.15.ebuild229
2 files changed, 230 insertions, 0 deletions
diff --git a/net-mail/cyrus-imapd/Manifest b/net-mail/cyrus-imapd/Manifest
index 28db78e6cf6d..9024ddcaa103 100644
--- a/net-mail/cyrus-imapd/Manifest
+++ b/net-mail/cyrus-imapd/Manifest
@@ -1,2 +1,3 @@
DIST cyrus-imapd-3.0.13.tar.gz 10840005 BLAKE2B f4790837a198673b42d553bc7cbc825456ff5a3d1d14ff382ca0f40252d09eb355f92c2020c0a974cc99eda9af4323a3a5b9428375288bf8892dfba35602da4e SHA512 5cd066916797efb975cdb97720f65edc72d3fe82afbd78a26aa8369d95ae4ca09c0593dd4bec5521156c64ea38af7a13065f3b35447a76267dec93feb0ac6ac6
DIST cyrus-imapd-3.0.14.tar.gz 10865880 BLAKE2B 36f3e60d715d2eab430040964e93cb332cfc4d9097f0f863b94325eb4eb964a4030d1d0f8ddb7870a08b655e1694bbc751d5aab99af6670ab33ad6747f55f6bd SHA512 0bade56f4f7834ef51efc4081f2915bf0f98a2a555cd1b847f13a34418e4c52f2abcb4018906c144c161241433a8ff9ddc6d88499804d3fe616a05f186a3f209
+DIST cyrus-imapd-3.0.15.tar.gz 10843341 BLAKE2B efe65c7afc7d63770adef9e4ea13b87e3b7fdd1847e4ada028175999b31ebb84f9d84b014018bd2be3fee9af1b5e81dd08f63225bc62dc5a4fd4a0791da16594 SHA512 2f65209095f086092fec0bfc9547c999a6e568cccc0a4164e7a3751fe2881f47bbbbd67ba9c9169feafead8c40d42f594d34171d911e4028425cfd8ba72d8f4a
diff --git a/net-mail/cyrus-imapd/cyrus-imapd-3.0.15.ebuild b/net-mail/cyrus-imapd/cyrus-imapd-3.0.15.ebuild
new file mode 100644
index 000000000000..621e5456a13b
--- /dev/null
+++ b/net-mail/cyrus-imapd/cyrus-imapd-3.0.15.ebuild
@@ -0,0 +1,229 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+inherit autotools flag-o-matic pam ssl-cert
+
+DESCRIPTION="The Cyrus IMAP Server"
+HOMEPAGE="https://www.cyrusimap.org/"
+SRC_URI="https://github.com/cyrusimap/${PN}/releases/download/${P}/${P}.tar.gz"
+
+LICENSE="BSD-with-attribution GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE="afs backup calalarm caps clamav http kerberos ldap lmdb \
+ mysql nntp pam perl postgres replication +server sieve snmp \
+ sqlite ssl static-libs tcpd test xapian"
+RESTRICT="!test? ( test )"
+
+CDEPEND="
+ sys-libs/zlib:0=
+ dev-libs/libpcre:3
+ >=dev-libs/cyrus-sasl-2.1.13:2
+ dev-libs/jansson
+ dev-libs/icu:0=
+ sys-libs/e2fsprogs-libs
+ afs? ( net-fs/openafs )
+ calalarm? ( dev-libs/libical:0= )
+ caps? ( sys-libs/libcap )
+ clamav? ( app-antivirus/clamav )
+ http? ( dev-libs/libxml2:2 dev-libs/libical:0= net-libs/nghttp2 )
+ kerberos? ( virtual/krb5 )
+ ldap? ( net-nds/openldap )
+ lmdb? ( dev-db/lmdb:0= )
+ mysql? ( dev-db/mysql-connector-c:0= )
+ nntp? ( !net-nntp/leafnode )
+ pam? (
+ sys-libs/pam
+ >=net-mail/mailbase-1
+ )
+ perl? ( dev-lang/perl:= )
+ postgres? ( dev-db/postgresql:* )
+ snmp? ( >=net-analyzer/net-snmp-5.2.2-r1:0= )
+ ssl? ( >=dev-libs/openssl-1.0.1e:0=[-bindist] )
+ sqlite? ( dev-db/sqlite:3 )
+ tcpd? ( >=sys-apps/tcp-wrappers-7.6
+ snmp? ( net-analyzer/net-snmp:0=[tcpd=] )
+ )
+ xapian? ( >=dev-libs/xapian-1.4.0:0= )
+"
+DEPEND="${CDEPEND}
+ test? ( dev-util/cunit )
+"
+
+# all blockers really needed?
+# file collision with app-arch/dump - bug 619584
+RDEPEND="${CDEPEND}
+ acct-group/mail
+ acct-user/cyrus
+ !mail-mta/courier
+ !net-mail/bincimap
+ !net-mail/courier-imap
+ !net-mail/uw-imap
+ !app-arch/dump
+"
+
+REQUIRED_USE="
+ afs? ( kerberos )
+ backup? ( sqlite )
+ calalarm? ( http )
+ http? ( sqlite )
+"
+
+# https://bugs.gentoo.org/678754
+# TODO: check underlinking for other libraries
+PATCHES=(
+ "${FILESDIR}/cyrus-imapd-libcap-libs-r1.patch"
+ )
+
+pkg_setup() {
+ # https://bugs.gentoo.org/604466
+ append-ldflags $(no-as-needed)
+}
+
+src_prepare() {
+ default
+ # Fix master(8)->cyrusmaster(8) manpage.
+ for i in `grep -rl -e 'master\.8' -e 'master(8)' "${S}"` ; do
+ sed -i -e 's:master\.8:cyrusmaster.8:g' \
+ -e 's:master(8):cyrusmaster(8):g' \
+ "${i}" || die "sed failed" || die "sed failed"
+ done
+ mv man/master.8 man/cyrusmaster.8 || die "mv failed"
+ sed -i -e "s:MASTER:CYRUSMASTER:g" \
+ -e "s:Master:Cyrusmaster:g" \
+ -e "s:master:cyrusmaster:g" \
+ man/cyrusmaster.8 || die "sed failed"
+
+ # lock.h to afs/lock.h
+ sed -i -e '/lock.h/s:lock.h:afs/lock.h:' \
+ ptclient/afskrb.c || die
+
+ eautoreconf
+}
+
+src_configure() {
+ local myconf
+ if use afs ; then
+ myconf+=" --with-afs-libdir=/usr/$(get_libdir)"
+ myconf+=" --with-afs-incdir=/usr/include/afs"
+ fi
+ # sphinx is unmaintained and dead, bug #662944
+ econf \
+ --enable-unit-tests \
+ --enable-murder \
+ --enable-idled \
+ --enable-event-notification \
+ --enable-autocreate \
+ --enable-pcre \
+ --with-com_err \
+ --with-cyrus-user=cyrus \
+ --with-sasl \
+ --without-krb \
+ --without-krbdes \
+ --disable-sphinx \
+ --enable-squat \
+ --with-zlib \
+ $(use_enable afs) \
+ $(use_enable afs krb5afspts) \
+ $(use_enable backup) \
+ $(use_enable calalarm calalarmd) \
+ $(use_with caps libcap) \
+ $(use_with clamav) \
+ $(use_enable nntp) \
+ $(use_enable http) \
+ $(use_with http nghttp2) \
+ $(use_enable replication) \
+ $(use_enable kerberos gssapi) \
+ $(use_with ldap) \
+ $(use_with lmdb) \
+ $(use_with mysql) \
+ $(use_with postgres pgsql) \
+ $(use_with perl) \
+ $(use_with sqlite) \
+ $(use_with ssl openssl) \
+ $(use_enable server) \
+ $(use_enable sieve) \
+ $(use_with snmp) \
+ $(use_enable static-libs static) \
+ $(use_with tcpd libwrap) \
+ $(use_enable xapian) \
+ ${myconf}
+}
+
+src_install() {
+ emake DESTDIR="${D}" INSTALLDIRS=vendor install
+
+ dodoc README*
+ dodoc -r doc
+ cp -r contrib tools "${D}/usr/share/doc/${PF}"
+ rm -f doc/text/Makefile*
+
+ mv "${D}"/usr/libexec/{master,cyrusmaster} || die
+
+ insinto /etc
+ newins "${D}/usr/share/doc/${PF}/doc/examples/cyrus_conf/normal.conf" cyrus.conf
+ newins "${D}/usr/share/doc/${PF}/doc/examples/imapd_conf/normal.conf" imapd.conf
+
+ sed -i -e '/^configdirectory/s|/var/.*|/var/imap|' \
+ -e '/^partition-default/s|/var/.*|/var/spool/imap|' \
+ -e '/^sievedir/s|/var/.*|/var/imap/sieve|' \
+ "${D}"/etc/imapd.conf
+
+ sed -i -e 's|/var/imap/socket/lmtp|/run/cyrus/socket/lmtp|' \
+ -e 's|/var/imap/socket/notify|/run/cyrus/socket/notify|' \
+ "${D}"/etc/cyrus.conf
+
+ # turn off sieve if not installed
+ if ! use sieve; then
+ sed -i -e "/sieve/s/^/#/" "${D}/etc/cyrus.conf" || die
+ fi
+ # same thing for http(s) as well
+ if ! use http; then
+ sed -i -e "/http/s/^/#/" "${D}/etc/cyrus.conf" || die
+ fi
+
+ newinitd "${FILESDIR}/cyrus.rc8" cyrus
+ newconfd "${FILESDIR}/cyrus.confd" cyrus
+ newpamd "${FILESDIR}/cyrus.pam-include" sieve
+
+ for subdir in imap/{,db,log,msg,proc,socket,sieve} spool/imap/{,stage.} ; do
+ keepdir "/var/${subdir}"
+ fowners cyrus:mail "/var/${subdir}"
+ fperms 0750 "/var/${subdir}"
+ done
+ for subdir in imap/{user,quota,sieve} spool/imap ; do
+ for i in a b c d e f g h i j k l m n o p q r s t v u w x y z ; do
+ keepdir "/var/${subdir}/${i}"
+ fowners cyrus:mail "/var/${subdir}/${i}"
+ fperms 0750 "/var/${subdir}/${i}"
+ done
+ done
+}
+
+pkg_preinst() {
+ if ! has_version ${CATEGORY}/${PN} ; then
+ elog "For correct logging add the following to /etc/syslog.conf:"
+ elog " local6.* /var/log/imapd.log"
+ elog " auth.debug /var/log/auth.log"
+ echo
+
+ elog "You have to add user cyrus to the sasldb2. Do this with:"
+ elog " saslpasswd2 cyrus"
+ fi
+}
+
+pkg_postinst() {
+ # do not install server.{key,pem) if they exist
+ if use ssl ; then
+ if [ ! -f "${ROOT}"/etc/ssl/cyrus/server.key ]; then
+ install_cert /etc/ssl/cyrus/server
+ chown cyrus:mail "${ROOT}"/etc/ssl/cyrus/server.{key,pem}
+ fi
+ fi
+
+ echo
+ einfo "Please see https://www.cyrusimap.org/imap/download/upgrade.html"
+ einfo "for upgrade instructions."
+ echo
+}