summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2022-05-20 04:16:27 +0100
committerSam James <sam@gentoo.org>2022-05-20 04:16:27 +0100
commitf325f07e22949e2155fbbfe982b5af12859b3950 (patch)
tree6a4d6ce628631af19913f0e612f5e3e5e697ef57 /net-mail
parentRevert "net-im/discord-bin: add maintainer; tidy ebuild" (diff)
downloadgentoo-f325f07e22949e2155fbbfe982b5af12859b3950.tar.gz
gentoo-f325f07e22949e2155fbbfe982b5af12859b3950.tar.bz2
gentoo-f325f07e22949e2155fbbfe982b5af12859b3950.zip
net-mail/getmail: add 6.18.9
Closes: https://bugs.gentoo.org/846146 Closes: https://bugs.gentoo.org/822747 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'net-mail')
-rw-r--r--net-mail/getmail/Manifest1
-rw-r--r--net-mail/getmail/getmail-6.18.9.ebuild27
2 files changed, 28 insertions, 0 deletions
diff --git a/net-mail/getmail/Manifest b/net-mail/getmail/Manifest
index ad55d6588a7d..f280e4d006f2 100644
--- a/net-mail/getmail/Manifest
+++ b/net-mail/getmail/Manifest
@@ -1 +1,2 @@
DIST getmail-6.14.tar.gz 185308 BLAKE2B c74fce627e6a23e0b209dddca690301f80626d9c4489d8cd2391884908e6f1c017602ed23ca4d343e2dd400b911d3f808235231217afd38f96017d8f0d20b3a2 SHA512 b8d2df52cbf145ee7e00ec1dbf589013d3caf8e39a3981e6ae4f1e36fe0b3d3d88df639e03e8697c39e6d00e20ddf1e995ed17f0b1fa1fa2ea52a803c16f062f
+DIST getmail-6.18.9.tar.gz 204488 BLAKE2B 4bf95cec36ce10d5fd6c9fbb6b96923915a13f4b339a9846caafc5602a56612fb9f4b7209a138a03b81b19b7d28328bb46c60165215384650e7dcf98294cc5fa SHA512 dfeaebbca0c8766a16783d27171e65595d97a4b557943677dd7e7a66a9da8b49dfdbfb4aba9655ce3815ff6e2f991905317085b156ba6dbac841bb0fbb26c8b5
diff --git a/net-mail/getmail/getmail-6.18.9.ebuild b/net-mail/getmail/getmail-6.18.9.ebuild
new file mode 100644
index 000000000000..473959e43c57
--- /dev/null
+++ b/net-mail/getmail/getmail-6.18.9.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_SINGLE_IMPL=1
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} )
+PYTHON_REQ_USE="ssl"
+inherit distutils-r1
+
+DESCRIPTION="A mail retriever with reliable Maildir and mbox delivery"
+HOMEPAGE="https://www.getmail6.org/ https://github.com/getmail6/getmail6"
+SRC_URI="https://github.com/getmail6/getmail6/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}/getmail6-${PV}"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+python_prepare_all() {
+ # Use gentoo version number (including revision) for doc dir and remove COPYING file
+ sed -i -e "s,'getmail-%s' % __version__,'${PF}'," \
+ -e "/docs\/COPYING/d" "${S}"/setup.py || die
+
+ distutils-r1_python_prepare_all
+}