summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBernard Cafarelli <voyageur@gentoo.org>2022-05-20 14:31:02 +0200
committerBernard Cafarelli <voyageur@gentoo.org>2022-05-20 14:31:02 +0200
commitfd62598230039b7ecc721e72f2af6c91588a54a0 (patch)
treee52f049bc2e075b48676f312f859694d9eac8d1f /net-mail
parentnet-mail/fetchmail: drop 7.0.0_alpha9-r1 (diff)
downloadgentoo-fd62598230039b7ecc721e72f2af6c91588a54a0.tar.gz
gentoo-fd62598230039b7ecc721e72f2af6c91588a54a0.tar.bz2
gentoo-fd62598230039b7ecc721e72f2af6c91588a54a0.zip
net-mail/fetchmail: add 6.4.30
Signed-off-by: Bernard Cafarelli <voyageur@gentoo.org>
Diffstat (limited to 'net-mail')
-rw-r--r--net-mail/fetchmail/Manifest1
-rw-r--r--net-mail/fetchmail/fetchmail-6.4.30.ebuild107
2 files changed, 108 insertions, 0 deletions
diff --git a/net-mail/fetchmail/Manifest b/net-mail/fetchmail/Manifest
index 85c305cee130..7b14d1c5cfe4 100644
--- a/net-mail/fetchmail/Manifest
+++ b/net-mail/fetchmail/Manifest
@@ -1,3 +1,4 @@
DIST fetchmail-6.4.21.tar.xz 1318996 BLAKE2B 4c2befad2b7dfa6957889e029572c259be7a20e4b54b864e2cca827540d745a57ad227f8e1fce1336e8f3a1005c780d8fa7c1b10b9ee05ce68dbcfac75afa179 SHA512 c9300f63c0e4073f199a9a7d9061774a7f88aad496b696cad96c0ee85107cae506461f0cd083903c60104b1e7654461213f3f759c1cdaffaf1c85fb1956faa67
DIST fetchmail-6.4.22.tar.xz 1330176 BLAKE2B 7086f8a3df263f68ae2034321f63c40fcf4759517f46c67ba4b5d3b33ba07d3bb4f512d749a67a2d76991b46847b6dd9df0795a7a28e8166842454001497cfc9 SHA512 ff6db2705b6e3806e22c326da8a0f6bdc0909965cd283b50f9d55bd3a18a52fc4b2f4b4afece1e81aa25b6f1037450cb2b579c4d2cfe4705d34b31d4c1a47e00
DIST fetchmail-6.4.27.tar.xz 1326668 BLAKE2B fb349f8e4b17929d8ab5ec144e2d6e4227b56143112eb3745830c339f8dfdaa80fb47060ad3671258563198ed1283a903fcd5a82564b7320a829ceb4c5826642 SHA512 75650c2a8bcfa6f4364dacd6964f00848a23e1bc96eed10f7fcfd9c8c6f6b6fe60eee2730c57c8a5263c11f01b3031cbef7d6b2bffa730de63e7ec262448af2f
+DIST fetchmail-6.4.30.tar.xz 1333524 BLAKE2B 67e6aff00b1678ad68a4539c40147c79fbb22970248a97fd16340dbc64e90339a476ea322afde7345858b7041a00364e181af37dc96a09dcdca2e096f62922ea SHA512 0ec540c4102267e6e72fefa5e76aa76f45d25a0e68ec40f1fd834719f2a4b5f3f78c587b050fc33d97dd8fc6f674950949e5c23f960ebcd3046d5cc2e06db1d0
diff --git a/net-mail/fetchmail/fetchmail-6.4.30.ebuild b/net-mail/fetchmail/fetchmail-6.4.30.ebuild
new file mode 100644
index 000000000000..98b1ae2dae89
--- /dev/null
+++ b/net-mail/fetchmail/fetchmail-6.4.30.ebuild
@@ -0,0 +1,107 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..10} )
+PYTHON_REQ_USE="tk"
+
+inherit autotools python-single-r1 systemd tmpfiles toolchain-funcs
+
+DESCRIPTION="the legendary remote-mail retrieval and forwarding utility"
+HOMEPAGE="https://www.fetchmail.info/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.xz"
+
+LICENSE="GPL-2 public-domain"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~sparc-solaris ~x64-solaris ~x86-solaris"
+IUSE="ssl nls kerberos tk socks"
+REQUIRED_USE="tk? ( ${PYTHON_REQUIRED_USE} )"
+
+RDEPEND="acct-user/fetchmail
+ ssl? (
+ >=dev-libs/openssl-1.1.1:=
+ )
+ kerberos? (
+ virtual/krb5
+ >=dev-libs/openssl-1.0.2:=
+ )
+ nls? ( virtual/libintl )
+ !elibc_glibc? ( sys-fs/e2fsprogs )
+ socks? ( net-proxy/dante )
+ tk? (
+ ${PYTHON_DEPS}
+ $(python_gen_cond_dep '
+ dev-python/future[${PYTHON_USEDEP}]
+ ')
+ )"
+DEPEND="${RDEPEND}
+ app-arch/xz-utils
+ sys-devel/flex
+ nls? ( sys-devel/gettext )"
+
+DOCS="FAQ FEATURES NEWS NOTES README README.NTLM README.SSL* TODO"
+HTML_DOCS="*.html"
+PATCHES=(
+ "${FILESDIR}"/${PN}-6.3.26-python-optional.patch
+)
+S=${WORKDIR}/${P/_/.}
+
+pkg_setup() {
+ use tk && python-single-r1_pkg_setup
+}
+
+src_prepare() {
+ default
+ # don't compile during src_install
+ use tk && : > "${S}"/py-compile
+ eautoreconf
+}
+
+src_configure() {
+ use tk || export PYTHON=:
+
+ econf \
+ --enable-RPA \
+ --enable-NTLM \
+ --enable-SDPS \
+ $(use_enable nls) \
+ $(use_with ssl ssl "${EPREFIX}/usr") \
+ $(use kerberos && echo "--with-ssl=${EPREFIX}/usr") \
+ $(use_with kerberos gssapi) \
+ $(use_with kerberos kerberos5) \
+ --without-hesiod \
+ $(use_with socks)
+}
+
+src_compile() {
+ emake AR="$(tc-getAR)"
+}
+
+src_install() {
+ default
+
+ newinitd "${FILESDIR}"/fetchmail.initd fetchmail
+ newconfd "${FILESDIR}"/fetchmail.confd fetchmail
+
+ systemd_dounit "${FILESDIR}"/${PN}.service
+ systemd_newunit "${FILESDIR}"/${PN}_at.service "${PN}@.service"
+ dotmpfiles "${FILESDIR}"/${PN}.conf
+
+ docinto contrib
+ local f
+ for f in contrib/* ; do
+ [ -f "${f}" ] && dodoc "${f}"
+ done
+
+ use tk && python_optimize
+}
+
+pkg_postinst() {
+ tmpfiles_process ${PN}.conf
+
+ if [[ -z ${REPLACING_VERSIONS} ]]; then
+ elog "Please see /etc/conf.d/fetchmail if you want to adjust"
+ elog "the polling delay used by the fetchmail init script."
+ fi
+}