summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIonen Wolkens <ionen@gentoo.org>2022-10-08 23:03:34 -0400
committerIonen Wolkens <ionen@gentoo.org>2022-10-08 23:04:29 -0400
commite4d6a81f314188398073db01332e408109c2844b (patch)
tree7d2a2e0caa584e33bee4fa1a6bbd26a2da9c747c /net-misc/aggregate
parentnet-misc/utelnetd: fix build with upcoming clang16 (diff)
downloadgentoo-e4d6a81f314188398073db01332e408109c2844b.tar.gz
gentoo-e4d6a81f314188398073db01332e408109c2844b.tar.bz2
gentoo-e4d6a81f314188398073db01332e408109c2844b.zip
net-misc/aggregate: EAPI6->8, fix configure with upcoming clang16
eautoreconf also removes the need for tc-export Closes: https://bugs.gentoo.org/871198 Signed-off-by: Ionen Wolkens <ionen@gentoo.org>
Diffstat (limited to 'net-misc/aggregate')
-rw-r--r--net-misc/aggregate/aggregate-1.6.ebuild19
1 files changed, 10 insertions, 9 deletions
diff --git a/net-misc/aggregate/aggregate-1.6.ebuild b/net-misc/aggregate/aggregate-1.6.ebuild
index b2a89cb1988e..ff5e7181db2a 100644
--- a/net-misc/aggregate/aggregate-1.6.ebuild
+++ b/net-misc/aggregate/aggregate-1.6.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI=8
-inherit toolchain-funcs
+inherit autotools
DESCRIPTION="Perform two optimisations on a list of prefixes to reduce the length of the list"
HOMEPAGE="https://ftp.isc.org/isc/aggregate"
@@ -12,16 +12,17 @@ SRC_URI="https://ftp.isc.org/isc/aggregate/${P}.tar.gz"
LICENSE="ISC"
SLOT="0"
KEYWORDS="~alpha amd64 ~hppa ~ia64 ~mips ppc sparc x86"
-IUSE=""
RDEPEND="dev-lang/perl"
-DEPEND=""
-PATCHES=( "${FILESDIR}/${P}-build-fixup.patch" )
+PATCHES=(
+ "${FILESDIR}"/${P}-build-fixup.patch
+)
-src_configure() {
- tc-export CC
- econf
+src_prepare() {
+ default
+
+ eautoreconf #871198
}
src_install() {