summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPPed72 <paolo.pedroni@iol.it>2021-02-04 12:56:56 +0100
committerThomas Deutschmann <whissi@gentoo.org>2021-02-04 23:30:41 +0100
commit4c9ea05c8deae4ba480e34a3cd51be1b334f9852 (patch)
treebc9ac8969a1bb169030b6a16067b815da7deb922 /net-misc/anydesk/anydesk-6.1.0.ebuild
parentsys-cluster/galera: remove unused patches (diff)
downloadgentoo-4c9ea05c8deae4ba480e34a3cd51be1b334f9852.tar.gz
gentoo-4c9ea05c8deae4ba480e34a3cd51be1b334f9852.tar.bz2
gentoo-4c9ea05c8deae4ba480e34a3cd51be1b334f9852.zip
net-misc/anydesk: Version bump to 6.1.0
No more 32-bit version. Closes: https://bugs.gentoo.org/768639 Signed-off-by: Paolo Pedroni <paolo.pedroni@iol.it> Package-Manager: Portage-3.0.13, Repoman-3.0.2 Closes: https://github.com/gentoo/gentoo/pull/19318 Signed-off-by: Thomas Deutschmann <whissi@gentoo.org>
Diffstat (limited to 'net-misc/anydesk/anydesk-6.1.0.ebuild')
-rw-r--r--net-misc/anydesk/anydesk-6.1.0.ebuild112
1 files changed, 112 insertions, 0 deletions
diff --git a/net-misc/anydesk/anydesk-6.1.0.ebuild b/net-misc/anydesk/anydesk-6.1.0.ebuild
new file mode 100644
index 000000000000..84f711fbaf94
--- /dev/null
+++ b/net-misc/anydesk/anydesk-6.1.0.ebuild
@@ -0,0 +1,112 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="7"
+
+inherit desktop optfeature systemd xdg-utils
+
+DESCRIPTION="Feature rich multi-platform remote desktop application"
+HOMEPAGE="https://anydesk.com"
+SRC_URI="https://download.anydesk.com/linux/${P}-amd64.tar.gz
+ https://download.anydesk.com/linux/generic-linux/${P}-amd64.tar.gz"
+
+# OpeSSL/SSLeay, libvpx, zlib, Xiph, xxHash
+LICENSE="AnyDesk-TOS BSD BSD-2 openssl ZLIB"
+SLOT="0"
+KEYWORDS="-* ~amd64"
+
+RDEPEND="
+ dev-libs/atk
+ dev-libs/glib:2
+ media-libs/fontconfig:1.0
+ media-libs/freetype:2
+ media-libs/glu
+ media-libs/mesa[X(+)]
+ sys-auth/polkit
+ x11-libs/cairo
+ x11-libs/gdk-pixbuf:2
+ x11-libs/gtk+:2
+ x11-libs/gtkglext
+ x11-libs/libICE
+ x11-libs/libSM
+ x11-libs/libX11
+ x11-libs/libxcb
+ x11-libs/libXdamage
+ x11-libs/libXext
+ x11-libs/libXfixes
+ x11-libs/libXi
+ x11-libs/libxkbfile
+ x11-libs/libXmu
+ x11-libs/libXrandr
+ x11-libs/libXrender
+ x11-libs/libXt
+ x11-libs/libXtst
+ x11-libs/pango
+"
+BDEPEND="dev-util/patchelf"
+
+RESTRICT="bindist mirror"
+
+QA_PREBUILT="opt/${PN}/*"
+
+src_install() {
+ local dst="/opt/${PN}"
+
+ exeinto ${dst}
+ doexe ${PN}
+
+ # bug 706344
+ patchelf --remove-needed libpangox-1.0.so.0 "${ED}${dst}/${PN}" || die
+
+ dodir /opt/bin
+ dosym "${dst}/${PN}" "/opt/bin/${PN}"
+
+ newinitd "${FILESDIR}/anydesk.init" anydesk
+ systemd_newunit "${FILESDIR}/anydesk-4.0.1.service" anydesk.service
+
+ insinto /usr/share/polkit-1/actions
+ doins polkit-1/com.philandro.anydesk.policy
+
+ insinto /usr/share
+ doins -r icons
+
+ domenu "${FILESDIR}/anydesk.desktop"
+
+ keepdir "/etc/${PN}"
+
+ dodoc copyright README
+}
+
+pkg_postinst() {
+ xdg_desktop_database_update
+ xdg_icon_cache_update
+
+ if [[ -z ${REPLACING_VERSIONS} ]]; then
+ elog "To run AnyDesk as background service use:"
+ elog
+ elog "OpenRC:"
+ elog "# rc-service anydesk start"
+ elog "# rc-update add anydesk default"
+ elog
+ elog "Systemd:"
+ elog "# systemctl start anydesk.service"
+ elog "# systemctl enable anydesk.service"
+ elog
+ elog "Please see README at /usr/share/doc/${PF}/README.bz2 for"
+ elog "further information about the linux version of AnyDesk."
+ elog
+ fi
+
+ elog "For querying information about the host PC AnyDesk calls"
+ elog "the following commands. Feel free to install them, but it"
+ elog "should run without as well."
+ elog
+ optfeature "lsb_release" sys-apps/lsb-release
+ optfeature "lspci" sys-apps/pciutils
+ optfeature "lsusb" sys-apps/usbutils
+}
+
+pkg_postrm() {
+ xdg_desktop_database_update
+ xdg_icon_cache_update
+}