summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJaco Kroon <jaco@uls.co.za>2019-06-13 12:00:50 +0200
committerJoonas Niilola <juippis@gentoo.org>2019-11-27 17:18:28 +0200
commitc0c5c5d7c44589ed5541acaf90917457baec804a (patch)
tree6b8f5dbf3d8cc114b08e86e014738800f425ff6f /net-misc/asterisk-extra-sounds/asterisk-extra-sounds-1.5.2.ebuild
parentnet-irc/inspircd: Drop 3.2.0 (diff)
downloadgentoo-c0c5c5d7c44589ed5541acaf90917457baec804a.tar.gz
gentoo-c0c5c5d7c44589ed5541acaf90917457baec804a.tar.bz2
gentoo-c0c5c5d7c44589ed5541acaf90917457baec804a.zip
net-misc/asterisk-extra-sounds: version bump + maintainer.
EAPI was updated from 2 to 7. version from 1.4.11 to 1.5.2. L10N was ammended with en_GB (Additional language). Taken maintainership + proxy maint. Implement blacklist to avoid conflicts with net-misc/asterisk-core-sounds. File and folder perms as per https://bugs.gentoo.org/507894 (not close) Package-Manager: Portage-2.3.66, Repoman-2.3.11 Closes: https://bugs.gentoo.org/show_bug.cgi?id=687712 Signed-off-by: Jaco Kroon <jaco@uls.co.za> Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Diffstat (limited to 'net-misc/asterisk-extra-sounds/asterisk-extra-sounds-1.5.2.ebuild')
-rw-r--r--net-misc/asterisk-extra-sounds/asterisk-extra-sounds-1.5.2.ebuild72
1 files changed, 72 insertions, 0 deletions
diff --git a/net-misc/asterisk-extra-sounds/asterisk-extra-sounds-1.5.2.ebuild b/net-misc/asterisk-extra-sounds/asterisk-extra-sounds-1.5.2.ebuild
new file mode 100644
index 000000000000..6f762733bdc8
--- /dev/null
+++ b/net-misc/asterisk-extra-sounds/asterisk-extra-sounds-1.5.2.ebuild
@@ -0,0 +1,72 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="7"
+
+DESCRIPTION="Extra sounds for asterisk"
+HOMEPAGE="http://www.asterisk.org/"
+MY_L10N="^en en_GB fr" # ^ is used to indicate to the loops below to NOT set this as an optional
+CODECS="alaw g722 g729 +gsm siren7 siren14 sln16 ulaw wav"
+
+SRC_URI=""
+IUSE="${CODECS}"
+for l in ${MY_L10N}; do
+ [[ "${l}" != ^* ]] && IUSE+=" l10n_${l//_/-}" && SRC_URI+=" l10n_${l//_/-}? ("
+ for c in ${CODECS}; do
+ SRC_URI+=" ${c#+}? ( http://downloads.asterisk.org/pub/telephony/sounds/releases/${PN}-${l#^}-${c#+}-${PV}.tar.gz )"
+ done
+ [[ "${l}" = ^* ]] || SRC_URI+=" )"
+done
+
+REQUIRE_USE="|| ( ${CODECS//+/} )"
+
+LICENSE="CC-BY-SA-3.0"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+
+BLACKLIST=("astcc-followed-by-the-pound-key")
+
+S="${WORKDIR}"
+
+src_unpack() {
+ local ar
+ local l c b
+
+ for ar in ${A}; do
+ l="${ar#${PN}-}"
+ l=${l%%-*}
+ c="${ar#${PN}-*-}"
+ c=${c%%-*}
+ ebegin "Unpacking ${c} audio files for \"${l}\""
+ [ -d "${WORKDIR}/${l}" ] || mkdir "${WORKDIR}/${l}" || die "Error creating unpack directory"
+ tar xf "${DISTDIR}/${ar}" -C "${WORKDIR}/${l}" || die "Error unpacking ${ar}"
+ eend $?
+
+ for b in "${BLACKLIST[@]}"; do
+ [ -r "${WORKDIR}/${l}/${b}.${c}" ] && rm "${WORKDIR}/${l}/${b}.${c}"
+ done
+ done
+}
+
+src_install() {
+ local l
+ local pf
+ for l in ${MY_L10N}; do
+ if [[ "${l}" = ^* ]] || use l10n_${l//_/-}; then
+ l="${l#^}"
+ dodoc ${l}/${PN#asterisk-}-${l}.txt
+ rm ${l}/${PN#asterisk-}-${l}.txt
+ for pf in CHANGES CREDITS LICENSE; do
+ dodoc ${l}/${pf}-${PN%-sounds}-${l}-${PV}
+ rm ${l}/${pf}-${PN%-sounds}-${l}-${PV}
+ done
+ fi
+ done
+
+ diropts -m 0755 -o root -g root
+ insopts -m 0644 -o root -g root
+
+ dodir /var/lib/asterisk/sounds
+ insinto /var/lib/asterisk/sounds
+ doins -r .
+}