summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /net-misc/asterisk-g729/asterisk-g729-11.0.3.1.5.ebuild
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'net-misc/asterisk-g729/asterisk-g729-11.0.3.1.5.ebuild')
-rw-r--r--net-misc/asterisk-g729/asterisk-g729-11.0.3.1.5.ebuild124
1 files changed, 124 insertions, 0 deletions
diff --git a/net-misc/asterisk-g729/asterisk-g729-11.0.3.1.5.ebuild b/net-misc/asterisk-g729/asterisk-g729-11.0.3.1.5.ebuild
new file mode 100644
index 000000000000..74e616a7aa34
--- /dev/null
+++ b/net-misc/asterisk-g729/asterisk-g729-11.0.3.1.5.ebuild
@@ -0,0 +1,124 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="4"
+
+inherit versionator multilib
+
+DESCRIPTION="G.729 codec and supporting files for asterisk"
+HOMEPAGE="http://store.digium.com/productview.php?product_code=G729CODEC"
+
+BENCH_PV=1.0.8
+
+AST_PV=11.0
+MY_PV=$(replace_version_separator 2 _)
+
+SRC_URI="x86? (
+ http://downloads.digium.com/pub/telephony/codec_g729/asterisk-${AST_PV}/x86-32/codec_g729a-${MY_PV}-athlon_32.tar.gz
+ http://downloads.digium.com/pub/telephony/codec_g729/asterisk-${AST_PV}/x86-32/codec_g729a-${MY_PV}-athlon_xp_32.tar.gz
+ http://downloads.digium.com/pub/telephony/codec_g729/asterisk-${AST_PV}/x86-32/codec_g729a-${MY_PV}-barcelona_32.tar.gz
+ http://downloads.digium.com/pub/telephony/codec_g729/asterisk-${AST_PV}/x86-32/codec_g729a-${MY_PV}-c3_2_32.tar.gz
+ http://downloads.digium.com/pub/telephony/codec_g729/asterisk-${AST_PV}/x86-32/codec_g729a-${MY_PV}-c3_32.tar.gz
+ http://downloads.digium.com/pub/telephony/codec_g729/asterisk-${AST_PV}/x86-32/codec_g729a-${MY_PV}-core2_32.tar.gz
+ http://downloads.digium.com/pub/telephony/codec_g729/asterisk-${AST_PV}/x86-32/codec_g729a-${MY_PV}-generic_32.tar.gz
+ http://downloads.digium.com/pub/telephony/codec_g729/asterisk-${AST_PV}/x86-32/codec_g729a-${MY_PV}-i686_32.tar.gz
+ http://downloads.digium.com/pub/telephony/codec_g729/asterisk-${AST_PV}/x86-32/codec_g729a-${MY_PV}-k6_3_32.tar.gz
+ http://downloads.digium.com/pub/telephony/codec_g729/asterisk-${AST_PV}/x86-32/codec_g729a-${MY_PV}-nocona_32.tar.gz
+ http://downloads.digium.com/pub/telephony/codec_g729/asterisk-${AST_PV}/x86-32/codec_g729a-${MY_PV}-opteron_32.tar.gz
+ http://downloads.digium.com/pub/telephony/codec_g729/asterisk-${AST_PV}/x86-32/codec_g729a-${MY_PV}-opteron_sse3_32.tar.gz
+ http://downloads.digium.com/pub/telephony/codec_g729/asterisk-${AST_PV}/x86-32/codec_g729a-${MY_PV}-pentium3m_32.tar.gz
+ http://downloads.digium.com/pub/telephony/codec_g729/asterisk-${AST_PV}/x86-32/codec_g729a-${MY_PV}-pentium4m_32.tar.gz
+ http://downloads.digium.com/pub/telephony/codec_g729/asterisk-${AST_PV}/x86-32/codec_g729a-${MY_PV}-pentium_m_32.tar.gz
+ http://downloads.digium.com/pub/telephony/codec_g729/asterisk-${AST_PV}/x86-32/codec_g729a-${MY_PV}-prescott_32.tar.gz
+ http://downloads.digium.com/pub/telephony/codec_g729/benchg729/x86-32/benchg729-${BENCH_PV}-x86_32 -> benchg729-x86_32
+ http://downloads.digium.com/pub/register/x86-32/register -> astregister-x86_32
+ http://downloads.digium.com/pub/register/x86-32/asthostid -> asthostid-x86_32
+)
+amd64? (
+ http://downloads.digium.com/pub/telephony/codec_g729/asterisk-${AST_PV}/x86-64/codec_g729a-${MY_PV}-barcelona_64.tar.gz
+ http://downloads.digium.com/pub/telephony/codec_g729/asterisk-${AST_PV}/x86-64/codec_g729a-${MY_PV}-core2_64.tar.gz
+ http://downloads.digium.com/pub/telephony/codec_g729/asterisk-${AST_PV}/x86-64/codec_g729a-${MY_PV}-generic_64.tar.gz
+ http://downloads.digium.com/pub/telephony/codec_g729/asterisk-${AST_PV}/x86-64/codec_g729a-${MY_PV}-nocona_64.tar.gz
+ http://downloads.digium.com/pub/telephony/codec_g729/asterisk-${AST_PV}/x86-64/codec_g729a-${MY_PV}-opteron_64.tar.gz
+ http://downloads.digium.com/pub/telephony/codec_g729/asterisk-${AST_PV}/x86-64/codec_g729a-${MY_PV}-opteron_sse3_64.tar.gz
+ http://downloads.digium.com/pub/telephony/codec_g729/benchg729/x86-64/benchg729-${BENCH_PV}-x86_64 -> benchg729-x86_64
+ http://downloads.digium.com/pub/register/x86-64/register -> astregister-x86_64
+ http://downloads.digium.com/pub/register/x86-64/asthostid -> asthostid-x86_64
+)
+http://g729.uls.co.za/static/g729-stats-collector/collect-g729-stats.sh"
+
+LICENSE="Digium"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND=""
+RDEPEND="${DEPEND} =net-misc/asterisk-11*"
+
+RESTRICT="mirror strip"
+
+QA_FLAGS_IGNORED_amd64="usr/lib64/asterisk/modules/codec_g729a.so usr/sbin/benchg729"
+QA_FLAGS_IGNORED_x86="usr/lib/asterisk/modules/codec_g729a.so usr/sbin/benchg729"
+QA_PREBUILT="usr/sbin/benchg729 usr/sbin/asthostid usr/sbin/astregister"
+
+S="${WORKDIR}"
+
+src_prepare() {
+ local binsuffix
+ local b
+
+ if use x86; then
+ binsuffix=x86_32
+ elif use amd64; then
+ binsuffix=x86_64
+ else
+ die "Ebuild only functions for x86 and amd64."
+ fi
+
+ for b in astregister asthostid benchg729; do
+ cp "${DISTDIR}/${b}-${binsuffix}" "${WORKDIR}/${b}" || die
+ fperms 755 ${b}
+ done
+
+ cp "${DISTDIR}/collect-g729-stats.sh" "${WORKDIR}" || die
+}
+
+src_compile() {
+ ./benchg729 | tee benchdata
+ variant=$(sed -nre "s/^Recommended flavor for this system is '([^']*)'.*/\1/p" < benchdata)
+ [ -d codec_g729a-${MY_PV}-${variant}_${size} ] || variant=generic
+ [ -z $variant ] && variant=generic
+}
+
+src_install() {
+ local size
+
+ if use x86; then
+ size=32
+ elif use amd64; then
+ size=64
+ else
+ die "Ebuild only functions for x86 and amd64."
+ fi
+
+ dosbin astregister
+ dosbin asthostid
+ dosbin benchg729
+ dosbin collect-g729-stats.sh
+
+ dodoc codec_g729a-${MY_PV}-${variant}_${size}/LICENSE
+ dodoc codec_g729a-${MY_PV}-${variant}_${size}/README
+ insinto usr/$(get_libdir)/asterisk/modules/
+ doins "codec_g729a-${MY_PV}-${variant}_${size}/codec_g729a.so"
+}
+
+pkg_postinst() {
+ einfo "Please note that Digium's register utility has been installed as astregister"
+ einfo
+ einfo "Please consider participating in the G.729 stats collection that ULS"
+ einfo "is performing. This will assist in picking better variants for more"
+ einfo "processors as we gather more statistics. All you need to do is run"
+ einfo "the collect-g729-stats.sh command."
+ [ "${variant}" = "generic" ] && einfo "You are using the generic flavor of the codec, in order to install a more appropriate one please install a G.729 license and remerge this package (${PN})."
+}