summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJakov Smolic <jakov.smolic@sartura.hr>2020-12-28 13:42:55 +0100
committerDavid Seifert <soap@gentoo.org>2020-12-28 13:42:55 +0100
commit91455eb096bb6f86387e6edceff58354cdb07e98 (patch)
tree431b29af90c1832f03781d4aedf27e6d11593c42 /net-misc/astmanproxy/astmanproxy-1.28.2.ebuild
parentmedia-video/frameworks: Port to EAPI 7 (diff)
downloadgentoo-91455eb096bb6f86387e6edceff58354cdb07e98.tar.gz
gentoo-91455eb096bb6f86387e6edceff58354cdb07e98.tar.bz2
gentoo-91455eb096bb6f86387e6edceff58354cdb07e98.zip
net-misc/astmanproxy: Port to EAPI 7
Closes: https://bugs.gentoo.org/706896 Closes: https://bugs.gentoo.org/727856 Package-Manager: Portage-3.0.9, Repoman-3.0.1 Signed-off-by: Jakov Smolic <jakov.smolic@sartura.hr> Signed-off-by: David Seifert <soap@gentoo.org>
Diffstat (limited to 'net-misc/astmanproxy/astmanproxy-1.28.2.ebuild')
-rw-r--r--net-misc/astmanproxy/astmanproxy-1.28.2.ebuild32
1 files changed, 13 insertions, 19 deletions
diff --git a/net-misc/astmanproxy/astmanproxy-1.28.2.ebuild b/net-misc/astmanproxy/astmanproxy-1.28.2.ebuild
index 2fb64067a9ab..b1999a399500 100644
--- a/net-misc/astmanproxy/astmanproxy-1.28.2.ebuild
+++ b/net-misc/astmanproxy/astmanproxy-1.28.2.ebuild
@@ -1,49 +1,43 @@
# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=5
+EAPI=7
-inherit base flag-o-matic multilib toolchain-funcs
+inherit toolchain-funcs
DESCRIPTION="Proxy for the Asterisk manager interface"
HOMEPAGE="https://github.com/davies147/astmanproxy/"
SRC_URI="https://github.com/davies147/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
-IUSE=""
-
-SLOT="0"
LICENSE="GPL-2"
+SLOT="0"
KEYWORDS="~amd64 ~ppc ~x86"
-DEPEND=""
-PATCHES=( "${FILESDIR}/${P}-gentoo.diff" )
+PATCHES=(
+ "${FILESDIR}"/${P}-gentoo.diff
+ "${FILESDIR}"/${P}-fno-common.patch
+)
src_prepare() {
- base_src_prepare
+ default
# Fix multilib
- sed -i -e "s#/usr/lib/#/usr/$(get_libdir)/#" "${S}/Makefile" \
+ sed -i -e "s#/usr/lib/#/usr/$(get_libdir)/#" Makefile \
|| die "multilib sed failed"
}
-src_compile() {
- emake CC="$(tc-getCC)" \
- LDFLAGS="${LDFLAGS}" \
- LD="$(tc-getLD)" \
- RAWLDFLAGS="$(raw-ldflags)"
+src_configure() {
+ tc-export CC
}
src_install() {
dosbin astmanproxy
+ dodoc -r samples
dodoc README VERSIONS
- docinto samples
- dodoc samples/*
-
insinto /etc/asterisk
- doins configs/astmanproxy.conf
- doins configs/astmanproxy.users
+ doins configs/astmanproxy.{conf,users}
newinitd "${FILESDIR}"/astmanproxy.rc6 astmanproxy
}