summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Weber <xmw@gentoo.org>2017-01-25 16:39:49 +0100
committerMichael Weber <xmw@gentoo.org>2017-01-25 17:11:29 +0100
commit3e1e1b2b75ac030a0d77a617a77a0a8778b4bd6f (patch)
treeb4569c9bbf89d75640e2a75127f3cde98ba59b19 /net-misc/balance/balance-3.57.ebuild
parentdev-util/fatrace: Version bump. (diff)
downloadgentoo-3e1e1b2b75ac030a0d77a617a77a0a8778b4bd6f.tar.gz
gentoo-3e1e1b2b75ac030a0d77a617a77a0a8778b4bd6f.tar.bz2
gentoo-3e1e1b2b75ac030a0d77a617a77a0a8778b4bd6f.zip
net-misc/balance: Version bump, drop USE=doc (no need to install pdf version of manpage).
Package-Manager: Portage-2.3.3, Repoman-2.3.1
Diffstat (limited to 'net-misc/balance/balance-3.57.ebuild')
-rw-r--r--net-misc/balance/balance-3.57.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/net-misc/balance/balance-3.57.ebuild b/net-misc/balance/balance-3.57.ebuild
new file mode 100644
index 000000000000..cd120799b0fc
--- /dev/null
+++ b/net-misc/balance/balance-3.57.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+inherit toolchain-funcs
+
+DESCRIPTION="TCP Load Balancing Port Forwarder"
+HOMEPAGE="http://www.inlab.de/balance.html"
+SRC_URI="http://www.inlab.de/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE=""
+
+DEPEND=""
+RDEPEND=""
+
+PATCHES=( "${FILESDIR}"/${P}-Makefile.patch )
+
+src_prepare() {
+ default
+
+ tc-export CC
+}
+
+src_install() {
+ default
+
+ #autocreated on program start, if missing
+ rmdir "${D}"/var/run/${PN}
+}