summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /net-misc/balance/files
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'net-misc/balance/files')
-rw-r--r--net-misc/balance/files/balance-3.54-Makefile.patch52
1 files changed, 52 insertions, 0 deletions
diff --git a/net-misc/balance/files/balance-3.54-Makefile.patch b/net-misc/balance/files/balance-3.54-Makefile.patch
new file mode 100644
index 000000000000..8b231aaa8316
--- /dev/null
+++ b/net-misc/balance/files/balance-3.54-Makefile.patch
@@ -0,0 +1,52 @@
+--- balance-3.54/Makefile
++++ balance-3.54/Makefile
+@@ -1,14 +1,14 @@
+ # $Id$
+
+ #CFLAGS=-g -I.
+-CFLAGS=-O2 -Wall -Wstrict-prototypes -Wuninitialized
++CFLAGS+=-Wall -Wstrict-prototypes -Wuninitialized
+
+ # uncomment for any OS other than Cygwin
+ BALANCE=balance
+ ROOT=root
+ INSTALL=install
+ BINDIR=/usr/sbin
+-MANDIR=${BINDIR}/../man/man1
++MANDIR=/usr/share/man/man1
+
+ # uncomment for Solaris:
+ # LIBRARIES=-lsocket -lnsl
+@@ -20,13 +20,13 @@
+ # BALANCE=balance.exe
+ # ROOT=Administrators
+
+-CC=gcc
++CC?=gcc
+ RELEASE=3.54
+
+ all: balance
+
+ balance: balance.o butils.o
+- $(CC) $(CFLAGS) -I. -o balance balance.o butils.o $(LIBRARIES)
++ $(CC) $(CFLAGS) $(LDFLAGS) -I. -o balance balance.o butils.o $(LIBRARIES)
+
+ balance.o: balance.c balance.h
+ $(CC) $(CFLAGS) -I. -c balance.c
+@@ -48,12 +48,15 @@
+ rm -f $(BALANCE) *.o balance.ps balance.pdf
+
+ install:
++ $(INSTALL) -o $(ROOT) -g $(ROOT) -m 755 -d \
++ $(DESTDIR)$(BINDIR) \
++ $(DESTDIR)$(MANDIR)
+ $(INSTALL) -o $(ROOT) -g $(ROOT) -m 755 $(BALANCE) \
+ $(DESTDIR)$(BINDIR)/$(BALANCE)
+ $(INSTALL) -o $(ROOT) -g $(ROOT) -m 755 balance.1 \
+ $(DESTDIR)$(MANDIR)
+ mkdir -p $(DESTDIR)/var/run/balance
+- chmod 1777 $(DESTDIR)/var/run/balance
++ chmod 1755 $(DESTDIR)/var/run/balance
+
+ release: balance.pdf
+ rm -rf ./releases/balance-$(RELEASE)