summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHarry Smallbones <info@harrysmallbones.co.uk>2020-08-31 02:42:01 +0100
committerJoonas Niilola <juippis@gentoo.org>2020-09-29 09:36:49 +0300
commitdfef63ceb2aee7ccba92c28b9e8cf6f2fa2e6483 (patch)
tree489b188ab17e7f14af6c174e4627e24f222cfc7d /net-misc/batctl/batctl-2020.3.ebuild
parentgui-wm/hikari: fix misalignments, add missing dies, fix typo on 2.1.2 (diff)
downloadgentoo-dfef63ceb2aee7ccba92c28b9e8cf6f2fa2e6483.tar.gz
gentoo-dfef63ceb2aee7ccba92c28b9e8cf6f2fa2e6483.tar.bz2
gentoo-dfef63ceb2aee7ccba92c28b9e8cf6f2fa2e6483.zip
net-misc/batctl: Version bump to 2020.3
Closes: https://bugs.gentoo.org/739696 Signed-off-by: Harry Smallbones <info@harrysmallbones.co.uk> Package-Manager: Portage-3.0.4, Repoman-2.3.23 Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Diffstat (limited to 'net-misc/batctl/batctl-2020.3.ebuild')
-rw-r--r--net-misc/batctl/batctl-2020.3.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/net-misc/batctl/batctl-2020.3.ebuild b/net-misc/batctl/batctl-2020.3.ebuild
new file mode 100644
index 000000000000..dc9f33ff9204
--- /dev/null
+++ b/net-misc/batctl/batctl-2020.3.ebuild
@@ -0,0 +1,34 @@
+# Copyright 2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit linux-info toolchain-funcs
+
+DESCRIPTION="BATMAN advanced control and management tool"
+HOMEPAGE="https://www.open-mesh.org/"
+SRC_URI="https://downloads.open-mesh.org/batman/releases/batman-adv-${PV}/${P}.tar.gz"
+
+LICENSE="GPL-2 MIT ISC"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+BDEPEND="virtual/pkgconfig"
+RDEPEND="dev-libs/libnl:3"
+DEPEND="${RDEPEND}"
+
+pkg_setup() {
+ if ! linux_config_exists || ! linux_chkconfig_present BATMAN_ADV; then
+ ewarn "batctl requires batman-adv kernel support"
+ fi
+}
+
+src_compile() {
+ emake CC="$(tc-getCC)" V=1 REVISION="gentoo-${PVR}"
+}
+
+src_install() {
+ emake DESTDIR="${D}" PREFIX="${EPREFIX}/usr" install
+ dodoc README.rst
+}