summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /net-misc/bird/files/1.3.1-v4-v6-build.patch
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'net-misc/bird/files/1.3.1-v4-v6-build.patch')
-rw-r--r--net-misc/bird/files/1.3.1-v4-v6-build.patch109
1 files changed, 109 insertions, 0 deletions
diff --git a/net-misc/bird/files/1.3.1-v4-v6-build.patch b/net-misc/bird/files/1.3.1-v4-v6-build.patch
new file mode 100644
index 000000000000..3d6d0e2ee5f3
--- /dev/null
+++ b/net-misc/bird/files/1.3.1-v4-v6-build.patch
@@ -0,0 +1,109 @@
+diff -uNr bird-1.3.1.ORIG//tools/Makefile-top.in bird-1.3.1/tools/Makefile-top.in
+--- bird-1.3.1.ORIG//tools/Makefile-top.in 2011-05-02 12:57:26.799971384 +0100
++++ bird-1.3.1/tools/Makefile-top.in 2011-05-02 12:57:42.587971260 +0100
+@@ -3,16 +3,19 @@
+
+ objdir=@objdir@
+
+-all depend tags install install-docs:
++all depend tags install install-docs install-bin install-bin6:
+ $(MAKE) -C $(objdir) $@
+
+ docs userdocs progdocs:
+ $(MAKE) -C doc $@
+
+-clean:
+- $(MAKE) -C $(objdir) clean
++almost-clean:
++ $(MAKE) -C $(objdir) almost-clean
+ find . -name "*~" -or -name "*.[oa]" -or -name "\#*\#" -or -name TAGS -or -name core -or -name depend -or -name ".#*" | xargs rm -f
+
++clean: almost-clean
++ $(MAKE) -C $(objdir) clean
++
+ distclean: clean
+ $(MAKE) -C doc distclean
+ rm -rf $(objdir) autom4te.cache
+diff -uNr bird-1.3.1.ORIG//tools/Makefile.in bird-1.3.1/tools/Makefile.in
+--- bird-1.3.1.ORIG//tools/Makefile.in 2011-05-02 12:57:26.799971384 +0100
++++ bird-1.3.1/tools/Makefile.in 2011-05-02 12:57:42.588971277 +0100
+@@ -3,13 +3,13 @@
+
+ include Rules
+
+-.PHONY: all daemon client subdir depend clean distclean tags docs userdocs progdocs
++.PHONY: all daemon client subdir depend clean distclean tags docs userdocs progdocs almost-clean
+
+ all: sysdep/paths.h .dep-stamp subdir daemon @CLIENT@
+
+-daemon: $(exedir)/bird
++daemon: $(exedir)/bird@SUFFIX6@
+
+-client: $(exedir)/birdc
++client: $(exedir)/birdc@SUFFIX6@
+
+ bird-dep := $(addsuffix /all.o, $(static-dirs)) conf/all.o lib/birdlib.a
+
+@@ -27,10 +27,10 @@
+ set -e ; for a in $(dynamic-dirs) ; do $(MAKE) -C $$a $@ ; done
+ set -e ; for a in $(static-dirs) $(client-dirs) ; do $(MAKE) -C $$a -f $(srcdir_abs)/$$a/Makefile $@ ; done
+
+-$(exedir)/bird: $(bird-dep)
++$(exedir)/bird@SUFFIX6@: $(bird-dep)
+ $(CC) $(LDFLAGS) -o $@ $^ $(LIBS)
+
+-$(exedir)/birdc: $(birdc-dep)
++$(exedir)/birdc@SUFFIX6@: $(birdc-dep)
+ $(CC) $(LDFLAGS) -o $@ $^ $(LIBS) $(CLIENT_LIBS)
+
+ .dir-stamp: sysdep/paths.h
+@@ -55,25 +55,42 @@
+ tags:
+ cd $(srcdir) ; etags -lc `find $(static-dirs) $(addprefix $(objdir)/,$(dynamic-dirs)) $(client-dirs) -name *.[chY]`
+
+-install: all
++install-gen:
+ $(INSTALL) -d $(DESTDIR)/$(sbindir) $(DESTDIR)/$(sysconfdir) $(DESTDIR)/$(localstatedir)/run
+- $(INSTALL_PROGRAM) -s $(exedir)/bird $(DESTDIR)/$(sbindir)/bird@SUFFIX6@
++
++install-bin: install-gen
++ $(INSTALL_PROGRAM) $(exedir)/bird $(DESTDIR)/$(sbindir)/
++ if test -n "@CLIENT@" ; then \
++ $(INSTALL_PROGRAM) $(exedir)/birdc $(DESTDIR)/$(sbindir)/ ; \
++ fi
++ if ! test -f $(DESTDIR)/$(sysconfdir)/bird.conf ; then \
++ $(INSTALL_DATA) $(srcdir)/doc/bird.conf.example $(DESTDIR)/$(sysconfdir)/bird.conf ; \
++ else \
++ echo "Not overwriting old bird.conf" ; \
++ fi
++
++install-bin6: install-gen
++ $(INSTALL_PROGRAM) $(exedir)/bird $(DESTDIR)/$(sbindir)/
+ if test -n "@CLIENT@" ; then \
+- $(INSTALL_PROGRAM) -s $(exedir)/birdc $(DESTDIR)/$(sbindir)/birdc@SUFFIX6@ ; \
++ $(INSTALL_PROGRAM) $(exedir)/birdc6 $(DESTDIR)/$(sbindir)/birdc ; \
+ fi
+- if ! test -f $(DESTDIR)/$(sysconfdir)/bird@SUFFIX6@.conf ; then \
+- $(INSTALL_DATA) $(srcdir)/doc/bird.conf.example $(DESTDIR)/$(sysconfdir)/bird@SUFFIX6@.conf ; \
++ if ! test -f $(DESTDIR)/$(sysconfdir)/bird6.conf ; then \
++ $(INSTALL_DATA) $(srcdir)/doc/bird.conf.example $(DESTDIR)/$(sysconfdir)/bird6.conf ; \
+ else \
+- echo "Not overwriting old bird@SUFFIX@.conf" ; \
++ echo "Not overwriting old bird6.conf" ; \
+ fi
+
++install: all install-bin@SUFFIX6@
++
+ install-docs:
+ $(INSTALL) -d $(DESTDIR)/$(docdir)
+ $(INSTALL_DATA) $(srcdir)/doc/{bird,prog}{,-*}.html $(DESTDIR)/$(docdir)/
+
+-clean:
++almost-clean:
+ find . -name "*.[oa]" -o -name core -o -name depend -o -name "*.html" | xargs rm -f
+ rm -f conf/cf-lex.c conf/cf-parse.* conf/commands.h conf/keywords.h
++
++clean: almost-clean
+ rm -f $(exedir)/bird $(exedir)/birdc $(exedir)/bird.ctl $(exedir)/bird6.ctl .dep-stamp
+
+ distclean: clean