summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /net-misc/cadaver
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'net-misc/cadaver')
-rw-r--r--net-misc/cadaver/Manifest1
-rw-r--r--net-misc/cadaver/cadaver-0.23.3.ebuild45
-rw-r--r--net-misc/cadaver/files/cadaver-0.23.2-disable-nls.patch17
-rw-r--r--net-misc/cadaver/metadata.xml8
4 files changed, 71 insertions, 0 deletions
diff --git a/net-misc/cadaver/Manifest b/net-misc/cadaver/Manifest
new file mode 100644
index 000000000000..c9b03cc69dc2
--- /dev/null
+++ b/net-misc/cadaver/Manifest
@@ -0,0 +1 @@
+DIST cadaver-0.23.3.tar.gz 831884 SHA256 fd4ce68a3230ba459a92bcb747fc6afa91e46d803c1d5ffe964b661793c13fca
diff --git a/net-misc/cadaver/cadaver-0.23.3.ebuild b/net-misc/cadaver/cadaver-0.23.3.ebuild
new file mode 100644
index 000000000000..def16c40a2b4
--- /dev/null
+++ b/net-misc/cadaver/cadaver-0.23.3.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="3"
+
+inherit autotools eutils
+
+DESCRIPTION="Command-line WebDAV client"
+HOMEPAGE="http://www.webdav.org/cadaver"
+SRC_URI="http://www.webdav.org/cadaver/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ppc64 ~sparc x86"
+IUSE="nls"
+
+RDEPEND=">=net-libs/neon-0.27.0"
+DEPEND="${RDEPEND}
+ sys-devel/gettext"
+
+src_prepare() {
+ epatch "${FILESDIR}/${PN}-0.23.2-disable-nls.patch"
+
+ rm -fr lib/{expat,intl,neon}
+ sed \
+ -e "/NE_REQUIRE_VERSIONS/s/29/& 30/" \
+ -e "s:lib/neon/Makefile lib/intl/Makefile ::" \
+ -i configure.ac || die "sed configure.ac failed"
+ sed -e "s/^\(SUBDIRS.*=\).*/\1/" -i Makefile.in || die "sed Makefile.in failed"
+ cp /usr/share/gettext/po/Makefile.in.in po || die "cp failed"
+
+ AT_M4DIR="m4 m4/neon" eautoreconf
+}
+
+src_configure() {
+ econf \
+ $(use_enable nls) \
+ --with-libs=/usr
+}
+
+src_install () {
+ emake DESTDIR="${D}" install || die "emake install failed"
+ dodoc BUGS ChangeLog FAQ NEWS README THANKS TODO
+}
diff --git a/net-misc/cadaver/files/cadaver-0.23.2-disable-nls.patch b/net-misc/cadaver/files/cadaver-0.23.2-disable-nls.patch
new file mode 100644
index 000000000000..6610d479b30d
--- /dev/null
+++ b/net-misc/cadaver/files/cadaver-0.23.2-disable-nls.patch
@@ -0,0 +1,17 @@
+Fix building with --disable-nls.
+--- src/cadaver.c.~1~ 2007-08-22 14:17:27.000000000 +0200
++++ src/cadaver.c 2008-03-29 08:58:57.248793293 +0100
+@@ -838,11 +838,12 @@
+
+ progname = argv[0];
+
++#ifdef ENABLE_NLS
++
+ #ifdef HAVE_SETLOCALE
+ setlocale(LC_ALL, "");
+ #endif
+
+-#ifdef ENABLE_NLS
+ bindtextdomain(PACKAGE_NAME, LOCALEDIR);
+ textdomain(PACKAGE_NAME);
+ #endif /* ENABLE_NLS */
diff --git a/net-misc/cadaver/metadata.xml b/net-misc/cadaver/metadata.xml
new file mode 100644
index 000000000000..72e4e11f0b84
--- /dev/null
+++ b/net-misc/cadaver/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>proxy-maintainers</herd>
+ <maintainer>
+ <email>arfrever.fta@gmail.com</email>
+ </maintainer>
+</pkgmetadata>