summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKai Krakow <kai@kaishome.de>2019-04-07 12:05:57 +0200
committerPatrice Clement <monsieurp@gentoo.org>2019-04-10 00:21:26 +0200
commit7f0eaa8781fbfd8d9e46a7b4e79ef8d96ac43eb0 (patch)
tree08510651fff2a36d4d7248a417aab53d8075a877 /net-misc/casync/casync-2_p20190407.ebuild
parentx11-plugins/pidgin-telegram: drop old version. (diff)
downloadgentoo-7f0eaa8781fbfd8d9e46a7b4e79ef8d96ac43eb0.tar.gz
gentoo-7f0eaa8781fbfd8d9e46a7b4e79ef8d96ac43eb0.tar.bz2
gentoo-7f0eaa8781fbfd8d9e46a7b4e79ef8d96ac43eb0.zip
net-misc/casync: version bump to 2-p20190407.
Closes: https://bugs.gentoo.org/669592 Package-Manager: Portage-2.3.62, Repoman-2.3.11 Signed-off-by: Kai Krakow <kai@kaishome.de> Closes: https://github.com/gentoo/gentoo/pull/11624 Signed-off-by: Patrice Clement <monsieurp@gentoo.org>
Diffstat (limited to 'net-misc/casync/casync-2_p20190407.ebuild')
-rw-r--r--net-misc/casync/casync-2_p20190407.ebuild46
1 files changed, 46 insertions, 0 deletions
diff --git a/net-misc/casync/casync-2_p20190407.ebuild b/net-misc/casync/casync-2_p20190407.ebuild
new file mode 100644
index 000000000000..5dc04cbd3945
--- /dev/null
+++ b/net-misc/casync/casync-2_p20190407.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit vcs-snapshot meson
+
+COMMIT="6d185a540c54195a919d4b44f9bf28c341da3bf1"
+DESCRIPTION=" Content-Addressable Data Synchronization Tool"
+HOMEPAGE="https://github.com/systemd/casync"
+SRC_URI="https://github.com/systemd/casync/archive/${COMMIT}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="+fuse +udev man selinux test"
+
+RDEPEND="
+ app-arch/xz-utils
+ app-arch/zstd
+ dev-libs/openssl:0
+ net-misc/curl
+ virtual/acl
+ fuse? ( sys-fs/fuse:0 )
+ selinux? ( sys-libs/libselinux )
+ udev? ( virtual/libudev )
+"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+ man? ( dev-python/sphinx )
+"
+
+src_configure() {
+ local emesonargs=(
+ -Dfuse="$(usex fuse true false)"
+ -Dman="$(usex man true false)"
+ -Dselinux="$(usex selinux true false)"
+ -Dtests="$(usex test true false)"
+ -Dudev="$(usex udev true false)"
+ )
+ meson_src_configure
+}
+
+src_install() {
+ meson_src_install
+ find "${ED}" \( -name "*.a" -o -name "*.la" \) -delete || die
+}