summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /net-misc/cgminer/cgminer-4.7.0.ebuild
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'net-misc/cgminer/cgminer-4.7.0.ebuild')
-rw-r--r--net-misc/cgminer/cgminer-4.7.0.ebuild90
1 files changed, 90 insertions, 0 deletions
diff --git a/net-misc/cgminer/cgminer-4.7.0.ebuild b/net-misc/cgminer/cgminer-4.7.0.ebuild
new file mode 100644
index 000000000000..e324094aa054
--- /dev/null
+++ b/net-misc/cgminer/cgminer-4.7.0.ebuild
@@ -0,0 +1,90 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit autotools eutils flag-o-matic
+
+DESCRIPTION="Bitcoin CPU/GPU/FPGA/ASIC miner in C"
+HOMEPAGE="http://bitcointalk.org/?topic=28402.msg357369 http://github.com/ckolivas/cgminer"
+SRC_URI="http://ck.kolivas.org/apps/cgminer/${P}.tar.bz2"
+#SRC_URI="http://ck.kolivas.org/apps/cgminer/4.5/${P}.tar.bz2"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~x86"
+
+HARDWARE="ants1 ants2 avalon avalon2 bab bitmine_A1 bflsc bitforce bitfury cointerra drillbit hashfast hashratio icarus klondike knc minion modminer spondoolies"
+IUSE="doc examples udev hardened ncurses ${HARDWARE}"
+
+REQUIRED_USE="|| ( ${HARDWARE} )"
+
+RDEPEND="net-misc/curl
+ >=dev-libs/jansson-2.6
+ ncurses? ( sys-libs/ncurses )
+ avalon? ( virtual/libusb:1 )
+ bflsc? ( virtual/libusb:1 )
+ bitforce? ( virtual/libusb:1 )
+ bitfury? ( virtual/libusb:1 )
+ cointerra? ( virtual/libusb:1 )
+ drillbit? ( virtual/libusb:1 )
+ hashfast? ( virtual/libusb:1 )
+ hashratio? ( virtual/libusb:1 )
+ icarus? ( virtual/libusb:1 )
+ klondike? ( virtual/libusb:1 )
+ modminer? ( virtual/libusb:1 )
+ spondoolies? ( virtual/libusb:1 )"
+DEPEND="virtual/pkgconfig
+ ${RDEPEND}"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${PN}-4.4.2-system-jansson.patch
+ eautoreconf
+}
+
+src_configure() {
+ use hardened && append-cflags "-nopie"
+
+ econf $(use_with ncurses curses) \
+ $(use_enable ants1) \
+ $(use_enable ants2) \
+ $(use_enable avalon) \
+ $(use_enable avalon2) \
+ $(use_enable bab) \
+ $(use_enable bitmine_A1) \
+ $(use_enable bflsc) \
+ $(use_enable bitforce) \
+ $(use_enable bitfury) \
+ $(use_enable cointerra) \
+ $(use_enable drillbit) \
+ $(use_enable hashfast) \
+ $(use_enable hashratio) \
+ $(use_enable icarus) \
+ $(use_enable klondike) \
+ $(use_enable knc) \
+ $(use_enable minion) \
+ $(use_enable modminer) \
+ $(use_enable spondoolies) \
+ --with-system-libusb
+ # sanitize directories (is this still needed?)
+ sed -i 's~^\(\#define CGMINER_PREFIX \).*$~\1"'"${EPREFIX}/usr/lib/cgminer"'"~' config.h
+}
+
+src_install() { # How about using some make install?
+ dobin cgminer
+
+ insinto /lib/udev/rules.d
+ use udev && doins 01-cgminer.rules
+
+ if use doc; then
+ dodoc AUTHORS NEWS README API-README
+ use icarus || use bitforce || use modminer && dodoc FPGA-README
+ use avalon || use bflsc && dodoc ASIC-README
+ fi
+
+ if use examples; then
+ docinto examples
+ dodoc api-example.php miner.php API.java api-example.c example.conf
+ fi
+}