summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /net-misc/cgterm/files
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'net-misc/cgterm/files')
-rw-r--r--net-misc/cgterm/files/cgterm-1.6-QA.patch46
1 files changed, 46 insertions, 0 deletions
diff --git a/net-misc/cgterm/files/cgterm-1.6-QA.patch b/net-misc/cgterm/files/cgterm-1.6-QA.patch
new file mode 100644
index 000000000000..76d253bd8b27
--- /dev/null
+++ b/net-misc/cgterm/files/cgterm-1.6-QA.patch
@@ -0,0 +1,46 @@
+diff -NrU5 cgterm-1.6.original/Makefile cgterm-1.6/Makefile
+--- cgterm-1.6.original/Makefile 2009-09-07 08:43:52.000000000 -0600
++++ cgterm-1.6/Makefile 2009-09-07 09:06:07.000000000 -0600
+@@ -8,11 +8,11 @@
+ # for solaris:
+ #SOCKETLIBS = -lsocket -lnsl
+
+ CC=gcc
+ CFLAGS=-O3 -Wall `sdl-config --cflags` -DPREFIX=\"$(PREFIX)\"
+-LDFLAGS=`sdl-config --libs` $(SOCKETLIBS)
++LDFLAGS+=`sdl-config --libs` $(SOCKETLIBS)
+
+
+ OBJS= \
+ kernal.o \
+ gfx.o \
+@@ -62,25 +62,22 @@
+
+ testimage: testimage.c diskimage.c dir.c
+ $(CC) -g -O3 -Wall -o testimage $^
+
+ install: all installdirs
+- strip cgterm$(EXESUFFIX)
+ cp cgterm$(EXESUFFIX) $(PREFIX)/bin/
+ cp cgchat$(EXESUFFIX) $(PREFIX)/bin/
+ cp *.bmp *.kbd *.wav $(PREFIX)/share/cgterm/
+ # cp cgterm.cfg $(PREFIX)/etc/
+ # cp cgchat.cfg $(PREFIX)/etc/
+
+-installdirs: $(PREFIX)/bin $(PREFIX)/share $(PREFIX)/share/cgterm $(PREFIX)/etc
++installdirs: $(PREFIX)/bin $(PREFIX)/share/cgterm $(PREFIX)/etc
+
+ $(PREFIX)/bin:
+- mkdir $(PREFIX)/bin > /dev/null 2>&1
+-$(PREFIX)/share:
+- mkdir $(PREFIX)/share > /dev/null 2>&1
++ mkdir -p $(PREFIX)/bin > /dev/null 2>&1
+ $(PREFIX)/share/cgterm:
+- mkdir $(PREFIX)/share/cgterm > /dev/null 2>&1
++ mkdir -p $(PREFIX)/share/cgterm > /dev/null 2>&1
+ $(PREFIX)/etc:
+- mkdir $(PREFIX)/etc > /dev/null 2>&1
++ mkdir -p $(PREFIX)/etc > /dev/null 2>&1
+
+ clean:
+ rm -f cgterm$(EXESUFFIX) cgchat$(EXESUFFIX) testkbd$(EXESUFFIX) *.o *~