summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-02-08 07:50:57 +0100
committerMichał Górny <mgorny@gentoo.org>2020-02-09 17:46:40 +0100
commit46f4b5d0f5807d37d7b2c0ed7fd7f564c44bd5c3 (patch)
treef8cc4e7cd25877232be6b34105e5f75ba1d6a46d /net-misc/charm/charm-1.9.2-r2.ebuild
parentnet-mail/offlineimap: Switch to PYTHON_MULTI_USEDEP API (diff)
downloadgentoo-46f4b5d0f5807d37d7b2c0ed7fd7f564c44bd5c3.tar.gz
gentoo-46f4b5d0f5807d37d7b2c0ed7fd7f564c44bd5c3.tar.bz2
gentoo-46f4b5d0f5807d37d7b2c0ed7fd7f564c44bd5c3.zip
net-misc/charm: Switch to PYTHON_MULTI_USEDEP API
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'net-misc/charm/charm-1.9.2-r2.ebuild')
-rw-r--r--net-misc/charm/charm-1.9.2-r2.ebuild40
1 files changed, 40 insertions, 0 deletions
diff --git a/net-misc/charm/charm-1.9.2-r2.ebuild b/net-misc/charm/charm-1.9.2-r2.ebuild
new file mode 100644
index 000000000000..52c66fb0448f
--- /dev/null
+++ b/net-misc/charm/charm-1.9.2-r2.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="5"
+
+PYTHON_COMPAT=( python2_7 )
+DISTUTILS_SINGLE_IMPL="1"
+
+inherit distutils-r1
+
+DESCRIPTION="A text based livejournal client"
+HOMEPAGE="http://ljcharm.sourceforge.net/"
+SRC_URI="mirror://sourceforge/ljcharm/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 sparc x86"
+IUSE=""
+
+DEPEND="
+ $(python_gen_cond_dep '
+ dev-python/feedparser[${PYTHON_MULTI_USEDEP}]
+ ')"
+
+DOCS=( CHANGES.charm sample.charmrc README.charm )
+HTML_DOCS=( charm.html )
+
+pkg_setup() {
+ python-single-r1_pkg_setup
+}
+
+python_prepare_all() {
+ distutils-r1_python_prepare_all
+ sed -e 's/("share\/doc\/charm", .*),/\\/' -i setup.py || die "sed failed"
+}
+
+pkg_postinst() {
+ elog "You need to create a ~/.charmrc before running charm."
+ elog "Read 'man charmrc' for more information."
+}