summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2020-09-02 17:50:50 +0200
committerJeroen Roovers <jer@gentoo.org>2020-09-02 17:51:37 +0200
commitf7179379b3d676aab1cd6eceafd28145bfed2ae1 (patch)
tree5bc42df0196184b0465a7e84154338a1c2e59612 /net-misc/chrony/chrony-3.5.1-r1.ebuild
parentnet-misc/chrony: Old (diff)
downloadgentoo-f7179379b3d676aab1cd6eceafd28145bfed2ae1.tar.gz
gentoo-f7179379b3d676aab1cd6eceafd28145bfed2ae1.tar.bz2
gentoo-f7179379b3d676aab1cd6eceafd28145bfed2ae1.zip
net-misc/chrony: Simplify setting systemd default options
Package-Manager: Portage-3.0.5, Repoman-3.0.1 Bug: https://bugs.gentoo.org/show_bug.cgi?id=739714 Fixes: 6fbce4846282a2d77a9a8094e3d2fcd7176afcd6 Signed-off-by: Jeroen Roovers <jer@gentoo.org>
Diffstat (limited to 'net-misc/chrony/chrony-3.5.1-r1.ebuild')
-rw-r--r--net-misc/chrony/chrony-3.5.1-r1.ebuild14
1 files changed, 5 insertions, 9 deletions
diff --git a/net-misc/chrony/chrony-3.5.1-r1.ebuild b/net-misc/chrony/chrony-3.5.1-r1.ebuild
index 38d6c2500b70..38bd1ccc1f01 100644
--- a/net-misc/chrony/chrony-3.5.1-r1.ebuild
+++ b/net-misc/chrony/chrony-3.5.1-r1.ebuild
@@ -68,24 +68,20 @@ src_prepare() {
-e 's|pkg-config|${PKG_CONFIG}|g' \
configure || die
- sed \
- -e 's/-F 1/-F 0/' \
- examples/chronyd.service > "${T}"/chronyd.service || die
-
cp "${FILESDIR}"/chronyd.conf-r1 "${T}"/chronyd.conf || die
}
src_configure() {
if ! use caps; then
sed -i \
- -e 's/-u ntp//' \
- "${T}"/chronyd.conf "${T}"/chronyd.service || die
+ -e 's/ -u ntp//' \
+ "${T}"/chronyd.conf examples/chronyd.service || die
fi
if ! use seccomp; then
sed -i \
- -e 's/-F 0//' \
- "${T}"/chronyd.conf "${T}"/chronyd.service || die
+ -e 's/ -F 0//' \
+ "${T}"/chronyd.conf examples/chronyd.service || die
fi
tc-export CC PKG_CONFIG
@@ -176,7 +172,7 @@ src_install() {
insinto /etc/logrotate.d
newins "${FILESDIR}"/chrony-2.4-r1.logrotate chrony
- systemd_dounit "${T}"/chronyd.service
+ systemd_dounit examples/chronyd.service
systemd_dounit examples/chrony-wait.service
systemd_enable_ntpunit 50-chrony chronyd.service
}