summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2020-08-27 12:01:53 +0200
committerJeroen Roovers <jer@gentoo.org>2020-08-27 12:04:48 +0200
commitcdbd2b4e08d33fa3b74dafab8b4a24da04beab03 (patch)
tree57bb94f5f0501bcda3cb1bf592c2433de458e8bb /net-misc/chrony/chrony-9999.ebuild
parentnet-misc/chrony: Add IUSE=sechash in 3.5.1, fix whitespace (diff)
downloadgentoo-cdbd2b4e08d33fa3b74dafab8b4a24da04beab03.tar.gz
gentoo-cdbd2b4e08d33fa3b74dafab8b4a24da04beab03.tar.bz2
gentoo-cdbd2b4e08d33fa3b74dafab8b4a24da04beab03.zip
net-misc/chrony: BDEPEND on virtual/pkgconfig
Package-Manager: Portage-3.0.4, Repoman-3.0.1 Signed-off-by: Jeroen Roovers <jer@gentoo.org>
Diffstat (limited to 'net-misc/chrony/chrony-9999.ebuild')
-rw-r--r--net-misc/chrony/chrony-9999.ebuild13
1 files changed, 11 insertions, 2 deletions
diff --git a/net-misc/chrony/chrony-9999.ebuild b/net-misc/chrony/chrony-9999.ebuild
index 84346525f5ca..877718f60318 100644
--- a/net-misc/chrony/chrony-9999.ebuild
+++ b/net-misc/chrony/chrony-9999.ebuild
@@ -43,6 +43,9 @@ RDEPEND="
${CDEPEND}
selinux? ( sec-policy/selinux-chronyd )
"
+BDEPEND="
+ nettle? ( virtual/pkgconfig )
+"
PATCHES=(
"${FILESDIR}"/${PN}-3.5-pool-vendor-gentoo.patch
"${FILESDIR}"/${PN}-3.5-r3-systemd-gentoo.patch
@@ -50,7 +53,7 @@ PATCHES=(
S="${WORKDIR}/${P/_/-}"
if [[ ${PV} == "9999" ]]; then
- BDEPEND=" virtual/w3m"
+ BDEPEND+=" virtual/w3m"
fi
src_prepare() {
@@ -60,6 +63,10 @@ src_prepare() {
-e 's:/etc/chrony\.conf:/etc/chrony/chrony.conf:g' \
doc/* examples/* || die
+ sed -i \
+ -e 's|pkg-config|${PKG_CONFIG}|g' \
+ configure || die
+
# Copy for potential user fixup
cp "${FILESDIR}"/chronyd.conf-r1 "${T}"/chronyd.conf
cp examples/chronyd.service "${T}"/chronyd.service
@@ -79,7 +86,7 @@ src_configure() {
"${T}"/chronyd.conf "${T}"/chronyd.service || die
fi
- tc-export CC
+ tc-export CC PKG_CONFIG
local CHRONY_EDITLINE
# ./configure legend:
@@ -93,6 +100,8 @@ src_configure() {
CHRONY_EDITLINE+=" $(usex libedit '' --without-editline)"
fi
+ # Note: ncurses and nss switches are mentioned in the configure script but
+ # do nothing
# not an autotools generated script
local myconf=(
$(use_enable seccomp scfilter)