summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2019-05-02 18:26:02 +0200
committerJeroen Roovers <jer@gentoo.org>2019-05-02 18:26:34 +0200
commit4af6fd8a9f777efa934ef73cb803ca4bc6d0d0c5 (patch)
treefd11bc9f73a72f75334e4a9ab2980fa73c8d2926 /net-misc/chrony
parentnet-dns/libidn2: Old (diff)
downloadgentoo-4af6fd8a9f777efa934ef73cb803ca4bc6d0d0c5.tar.gz
gentoo-4af6fd8a9f777efa934ef73cb803ca4bc6d0d0c5.tar.bz2
gentoo-4af6fd8a9f777efa934ef73cb803ca4bc6d0d0c5.zip
net-misc/chrony: Version 3.5_pre1
Package-Manager: Portage-2.3.66, Repoman-2.3.12 Signed-off-by: Jeroen Roovers <jer@gentoo.org>
Diffstat (limited to 'net-misc/chrony')
-rw-r--r--net-misc/chrony/Manifest1
-rw-r--r--net-misc/chrony/chrony-3.5_pre1.ebuild123
-rw-r--r--net-misc/chrony/chrony-9999.ebuild6
3 files changed, 127 insertions, 3 deletions
diff --git a/net-misc/chrony/Manifest b/net-misc/chrony/Manifest
index ec6f372b2142..3a12680dcc72 100644
--- a/net-misc/chrony/Manifest
+++ b/net-misc/chrony/Manifest
@@ -1,3 +1,4 @@
DIST chrony-3.1.tar.gz 424109 BLAKE2B eb6bc13905a05eab15b00919577cceb4c8c881b4881fbd0e19d966dca86ed6973c31618b1ae56b59cad989144bf59a0206328d50d9eb436fdb058684e74a1661 SHA512 4ba3a75c3634050bb63ba9ee80d9be7a295f44ce4d195a050e4be4738bd7dd807fe37f2289d7ead4a75272bd5ebadbd03c233c67f859e9b68871fca5a6671427
DIST chrony-3.3.tar.gz 443571 BLAKE2B cc35f55b8d63eed85495f88b71c9285c68867a28b27c6c5e7d4475a77857ce4a09fbe561906757d66fee13b19d9ee750d41518050048776b2c0ef600407632e9 SHA512 36975d863599141e8e5b071d35cf67326b27f5b0da7ec942dbb4530377d10472b0729eea632e0702718b515cb2d5fd41a7eba158e6dade7f05adfb1bdffa5df0
DIST chrony-3.4.tar.gz 453056 BLAKE2B 088eb18bfc9ae4a7a3d656dfabddc565bc4a0da995c172183bed12bc5df59e87ab7363ba64e3579cdb414da77bd7f1fe05b66e33474282df57daf1fd8a55e182 SHA512 4fbb0311c8d363a87edd6f5d1be3d8554da169f260ba23c1ad9e8c567808258c6fd7513ba630d6fa27453ecfd81f0ece0e26d5ee2f98ca47fbc9887181a36918
+DIST chrony-3.5-pre1.tar.gz 457961 BLAKE2B a43e36df7d3b2a2865efb784240e399c2a16748064cedf96b0da849f0cdf8b4d91e7fc616995277f29d2c55176e08526dbedbc8b866238994f8a4187b822aa20 SHA512 ccca35e17f18ed80e0db984c321f5fefabb1056feaae3aed08bf9e1ae732b22af05f87bafe812154af7e5adced91d90618e3833bc266be06ba2fa095685b07da
diff --git a/net-misc/chrony/chrony-3.5_pre1.ebuild b/net-misc/chrony/chrony-3.5_pre1.ebuild
new file mode 100644
index 000000000000..d32f046f9da9
--- /dev/null
+++ b/net-misc/chrony/chrony-3.5_pre1.ebuild
@@ -0,0 +1,123 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+inherit systemd toolchain-funcs
+
+DESCRIPTION="NTP client and server programs"
+HOMEPAGE="https://chrony.tuxfamily.org/"
+SRC_URI="https://download.tuxfamily.org/${PN}/${P/_/-}.tar.gz"
+LICENSE="GPL-2"
+SLOT="0"
+
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ppc ~ppc64 ~sparc ~x86"
+IUSE="caps +cmdmon html ipv6 libedit +ntp +phc pps readline +refclock +rtc seccomp selinux +adns"
+REQUIRED_USE="
+ ?? ( libedit readline )
+"
+
+CDEPEND="
+ caps? ( sys-libs/libcap )
+ libedit? ( dev-libs/libedit )
+ readline? ( >=sys-libs/readline-4.1-r4:= )
+ seccomp? ( sys-libs/libseccomp )
+"
+DEPEND="
+ ${CDEPEND}
+ html? ( dev-ruby/asciidoctor )
+ pps? ( net-misc/pps-tools )
+"
+RDEPEND="
+ ${CDEPEND}
+ selinux? ( sec-policy/selinux-chronyd )
+"
+
+RESTRICT=test
+
+S="${WORKDIR}/${P/_/-}"
+
+PATCHES=(
+ "${FILESDIR}"/chronyd-systemd-gentoo.patch
+)
+
+src_prepare() {
+ default
+ sed -i \
+ -e 's:/etc/chrony\.conf:/etc/chrony/chrony.conf:g' \
+ doc/* examples/* || die
+}
+
+src_configure() {
+ tc-export CC
+
+ local CHRONY_EDITLINE
+ # ./configure legend:
+ # --disable-readline : disable line editing entirely
+ # --without-readline : do not use sys-libs/readline (enabled by default)
+ # --without-editline : do not use dev-libs/libedit (enabled by default)
+ if ! use readline && ! use libedit; then
+ CHRONY_EDITLINE='--disable-readline'
+ else
+ CHRONY_EDITLINE+=" $(usex readline '' --without-readline)"
+ CHRONY_EDITLINE+=" $(usex libedit '' --without-editline)"
+ fi
+
+ # not an autotools generated script
+ local CHRONY_CONFIGURE="
+ ./configure \
+ $(use_enable seccomp scfilter) \
+ $(usex adns '' --disable-asyncdns) \
+ $(usex caps '' --disable-linuxcaps) \
+ $(usex cmdmon '' --disable-cmdmon) \
+ $(usex ipv6 '' --disable-ipv6) \
+ $(usex ntp '' --disable-ntp) \
+ $(usex phc '' --disable-phc) \
+ $(usex pps '' --disable-pps) \
+ $(usex refclock '' --disable-refclock) \
+ $(usex rtc '' --disable-rtc) \
+ ${CHRONY_EDITLINE} \
+ ${EXTRA_ECONF} \
+ --chronysockdir=/run/chrony \
+ --disable-sechash \
+ --docdir=/usr/share/doc/${PF} \
+ --mandir=/usr/share/man \
+ --prefix=/usr \
+ --sysconfdir=/etc/chrony \
+ --with-pidfile="${EPREFIX}/run/chrony/chronyd.pid"
+ --without-nss \
+ --without-tomcrypt
+ "
+
+ # print the ./configure call to aid in future debugging
+ einfo ${CHRONY_CONFIGURE}
+ bash ${CHRONY_CONFIGURE} || die
+}
+
+src_compile() {
+ emake all docs $(usex html '' 'ADOC=true')
+}
+
+src_install() {
+ default
+
+ newinitd "${FILESDIR}"/chronyd.init-r2 chronyd
+ newconfd "${FILESDIR}"/chronyd.conf chronyd
+
+ insinto /etc/${PN}
+ newins examples/chrony.conf.example1 chrony.conf
+
+ docinto examples
+ dodoc examples/*.example*
+
+ if use html; then
+ docinto html
+ dodoc doc/*.html
+ fi
+
+ keepdir /var/{lib,log}/chrony
+
+ insinto /etc/logrotate.d
+ newins "${FILESDIR}"/chrony-2.4-r1.logrotate chrony
+
+ systemd_dounit examples/chronyd.service
+}
diff --git a/net-misc/chrony/chrony-9999.ebuild b/net-misc/chrony/chrony-9999.ebuild
index 3281755d0869..188564043dd7 100644
--- a/net-misc/chrony/chrony-9999.ebuild
+++ b/net-misc/chrony/chrony-9999.ebuild
@@ -1,8 +1,8 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
-inherit eutils git-r3 systemd toolchain-funcs
+EAPI=7
+inherit git-r3 systemd toolchain-funcs
DESCRIPTION="NTP client and server programs"
HOMEPAGE="https://chrony.tuxfamily.org/"