summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Gilbert <floppym@gentoo.org>2019-09-25 02:39:27 -0400
committerJeroen Roovers <jer@gentoo.org>2019-09-26 09:36:04 +0200
commit53851d0721fd2ecce0bace26725d59397de34882 (patch)
tree761c0a521b14447ea759d656da06f0bf49c2ce3c /net-misc/chrony
parentsys-apps/iproute2: stable 5.2.0-r1 for ppc64, bug #695624 (diff)
downloadgentoo-53851d0721fd2ecce0bace26725d59397de34882.tar.gz
gentoo-53851d0721fd2ecce0bace26725d59397de34882.tar.bz2
gentoo-53851d0721fd2ecce0bace26725d59397de34882.zip
net-misc/chrony: clean up configure arguments
Closes: https://bugs.gentoo.org/695610 Package-Manager: Portage-2.3.75_p7, Repoman-2.3.17_p49 Signed-off-by: Mike Gilbert <floppym@gentoo.org> Signed-off-by: Jeroen Roovers <jer@gentoo.org>
Diffstat (limited to 'net-misc/chrony')
-rw-r--r--net-misc/chrony/chrony-3.5.ebuild47
-rw-r--r--net-misc/chrony/chrony-9999.ebuild47
2 files changed, 46 insertions, 48 deletions
diff --git a/net-misc/chrony/chrony-3.5.ebuild b/net-misc/chrony/chrony-3.5.ebuild
index 21c96f642157..c74eea646f90 100644
--- a/net-misc/chrony/chrony-3.5.ebuild
+++ b/net-misc/chrony/chrony-3.5.ebuild
@@ -66,34 +66,33 @@ src_configure() {
fi
# not an autotools generated script
- local CHRONY_CONFIGURE="
- ./configure \
- $(use_enable seccomp scfilter) \
- $(usex adns '' --disable-asyncdns) \
- $(usex caps '' --disable-linuxcaps) \
- $(usex cmdmon '' --disable-cmdmon) \
- $(usex ipv6 '' --disable-ipv6) \
- $(usex ntp '' --disable-ntp) \
- $(usex phc '' --disable-phc) \
- $(usex pps '' --disable-pps) \
- $(usex refclock '' --disable-refclock) \
- $(usex rtc '' --disable-rtc) \
- ${CHRONY_EDITLINE} \
- ${EXTRA_ECONF} \
- --chronysockdir=/run/chrony \
- --disable-sechash \
- --docdir=/usr/share/doc/${PF} \
- --mandir=/usr/share/man \
- --prefix=/usr \
- --sysconfdir=/etc/chrony \
+ local myconf=(
+ $(use_enable seccomp scfilter)
+ $(usex adns '' --disable-asyncdns)
+ $(usex caps '' --disable-linuxcaps)
+ $(usex cmdmon '' --disable-cmdmon)
+ $(usex ipv6 '' --disable-ipv6)
+ $(usex ntp '' --disable-ntp)
+ $(usex phc '' --disable-phc)
+ $(usex pps '' --disable-pps)
+ $(usex refclock '' --disable-refclock)
+ $(usex rtc '' --disable-rtc)
+ ${CHRONY_EDITLINE}
+ ${EXTRA_ECONF}
+ --chronysockdir="${EPREFIX}/run/chrony"
+ --disable-sechash
+ --docdir="${EPREFIX}/usr/share/doc/${PF}"
+ --mandir="${EPREFIX}/usr/share/man"
+ --prefix="${EPREFIX}/usr"
+ --sysconfdir="${EPREFIX}/etc/chrony"
--with-pidfile="${EPREFIX}/run/chrony/chronyd.pid"
- --without-nss \
+ --without-nss
--without-tomcrypt
- "
+ )
# print the ./configure call to aid in future debugging
- einfo ${CHRONY_CONFIGURE}
- bash ${CHRONY_CONFIGURE} || die
+ echo bash ./configure "${myconf[@]}" >&2
+ bash ./configure "${myconf[@]}" || die
}
src_compile() {
diff --git a/net-misc/chrony/chrony-9999.ebuild b/net-misc/chrony/chrony-9999.ebuild
index a9bf2fae2782..53dd5de5b8a0 100644
--- a/net-misc/chrony/chrony-9999.ebuild
+++ b/net-misc/chrony/chrony-9999.ebuild
@@ -64,34 +64,33 @@ src_configure() {
fi
# not an autotools generated script
- local CHRONY_CONFIGURE="
- ./configure \
- $(use_enable seccomp scfilter) \
- $(usex adns '' --disable-asyncdns) \
- $(usex caps '' --disable-linuxcaps) \
- $(usex cmdmon '' --disable-cmdmon) \
- $(usex ipv6 '' --disable-ipv6) \
- $(usex ntp '' --disable-ntp) \
- $(usex phc '' --disable-phc) \
- $(usex pps '' --disable-pps) \
- $(usex refclock '' --disable-refclock) \
- $(usex rtc '' --disable-rtc) \
- ${CHRONY_EDITLINE} \
- ${EXTRA_ECONF} \
- --chronysockdir=/run/chrony \
- --disable-sechash \
- --docdir=/usr/share/doc/${PF} \
- --mandir=/usr/share/man \
- --prefix=/usr \
- --sysconfdir=/etc/chrony \
+ local myconf=(
+ $(use_enable seccomp scfilter)
+ $(usex adns '' --disable-asyncdns)
+ $(usex caps '' --disable-linuxcaps)
+ $(usex cmdmon '' --disable-cmdmon)
+ $(usex ipv6 '' --disable-ipv6)
+ $(usex ntp '' --disable-ntp)
+ $(usex phc '' --disable-phc)
+ $(usex pps '' --disable-pps)
+ $(usex refclock '' --disable-refclock)
+ $(usex rtc '' --disable-rtc)
+ ${CHRONY_EDITLINE}
+ ${EXTRA_ECONF}
+ --chronysockdir="${EPREFIX}/run/chrony"
+ --disable-sechash
+ --docdir="${EPREFIX}/usr/share/doc/${PF}"
+ --mandir="${EPREFIX}/usr/share/man"
+ --prefix="${EPREFIX}/usr"
+ --sysconfdir="${EPREFIX}/etc/chrony"
--with-pidfile="${EPREFIX}/run/chrony/chronyd.pid"
- --without-nss \
+ --without-nss
--without-tomcrypt
- "
+ )
# print the ./configure call to aid in future debugging
- einfo ${CHRONY_CONFIGURE}
- bash ${CHRONY_CONFIGURE} || die
+ echo bash ./configure "${myconf[@]}" >&2
+ bash ./configure "${myconf[@]}" || die
}
src_compile() {