summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /net-misc/clockspeed/clockspeed-0.62-r6.ebuild
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'net-misc/clockspeed/clockspeed-0.62-r6.ebuild')
-rw-r--r--net-misc/clockspeed/clockspeed-0.62-r6.ebuild46
1 files changed, 46 insertions, 0 deletions
diff --git a/net-misc/clockspeed/clockspeed-0.62-r6.ebuild b/net-misc/clockspeed/clockspeed-0.62-r6.ebuild
new file mode 100644
index 000000000000..3e2cc1d01955
--- /dev/null
+++ b/net-misc/clockspeed/clockspeed-0.62-r6.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+inherit eutils flag-o-matic
+
+DESCRIPTION="A simple Network Time Protocol (NTP) client"
+HOMEPAGE="http://cr.yp.to/clockspeed.html"
+
+# this is the trailing part of the name for the latest leapseconds file.
+LEAPSECONDS_DATE="20081114"
+
+SRC_URI="http://cr.yp.to/clockspeed/${P}.tar.gz
+ http://dev.gentoo.org/~pacho/maintainer-needed/leapsecs.dat."$LEAPSECONDS_DATE""
+
+LICENSE="all-rights-reserved"
+SLOT="0"
+KEYWORDS="amd64 ~mips x86"
+IUSE="static selinux"
+RESTRICT="mirror bindist test"
+
+DEPEND="sys-apps/groff"
+RDEPEND="selinux? ( sec-policy/selinux-clockspeed )
+ net-dns/djbdns"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-gentoo.patch
+}
+
+src_configure() {
+ echo "$(tc-getCC) ${CFLAGS} ${ASFLAGS}" > conf-cc
+ use static && append-ldflags -static
+ echo "$(tc-getCC) ${LDFLAGS}" > conf-ld
+}
+
+src_install() {
+ dobin clockspeed clockadd clockview sntpclock taiclock taiclockd
+ dosbin "${FILESDIR}"/ntpclockset
+
+ doman *.1
+ dodoc BLURB CHANGES INSTALL README THANKS TODO
+
+ insinto /var/lib/clockspeed
+ newins "${DISTDIR}"/leapsecs.dat."$LEAPSECONDS_DATE" leapsecs.dat
+}