summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBen Kohler <bkohler@gentoo.org>2020-11-01 07:15:01 -0600
committerBen Kohler <bkohler@gentoo.org>2020-11-01 07:15:16 -0600
commite24b40d03f55936f67535d57ae8dda4bc911ca55 (patch)
tree26398c6d29c4827cde00557dc472a2a31d7b776a /net-misc/cmst/cmst-2020.11.01.ebuild
parentdev-haskell/uuid-types: update to EAPI=7 (diff)
downloadgentoo-e24b40d03f55936f67535d57ae8dda4bc911ca55.tar.gz
gentoo-e24b40d03f55936f67535d57ae8dda4bc911ca55.tar.bz2
gentoo-e24b40d03f55936f67535d57ae8dda4bc911ca55.zip
net-misc/cmst: bump to 2020.11.01
Package-Manager: Portage-3.0.8, Repoman-3.0.2 Signed-off-by: Ben Kohler <bkohler@gentoo.org>
Diffstat (limited to 'net-misc/cmst/cmst-2020.11.01.ebuild')
-rw-r--r--net-misc/cmst/cmst-2020.11.01.ebuild43
1 files changed, 43 insertions, 0 deletions
diff --git a/net-misc/cmst/cmst-2020.11.01.ebuild b/net-misc/cmst/cmst-2020.11.01.ebuild
new file mode 100644
index 000000000000..02c5f056724b
--- /dev/null
+++ b/net-misc/cmst/cmst-2020.11.01.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+inherit qmake-utils xdg-utils
+
+DESCRIPTION="Qt GUI for Connman with system tray icon"
+HOMEPAGE="https://github.com/andrew-bibb/cmst"
+SRC_URI="https://github.com/andrew-bibb/cmst/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND="dev-qt/qtcore:5
+ dev-qt/qtdbus:5
+ dev-qt/qtgui:5
+ dev-qt/qtnetwork:5
+ dev-qt/qtwidgets:5
+"
+RDEPEND="${DEPEND}
+ net-misc/connman
+"
+
+src_configure() {
+ export USE_LIBPATH="${EPREFIX}/usr/$(get_libdir)/${PN}"
+ eqmake5 DISTRO=gentoo
+}
+
+src_install() {
+ emake INSTALL_ROOT="${D}" install
+ rm -r "${D}"/usr/share/licenses || die
+ gunzip "${D}"/usr/share/man/man1/cmst.1.gz
+}
+
+pkg_postinst() {
+ xdg_icon_cache_update
+}
+
+pkg_postrm() {
+ xdg_icon_cache_update
+}