summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBen Kohler <bkohler@gentoo.org>2020-05-25 07:37:38 -0500
committerBen Kohler <bkohler@gentoo.org>2020-05-25 07:37:51 -0500
commit339117ca936c353935b51bdbed2c336756b63c36 (patch)
tree4b745218b75deb85ad01a8faa3cee52be0b852d5 /net-misc/connman-json-client/connman-json-client-1.0_p20150721-r2.ebuild
parentapp-crypt/pinentry: amd64 stable wrt bug #724374 (diff)
downloadgentoo-339117ca936c353935b51bdbed2c336756b63c36.tar.gz
gentoo-339117ca936c353935b51bdbed2c336756b63c36.tar.bz2
gentoo-339117ca936c353935b51bdbed2c336756b63c36.zip
net-misc/connman-json-client: revbump to respect CFLAGS, drop old
Closes: https://bugs.gentoo.org/725092 Package-Manager: Portage-2.3.100, Repoman-2.3.22 Signed-off-by: Ben Kohler <bkohler@gentoo.org>
Diffstat (limited to 'net-misc/connman-json-client/connman-json-client-1.0_p20150721-r2.ebuild')
-rw-r--r--net-misc/connman-json-client/connman-json-client-1.0_p20150721-r2.ebuild38
1 files changed, 38 insertions, 0 deletions
diff --git a/net-misc/connman-json-client/connman-json-client-1.0_p20150721-r2.ebuild b/net-misc/connman-json-client/connman-json-client-1.0_p20150721-r2.ebuild
new file mode 100644
index 000000000000..2fe35cf86af6
--- /dev/null
+++ b/net-misc/connman-json-client/connman-json-client-1.0_p20150721-r2.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit autotools vcs-snapshot
+COMMIT="3c34b2ee62d2e188090d20e7ed2fd94bab9c47f2"
+
+DESCRIPTION="An ncurses UI for connman"
+HOMEPAGE="https://github.com/eurogiciel-oss/connman-json-client"
+SRC_URI="https://github.com/eurogiciel-oss/${PN}/archive/${COMMIT}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND="dev-libs/json-c:0=
+ >=sys-apps/dbus-1.4
+ sys-libs/ncurses:0"
+RDEPEND="${DEPEND}"
+
+PATCHES=( "${FILESDIR}"/cjc-fix-for-json-0.14.patch )
+
+src_prepare() {
+ sed -i -e '/^AM_CFLAGS/ s/ -Werror$//' Makefile.am || die
+ default
+ eautoreconf
+}
+
+src_compile() {
+ emake CFLAGS="${CFLAGS}"
+}
+
+src_install() {
+ default
+ dobin connman_ncurses
+}