summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBen Kohler <bkohler@gentoo.org>2021-07-13 10:44:14 -0500
committerBen Kohler <bkohler@gentoo.org>2021-07-13 10:44:25 -0500
commit60a991c0e74c9213bfdd17af9b41730735d0a1c4 (patch)
tree6023da9f4107c5f61f546f7bc5f9611076cc64db /net-misc/connman-notify
parentsys-fs/btrfs-progs: Removed old (diff)
downloadgentoo-60a991c0e74c9213bfdd17af9b41730735d0a1c4.tar.gz
gentoo-60a991c0e74c9213bfdd17af9b41730735d0a1c4.tar.bz2
gentoo-60a991c0e74c9213bfdd17af9b41730735d0a1c4.zip
net-misc/connman-notify: bump to EAPI=8
Package-Manager: Portage-3.0.20, Repoman-3.0.3 Signed-off-by: Ben Kohler <bkohler@gentoo.org>
Diffstat (limited to 'net-misc/connman-notify')
-rw-r--r--net-misc/connman-notify/connman-notify-0_pre20191003-r3.ebuild40
1 files changed, 40 insertions, 0 deletions
diff --git a/net-misc/connman-notify/connman-notify-0_pre20191003-r3.ebuild b/net-misc/connman-notify/connman-notify-0_pre20191003-r3.ebuild
new file mode 100644
index 000000000000..e9555e6bfa2b
--- /dev/null
+++ b/net-misc/connman-notify/connman-notify-0_pre20191003-r3.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{7..10} )
+
+inherit desktop python-single-r1
+
+MY_COMMIT="4f1e0a6b27ebf5d9b7508594188fe0f86c34ec52"
+
+DESCRIPTION="Desktop notification integration for connman"
+HOMEPAGE="https://gitlab.com/wavexx/connman-notify/"
+SRC_URI="https://gitlab.com/wavexx/connman-notify/repository/${MY_COMMIT}/archive.tar.bz2 -> ${P}.tar.bz2"
+
+EGIT_REPO_URI="https://gitlab.com/wavexx/connman-notify.git"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+RDEPEND="${PYTHON_DEPS}
+ $(python_gen_cond_dep '
+ dev-python/dbus-python[${PYTHON_USEDEP}]
+ dev-python/pygobject:3[${PYTHON_USEDEP}]
+ ')
+ net-misc/connman
+ virtual/notification-daemon"
+
+S=${WORKDIR}/${PN}-${MY_COMMIT}-${MY_COMMIT}
+
+src_install() {
+ python_fix_shebang ${PN}
+ dobin ${PN}
+ dodoc README.rst
+
+ make_desktop_entry ${PN} ${PN} ${PN} Network
+}