summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBen Kohler <bkohler@gentoo.org>2019-06-06 20:40:12 -0500
committerBen Kohler <bkohler@gentoo.org>2019-06-06 20:40:12 -0500
commit7a5976eefb5f6ba517ed986315f46e455ce98fab (patch)
treebf37836dbbbf7b386a543f6231915915dbb1d945 /net-misc/connman-ui/connman-ui-0_p20150622.ebuild
parentnet-misc/connman-json-client: remove -Werror (diff)
downloadgentoo-7a5976eefb5f6ba517ed986315f46e455ce98fab.tar.gz
gentoo-7a5976eefb5f6ba517ed986315f46e455ce98fab.tar.bz2
gentoo-7a5976eefb5f6ba517ed986315f46e455ce98fab.zip
net-misc/connman-ui: take package & add snapshot ebuild
Package-Manager: Portage-2.3.67, Repoman-2.3.14 Signed-off-by: Ben Kohler <bkohler@gentoo.org>
Diffstat (limited to 'net-misc/connman-ui/connman-ui-0_p20150622.ebuild')
-rw-r--r--net-misc/connman-ui/connman-ui-0_p20150622.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/net-misc/connman-ui/connman-ui-0_p20150622.ebuild b/net-misc/connman-ui/connman-ui-0_p20150622.ebuild
new file mode 100644
index 000000000000..a1a5d26d62e8
--- /dev/null
+++ b/net-misc/connman-ui/connman-ui-0_p20150622.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit autotools vcs-snapshot
+COMMIT="fce0af94e121bde77c7fa2ebd6a319f0180c5516"
+
+DESCRIPTION="A full-featured GTK based trayicon UI for ConnMan"
+HOMEPAGE="https://github.com/tbursztyka/connman-ui"
+SRC_URI="https://github.com/tbursztyka/${PN}/archive/${COMMIT}.tar.gz -> ${P}.tar.gz"
+KEYWORDS="~amd64 ~x86"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+
+CDEPEND="
+ dev-libs/glib:2
+ sys-apps/dbus
+ x11-libs/gtk+:3
+"
+RDEPEND="${CDEPEND}
+ net-misc/connman
+"
+DEPEND="${CDEPEND}
+ dev-util/intltool
+ virtual/pkgconfig
+"
+
+src_prepare() {
+ default
+ eautoreconf
+}