summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBen Kohler <bkohler@gentoo.org>2018-08-23 07:53:53 -0500
committerBen Kohler <bkohler@gentoo.org>2018-08-23 08:03:41 -0500
commit2d97b6a9805352dc8aa083b9b8467e3a8d03bdc8 (patch)
tree6dee1a6d94a97b8416ff2c85573fa77200024793 /net-misc/connman
parentsys-process/xjobs: remove "unused" xjobs-20151016.ebuild. (diff)
downloadgentoo-2d97b6a9805352dc8aa083b9b8467e3a8d03bdc8.tar.gz
gentoo-2d97b6a9805352dc8aa083b9b8467e3a8d03bdc8.tar.bz2
gentoo-2d97b6a9805352dc8aa083b9b8467e3a8d03bdc8.zip
net-misc/connman: add myself as maintainer, bump to 1.36, iwd support
Added myself to maintainers list after several attempts to contact existing maintainer. Bump to version 1.36 and remove obsoleted patches. Also add support for net-misc/iwd backend. Also process tmpfiles. Closes: https://bugs.gentoo.org/642682 Closes: https://bugs.gentoo.org/657696 Package-Manager: Portage-2.3.48, Repoman-2.3.10
Diffstat (limited to 'net-misc/connman')
-rw-r--r--net-misc/connman/Manifest1
-rw-r--r--net-misc/connman/connman-1.36.ebuild94
-rw-r--r--net-misc/connman/metadata.xml5
3 files changed, 100 insertions, 0 deletions
diff --git a/net-misc/connman/Manifest b/net-misc/connman/Manifest
index afe972092cfb..95fc6fc9097d 100644
--- a/net-misc/connman/Manifest
+++ b/net-misc/connman/Manifest
@@ -2,3 +2,4 @@ DIST connman-1.29.tar.xz 653324 BLAKE2B 16c09339f84eff5c4977d0c7b71e5a757cf8bdef
DIST connman-1.33.tar.xz 669800 BLAKE2B 5500b9a318bc0484d9647e5e27fa2da6d59d9238cba26564940979f27e339648f72700f6f78ded719ce08e8d2353bd361388baedb353301519363c4f14227544 SHA512 5670124d2e17ffde4bd5fb878198843b712a31f5840e8523e8247373c8547619e32a4d6dda9cf993eebd5c65bdd256cfc570708a79da1d10f969662b5b750566
DIST connman-1.34.tar.xz 684992 BLAKE2B 48912ed7e52f1e696189240fc0d8cecec596cdb247683cd80c236a5757846d337d6d171dd1707acbb8414e09d4168212e614238136138c89acede6fc77c3a406 SHA512 732669648936630ae5895cba8bcccc69757ab594bc31ee8e4925b0e402d190939891fac61136f3f086ce708b8d576136f0947914c0cc07427c170cbf9b85a308
DIST connman-1.35.tar.xz 686092 BLAKE2B 706d8333dc2fcbee8d0ef3849325c4975dfe312a7a542ee96859a1724e05b1302c244a0108ab70033b398301c235fb13cb9509e9147dc2bb049e900f3799cd98 SHA512 2234b4d18b038f9a33939035cddebd31c74ce962e5616c2c30b2912476612ef3f7d5b9edca64bf6e69fa358252ed432124e036ac3516b291b86695cb9a96c6a8
+DIST connman-1.36.tar.xz 692616 BLAKE2B 7d8cea55365fbfe78cd897b5b65d8edf475a737220732c46c95dda4c6b12badddca38150dbedddcc95c29bce486d86fe130a9d65043c6e18ed6b1eba3fe5aec0 SHA512 c0b9e924a28d58539d44c314168ae7aa46dfea8ce9d125198f525a6d6ef95ca77fd0357c4c4c7548b362b9de8e6f85c7915b1a4cf89b65116c4cbc4df75318e1
diff --git a/net-misc/connman/connman-1.36.ebuild b/net-misc/connman/connman-1.36.ebuild
new file mode 100644
index 000000000000..957d31c3b434
--- /dev/null
+++ b/net-misc/connman/connman-1.36.ebuild
@@ -0,0 +1,94 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="6"
+inherit autotools systemd tmpfiles
+
+DESCRIPTION="Provides a daemon for managing internet connections"
+HOMEPAGE="https://01.org/connman"
+SRC_URI="mirror://kernel/linux/network/${PN}/${P}.tar.xz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~x86"
+
+IUSE="${IUSE} bluetooth debug doc examples +ethernet iptables iwd l2tp nftables"
+IUSE="${IUSE} ofono openvpn openconnect pptp policykit tools vpnc wifi wispr networkmanager"
+
+REQUIRED_USE="|| ( iptables nftables )"
+RDEPEND=">=dev-libs/glib-2.16
+ >=sys-apps/dbus-1.2.24
+ iptables? ( >=net-firewall/iptables-1.4.8 )
+ bluetooth? ( net-wireless/bluez )
+ iwd? ( net-wireless/iwd )
+ l2tp? ( net-dialup/xl2tpd )
+ nftables? (
+ >=net-libs/libnftnl-1.0.4:0=
+ >=net-libs/libmnl-1.0.0:0= )
+ ofono? ( net-misc/ofono )
+ openconnect? ( net-vpn/openconnect )
+ openvpn? ( net-vpn/openvpn )
+ policykit? ( sys-auth/polkit )
+ pptp? ( net-dialup/pptpclient )
+ vpnc? ( net-vpn/vpnc )
+ wifi? ( >=net-wireless/wpa_supplicant-2.0[dbus] )
+ wispr? ( net-libs/gnutls )"
+
+DEPEND="${RDEPEND}
+ >=sys-kernel/linux-headers-2.6.39
+ virtual/pkgconfig"
+
+PATCHES=(
+ "${FILESDIR}/${PN}-1.33-polkit-configure-check-fix.patch"
+)
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+src_configure() {
+ econf \
+ --localstatedir=/var \
+ --with-systemdunitdir=$(systemd_get_systemunitdir) \
+ --with-tmpfilesdir="${EPREFIX}"/usr/lib/tmpfiles.d \
+ --enable-client \
+ --enable-datafiles \
+ --enable-loopback=builtin \
+ $(use_enable examples test) \
+ $(use_enable ethernet ethernet builtin) \
+ $(use_enable wifi wifi builtin) \
+ $(use_enable iwd) \
+ $(use_enable bluetooth bluetooth builtin) \
+ $(use_enable l2tp l2tp builtin) \
+ $(use_enable ofono ofono builtin) \
+ $(use_enable openconnect openconnect builtin) \
+ $(use_enable openvpn openvpn builtin) \
+ $(use_enable policykit polkit builtin) \
+ $(use_enable pptp pptp builtin) \
+ $(use_enable vpnc vpnc builtin) \
+ $(use_enable wispr wispr builtin) \
+ $(use_enable debug) \
+ $(use_enable tools) \
+ $(use_enable networkmanager nmcompat) \
+ --with-firewall=$(usex iptables "iptables" "nftables" ) \
+ --disable-iospm \
+ --disable-hh2serial-gps
+}
+
+src_install() {
+ default
+ dobin client/connmanctl
+
+ if use doc; then
+ dodoc doc/*.txt
+ fi
+ keepdir /usr/lib/${PN}/scripts
+ keepdir /var/lib/${PN}
+ newinitd "${FILESDIR}"/${PN}.initd2 ${PN}
+ newconfd "${FILESDIR}"/${PN}.confd ${PN}
+}
+
+pkg_postinst() {
+ tmpfiles_process /usr/lib/tmpfiles.d/connman_resolvconf.conf
+}
diff --git a/net-misc/connman/metadata.xml b/net-misc/connman/metadata.xml
index a4bbe92fa34b..9bf64dff4d86 100644
--- a/net-misc/connman/metadata.xml
+++ b/net-misc/connman/metadata.xml
@@ -5,8 +5,13 @@
<email>dlan@gentoo.org</email>
<name>Yixun Lan</name>
</maintainer>
+ <maintainer type="person">
+ <email>bkohler@gentoo.org</email>
+ <name>Ben Kohler</name>
+ </maintainer>
<use>
<flag name="ethernet">Enable ethernet support.</flag>
+ <flag name="iwd">Enable wifi support via net-wireless/iwd</flag>
<flag name="l2tp">Use <pkg>net-dialup/xl2tpd</pkg> for L2TP VPN support.</flag>
<flag name="iptables">Use <pkg>net-firewall/iptables</pkg> as firewall.</flag>
<flag name="nftables">Use <pkg>net-firewall/nftables</pkg> as firewall.</flag>