summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2022-11-07 05:15:04 +0000
committerSam James <sam@gentoo.org>2022-11-07 05:15:04 +0000
commit37258e9a9e3b5144df49a70e29c5fe11c9cd0898 (patch)
tree5540a3ae145f7ba5c79389fa998ee950a682d059 /net-misc/curl
parentnet-im/mattermost-desktop-bin: fix python path (diff)
downloadgentoo-37258e9a9e3b5144df49a70e29c5fe11c9cd0898.tar.gz
gentoo-37258e9a9e3b5144df49a70e29c5fe11c9cd0898.tar.bz2
gentoo-37258e9a9e3b5144df49a70e29c5fe11c9cd0898.zip
net-misc/curl: fix USE=-ssl build
Closes: https://bugs.gentoo.org/878751 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'net-misc/curl')
-rw-r--r--net-misc/curl/curl-7.86.0-r1.ebuild4
1 files changed, 3 insertions, 1 deletions
diff --git a/net-misc/curl/curl-7.86.0-r1.ebuild b/net-misc/curl/curl-7.86.0-r1.ebuild
index 5ab554508bc4..cbce0c5d0c97 100644
--- a/net-misc/curl/curl-7.86.0-r1.ebuild
+++ b/net-misc/curl/curl-7.86.0-r1.ebuild
@@ -112,10 +112,11 @@ multilib_src_configure() {
# TODO: in the future, we may want to add wolfssl (https://www.wolfssl.com/)
local myconf=()
- myconf+=( --without-gnutls --without-mbedtls --without-nss --without-ssl )
myconf+=( --without-ca-fallback --with-ca-bundle="${EPREFIX}"/etc/ssl/certs/ca-certificates.crt )
#myconf+=( --without-default-ssl-backend )
if use ssl ; then
+ myconf+=( -without-gnutls --without-mbedtls --without-nss )
+
if use gnutls || use curl_ssl_gnutls; then
einfo "SSL provided by gnutls"
myconf+=( --with-gnutls --with-nettle )
@@ -150,6 +151,7 @@ multilib_src_configure() {
fi
else
+ myconf+=( --without-ssl )
einfo "SSL disabled"
fi