summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergey Popov <pinkbyte@gentoo.org>2020-07-08 17:45:28 +0300
committerSergey Popov <pinkbyte@gentoo.org>2020-07-08 17:46:09 +0300
commit31b0ec1ff5de7dddb1c2291e64290c2a82c9b2ab (patch)
tree1da83b470ed0080ca2fc8dce2683b5aca5479471 /net-misc/dhcdrop
parentapp-text/foliate: bump to 2.4.2 (diff)
downloadgentoo-31b0ec1ff5de7dddb1c2291e64290c2a82c9b2ab.tar.gz
gentoo-31b0ec1ff5de7dddb1c2291e64290c2a82c9b2ab.tar.bz2
gentoo-31b0ec1ff5de7dddb1c2291e64290c2a82c9b2ab.zip
net-misc/dhcdrop: revision bump
Bump EAPI to 7 Fix building with clang Closes: https://bugs.gentoo.org/731694 Package-Manager: Portage-2.3.99, Repoman-2.3.22 Signed-off-by: Sergey Popov <pinkbyte@gentoo.org>
Diffstat (limited to 'net-misc/dhcdrop')
-rw-r--r--net-misc/dhcdrop/dhcdrop-0.5-r1.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/net-misc/dhcdrop/dhcdrop-0.5-r1.ebuild b/net-misc/dhcdrop/dhcdrop-0.5-r1.ebuild
new file mode 100644
index 000000000000..5757f718f4d5
--- /dev/null
+++ b/net-misc/dhcdrop/dhcdrop-0.5-r1.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DESCRIPTION="Effectively suppresses illegal DHCP servers on the LAN"
+HOMEPAGE="http://www.netpatch.ru/dhcdrop.html"
+SRC_URI="http://www.netpatch.ru/projects/${PN}/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~mips ~x86"
+
+IUSE="static"
+
+RDEPEND="!static? ( net-libs/libpcap )"
+DEPEND="static? ( net-libs/libpcap[static-libs] )
+ ${RDEPEND}"
+
+DOCS=( AUTHORS ChangeLog INSTALL NEWS README )
+
+src_prepare() {
+ # Fix building with clang, bug #731694
+ sed -i \
+ -e '/^PACKAGE_/s/"//g' \
+ configure || die
+
+ eapply_user
+}
+
+src_configure() {
+ econf $(use static && echo "--enable-static-build")
+}